Behringer X-Touch One channel/banking issue

I have a brand new X-Touch One control surface (the model that has a single motorized fader), it’s working in Mackie mode and everything works great EXCEPT the channel/banking management …

Here’s what I observe:

  • When selecting in Ardour one of the first 8 tracks, the fader moves to the correct position and LCD screen correctly displays the name of the track.
  • When selecting a track in Ardour beyond the 8th, the fader drops to infinity and LCD goes blank (That I can understand as the default config is based on a bank size of 8 channels)
  • Being on the 1st track (and it’s correctly reflected on the fader position and LCD) and pressing the channel increase button, the fader drops to infinity, LCD goes blank.

Basically, I can’t navigate the strips using the Bank/Channel buttons …
image

Question: Does it work properly for people that have other control surfaces with a single fader ? (i.e. Faderport)
Question: Any suggestion how to debug ? Capturing the MIDI (sysex ?) data ?

As a side note, I used to own the X-Touch Compact (that has 8+1 faders) and the channel/banking switching worked fine. (I got rid of that control surface because it was really unpractical not having the LCD displays per strip … you never know what strip you’re actually touching :frowning: )

The faderport has it’s own module in Ardour so it would not use the mackie code.

mackie control is all midi notes, cc and ptichbend except for the displays. But the menubar->Window->MIDI Tracer will show all of those. For full testing an external midi tracer is very helpful. On Linux I would use: gmidimonitor for either jack or alsa.

For more help: http://stash.reaper.fm/2063/LogicControl_EN.pdf in chapter 13 you can find the midi messages for everything. Ignore page 106, mackie control doesn’t use that bit. I would grab that manual pretty quick as I first found it on the Logic site but it has been gone from there for a while (Apple doesn’t like people actually knowing anything). then midiboxlc [MIDIbox] had two links to it but they are gone as well. in the end I looked for the file name…
It would also be nice to know what your box does inside. Behringer has sometimes been pretty good about documenting these things. I am not sure if it is company policy or some of the engineers have just been nice.
It has been a long time since I have used mackie control at all. So I don’t know how much more help I can be.

1 Like

Thanks for all the info !
I downloaded the PDF and had a quick look at chapter 13.
I’ll make some tests

Right, I found that after I posted my initial message while looking at the source code …

Well, here are my first findings

Using the Fader Bank buttons seem to emit the expected messages:
image
image

Now using the Channel buttons emit the “Channel Select” messages
image
image

I would have expected it to send the actual Channel change messages ?
image

I’ll look at Ardour’s code but any upfront comment on what Ardour is actually expceting ?

Note that this Control Surface has a “Mackie User” mode where one can change the config of the buttons (I’m using the standard Mackie right now); I’ll check if these buttons can be re-assigned to send the channel left/right messages

Small update
putting the device in MC User mode I was able to change the assignment of the CHANNEL buttons
Initially they were set to <FDR and FDR>
I changed them to <CHN and CHN>

So now, for the 8 first strips, things work pretty well.

  • I can select the strips in Ardour and it will update the LCD/Fader/etc
  • I can navigate left and right with the device’s CHANNEL buttons and it will not only updtae the fader/LCD/etc but il also selects the strip in Ardour

Now, going above the 8th strip:

  • Selecting the strip in Ardour gets the device’s fader to drop to infinity and the LCD to go blank
  • Continuing to navigate with the device’s CHANNEL buttons does select the correct track in Ardour ! but the fader/LCD don’t reflect that selection

Using the BANK button doesn’t seem to get me to switch to the next set of 8 strips …

  • if I’m on strip 1 and press BANK> I would expect the fader to land on strip 9 but the fader drops to infinity and the LCD displays “Select Bank”

Any idea to go further ? I tried to mess with the x-touch-one.device file, declaring larger number of strips but it does weird things …

I must say I’m a bit confused about how a device with a single strip is supposed to behave with a bank width of 8 :thinking:

This sounds like behavior built into the device. Ardour does not contain the string “Select Bank”.

The bank width is a function of information contained the *.device file. The entry:

<Strips value="8"/>

in the X Touch One device file (inside Ardour) is incorrect.

Right, I have of course tried to change it to 1 but it’s even less functional. Where above I can navigate the first 8 strips (selecting them in Ardour or using the CHANNEL buttons), now I can navigate the very first strip and that’s it :slight_smile:
Note that continuing to press the CHANNEL buttons does make the next strip in Ardour selected but it’s like Ardour doesn’t send back the strip info (name, fader, mute/solo) back to the device (or it’s not sending what the device expects)

By the way, the entre

<MasterFader value=“no”/>

is also incorrect. Turning it on makes the Master Fader selection button (and therefore the fader) work fine :slight_smile:

I’ll make a pull request once I have sorted out the rest of the config …