AVL MX and Zoom L-20: Control and Audio Playback - RESOLVED

I think I have successfully got this setup to work one time; however, it’s been a while and today I was wanting to test a direct line-in recording and apply effects, etc to the recording in post.

However, when I turn on my interface (Zoom L-20), then start up my computer and get a new Ardour session created/started, anything I record in Ardour does not come through playback.
Also, I swear when I first got things set up (about a month ago), the sliders on the L-20 controlled sliders in Ardour (volume, at least); however, that is no longer happening. (did I dream this up?)

I am able to record input from the L-20 channels into ardour; however, L-20 volume adjustments do not affect ardour sound detection. I can maximize Master and Channel volume on the L-20; however, the ardour input meter doesn’t change unless I increase the gain on the channel on the L-20.

I followed the article from @stephenharker in regards to Jack setup, making sure PulseAudio does not have the profile “on” for the L-20 ( Zoom L-20 works great in Ardour on Linux - Installation & Configuration / Linux - Ardour); but, I’m not sure what else there is.

@stephenharker , if you see this, do you have any documentation I can look at (links to other posts, etc)?


When you are using any USB Mixer as an Audio interface (that isn’t also a control surface) with a DAW it is normal that the the signal coming into Ardour is controlled ‘pre-fader’ at the channel gain stage of the mixer, that means the sound is coming in from the ‘top’ of your L20 mixer channel before the volume Fader. For this reason moving the faders on your mixer will do nothing to change the input or output volumes in Ardour, that has to be done with Ardour’s Mixer Faders in the software…

Also the Zoom L20 (I just bought one too but haven’t used it with a DAW) is not a control surface that you can map to control Ardours Faders that I know of, it is simply a multichannel USB Audio interface. To use it on Linux it must be in ‘class compliant’ mode.

I will now defer to @stephenharker who has more experience with recording the L20 with Ardour…

1 Like

Hello. Yes what Glen says is correct. There is no control of Ardour possible, that I can see, from the Zoom, it doesn’t transmit MIDI over USB. And the audio levels that the Zoom sends over USB are pre-fader which means only the gain control on each channel has any effect on the level seen by Ardour.

When you say “anything I record in Ardour does not come through playback.” what do you mean exactly? There are 2 stereo channels 19/20 and 21/22 on the Zoom that have a USB button which when enabled should allow you to play back from Ardour. Sorry if I’ve misunderstood the issue…


1 Like

Thanks @GMaq and @stephenharker, I must have been dreaming about the faders controlling Ardour as a MIDI controller. :sweat_smile:

I see what you mean about pre-fader, again, I must have been dreaming it…

Now, what I meant was I couldn’t get any playback (sound) from my recorded track in ardour when I try to play it, whether it’s via “audition” mode or not… I can’t “hear” what I just recorded… I think I read on your article about the playback from ardour onto the SD card, essentially sending signal from pre-fader to ardour (mastering) and back to SD card; or maybe mastered channels directly to card + prefade to ardour for post?

I’ll have to check that USB button on the stereo channels. Does that mean I should be able to hear playback from ardour to the headphone jack on the L-20? ANSWER: YES
I suspect those are only effective if they are correctly mapped in Ardour/Jack?

I must have been expecting to hear playback through the system (computer) speakers/headphones/whatever output is enabled in PulseAudio; but, realistically, proper setup should probably be through quality system speakers, from the board, perhaps? (I bet I’m over-thinking/complicating it.)

Regardless, thanks for pointing me in the right direction, guys!

Update: of course, you were both right!
This morning, I only added 8 tracks to my new Ardour Recording session (instead of all 20 that were available), pressed the USBAudio Return button(s) on the L20 and I could hear playback through the L20 (headphones) while adjusting the 17/18 (USB 1-2) and master faders for playback volume.

I haven’t messed with recording directly to the L20 SD card in addition to Ardour recording; but, experience will set me straight about my initial playback from ardour to write to SD overthinking/hypothesis. (Rhetorical: why would you want to do that? Unless it’s to bounce and dub tracks.)

Thanks again, guys!

1 Like

Glad you got everything working :slight_smile: I guess if you were recording a live performance that included a backing track coming from Ardour, you could record that from USB along with the 16 live instruments all to the SD card at once and all in sync.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.