Audio Assault plugins online registration

Audio Assault Plugins cannot be registered via Mixbus/Ardour. I have to open the plugins in Reaper and register them through that. It’s kind of frustrating. Might be related to this topic as well. (It may be that it applies to all plugins that are activated via the Plugin Gui online)

Is it possible to do something about it? This is the latest version of AvLinux MXE.
I appreciate your help.

As a workaround did you try to register them using their Standalone prog? (in the same archive you got the plugins)

Yes, I tried it and it also works that way, but not all of their plugins have a stanalone version. That’s why I used Reaper.

I had the same problem. Registrering the plugin using Carla didn’t do anything for the plugin in Ardour, however, using the offline registration process worked. It’s still sort of a workaround though.

Ardour modifies some environment variables (I think LD_PRELOAD, possibly LD_LIBRARY_PATH, I can’t remember) is the culprit here - in order for the bundled Ardour binary to work. This appears to stop web browsers opened from within ardour - or from within a plugin loaded into ardour - from functioning correctly. Specifically seems to (quite understandably) regard connections as insecure (that was my experience).
Ardour itself appears to have a workaround in its own code, for launching a browser e.g. to provide for IRC connectivity - but unless a plugin has a similar ardour-specific workaround my guess is you may run into this and similar or related issues.

Can you elaborate what you mean?
I’m not aware of any work-around, except vfork is used (fork is not realtime safe).

Other plugins also use [v]fork just fine to open web-pages just fine e.g. Linux: vfork() is called in openURL() in invalid way · Issue #657 · surge-synthesizer/surge · GitHub

I expect the issue is unrelated to this, particularly since Carla (which process isolates plugins) also has this issue.

Anyway it’s not even clear what plugin format is used (VST3?) what OS, and what platform. So I won’t even speculate.

At least I use AvLinux MXE, where the problem appears. As well as TAL Software plugins are unable to contact their servers. In Windows, both of these work, so it should be clear that the problem is on the Linux.

I don’t know what the correct marching order is to fix it. Will the user make a bug report to the plugin company about this problem that occurs with Ardour/Mixbus. Or do you have a channel between the developers that you can use to handle communication. From the user’s point of view, it is not easy to figure out.

I sent an email to TAL software earlier, but they didn’t know how to help. I’m not connected to Audio Assault yet.

I think it would be useful for Linux audio if these things could be made to work and cooperation would expand to create a better Linux pro audio. Between both open source and closed source code creators


PBD::open_uri (const char* uri)

/* revert all environment settings back to whatever they were when ardour started

	if (global_epa) {
		current_epa.reset (new EnvironmentalProtectionAgency(true)); /* will restore settings when we leave scope */
		global_epa->restore ();


Depends on the default browser too. You can normally open a page just fine, but in some instances it will fail later if you try to open any kind of secure connection (this is kind of vague because the inner workings of web browsers are not my area of expertise at all)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.