AU plugins not found

After installing new AU plugins, most do not appear in Ardour. I drop the component file in audio/plugins/components/, and about 1 in 10 is recognized by ardour and shows up. I can imagine that some freeware plugins are not very compatible, but that many? Is there a way to see why this is? The problem is also for VST plugins, but much less…

Wow, that’s definitely not normal. Can you clear the black-list and Cache in Preferences > Plugins >Audio Units, and then re-scan plugins in Preferences > Plugins?

Then check Menu > Window > Log there may be some more information there.

1 Like

I did try that, but scanning VST plugins takes ages. I stopped it after an hour.

I meant clearing Audio Unit cache/blacklist (not VST), but if you have that many plugins that scanning takes hours. You probably have thousands and 10% success rate does seem more realistic…

Perhaps scanning times out (license checks) or some there is some odd conflicts between plugins when ardour loads the plugins during initial scan?

Can you run auval -a in a terminal? That will discover and list all install audio-unit plugins. Is that reasonably fast?

that worked. all the ones in that list are the ones available in Ardour, but I have .component files in the proper directory that do not show here. Problem perhaps outside of ardour? This evening I will let the scan run fully through. With VST disabled, the scan for new plugins is fairly quick (looking only for AU), when looking for VST`s it takes ages.I don’t have that many, I’m actually setting up my ideal workflow coming from an outdated pro tools LE system. I have found very good plugins, and ardour is working like a charm, it is just a shame that finding plugins is a bit hit and miss. I have to say that the commercial plugins (native instruments) are spotless, only the freeware are missing.

OK, so it seems like this is not an Ardour issus per se. auval is Apples official Audio Unit validation tool, and Logic Pro won’t load AU’s that don’t validate either. I don’t know about ProTools/Mac.

Perhaps check permissions of the folders /Library/Audio/Plug-Ins/Components/*.component

thanks, I’ll do that. any pointers as to how? I am new to Mac, coming from a livelong pc and linux experience

Same way you would on Linux should work fine on Mac.

ls -ltah I believe will list permissions as well IIRC.

   Seablade

I don’t know if you can configure it in ProTools, but Apple’s tools (and Ardour, and Logic Pro, etc) only look in /Library/Audio/Plug-Ins/Components/ and your user’s $HOME/Library/Audio/Plug-Ins/Components/.
Same for other Plugin formats. e.g. VST plugins also must be bundles in the Library/Audio//Plugin-Ins/VST/ folder. and all need to be readable by the user.

It could also be a 32 / 64Bit issue. Most (commercial) plug-ins used to be universal binaries containing both 32 and 64bit compatible versions, so either a 32 or 64Bit host application would automatically ‘just work’ with them. However, support for 32Bit has been more aggressively deprecated in more recent versions of macOS which means you may encounter some incompatibilities.

I don’t think its relevant in this case, but for reference, the ProTools plug-ins folder is normally:

/Library/Application Support/Avid/Audio/Plug-Ins

And I don’t believe its configurable. As far as I am aware ProTools does not load formats such as Audio Unit or VST. Similarly, Logic Pro only loads Audio Units.

AudioUnit plugins are all cataloged, discovered, enumerated and managed using OS-provided facilities. Applications do not contain their own search code, they simply ask the OS for a list of AudioUnit “components”. Consequently, all plugin hosts on macOS use the same OS facilities, the same folder locations and the same folder contents.

Plugin hosts may choose to hide/ignore certain plugins based on their attributes and the context in which they are going to be used.

Then auval would still show them, would it not? Also Ardour lists ignored and blacklisted plugins in the Log Window.

As far as I know, that is for AAX only. Do you know if ProTools has facilities to also get custom AUs from that path?

Yes - exactly. I don’t know why we’re discussing it, since as I said, ProTools doesn’t load other (non-avid) formats.

I think there are 32 and 64Bit versions of auval or it can be configured. I’d have to go and look at some of my build / validation scripts for example, but e.g. when I build Audio Unit plug-ins I run separate 32 and 64Bit validation on my code.

True, well, in theory anyway - but in the case of Logic, it uses auval, to validate the plug-ins and then chooses not to show any which fail (for example you may still be able to find a plug-in in another application such as Reaper).
It may be that in some versions of Logic auval is (locally) contained within the (sandboxed) application bundle. However it is a safe assumption that plug-in locations are standard (and not configurable) which is a good thing.

funny thing is, when using auval -32 -a, I get a lot more plugins. When using auval -a, a different list. Auval -64 -a does not work.

=is it a 64 vs 32 bit thing? I am on Mojave

To me that would imply some kind of 32 / 64Bit issue - the Ardour devs can probably shed more light on how that affects Ardour’s AU plug-in discovery.

Ardour delegates this to MacOS/X. It can load all AU bundles that are supported on the system regardless of architecture. – I have not seen this before, nor do I have an explanation.

Perhaps this is new on Mojave which deprecates 32bit? Testing happens with older systems (10.6, 10.10, and 10.11) and both 32 and 64bit plugins are listed by default. The vast majority of plugins are however universal binaries, multi-arch and so not an issue.