AU Plugin not found (MAC OSX)

Hi there,

Sorry for re-creating an old topic, but it’s been closed :woozy_face:

AU plugins not found

I’ve added 2 AU plugins in the right folder (/Library/Audio/Plug-Ins/Components/), both coming from the same creator. One of them is detected but the other one is not. I’m using Ardour 6.0.0, I’ve cleared Cache/BlackList and reloaded plugins in Window/Preferences/Plugins but it doesn’t not solve my problem.

I’ve tried /Library/Audio/Plug-Ins/Components/*.component in the Terminal, which gives me zsh: permission denied: /Library/Audio/Plug-Ins/Components/zylia-amb-plugin.component, which corresponds to the plugin I’d like to use.

How should I proceed to make this plugin appear in Ardour ?

Thanks for any help :slightly_smiling_face:

First use a Terminal window to run auval to verify that the plugin “works” with Apple’s own verification tool. If you need help doing this, ask - it’s not hard but it’s also not a well documented process.

Wow, that’s a fast response !

auval -a gives me a list in which the “working plugin” is present, but not the other one.

This indicates that the plugin doesn’t work. Out of curiosity what does running file on the .component file give you, like below…

file /Library/Audio/Plug-Ins/Components/PLUGIN.component/Contents/MacOS/PLUGIN

Replacing PLUGIN as appropriate for your plugin obviously.


Simply ends up with (No such file or directory)

I can get a AAX version of the same plugin, is Ardour fine with such format ?

No AAX will not work on Ardour (Or anything other than ProTools) sorry.

The message you got simply means you pointed it to something that doesn’t exist. Some plugins might not be structured quite like I posted, but should be similar so depending you could try to figure out where it is it needs to be pointed if you feel comfortable, but it isn’t a major deal. The short version is that if Apple’s built in tool (auval) doesn’t validate it or find it’s installation, so it probably isn’t an issue with Ardour but rather with the plugin or it’s installation.

The reason I asked you to run the above is I was wondering if you might be trying to run the plugin compiled for the wrong platform or something similar which file would tell us how the plugin was compiled, but it needs to be pointed at the actual compiled object.


Is Ardour limited to AU or I can try with VST format on MacOSX ?

By the way I’m temporarily using a “Free/Demo” version of Ardour, could it explain some plugin troubles ?

AU and LV2 on Mac only at this time. EDIT: Corrected by Robin below!

Nope should be the exact same, but again one of your plugins is working, and one isn’t even being detected by Apple’s (Makers of the AU spec) own detection and validation system (auval) which indicates the problem isn’t really with Ardour for that plugin.


You’re behind the times.
Ardour supports Mac VSTs on MacOS/X since 5.x (November 2016).

MacVST support is enabled by default, but you may to scan plugins manually or enable Preferences > Plugins > VST > Scan for [new] VST Plugins on Application Start

(Note that this applies to VST2. Newer VST3 format is not yet supported by Ardour on any platform.)


Dang it I should have remembered that, now that I think of it I remember seeing that in the preferences, I am just to used to using AU on OS X, but I remember having the discussion about VST support and being happy for it due to cross platform VSTs. Thanks for the correction


Problem solved ! It seemed to come from the plugin itself, as suggested. After reinstallation/rebooting I’ve reloaded plugins and they all work fine.

Thanks anyway for your answers, always good to learn more about Ardour and plugins :wink:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.