Ardour won't start

Hello everyone,

I am just getting started with Ubuntu and sound recording. My problem is a very basic one and I am sorry if this has already been asked several million times before but I cannot launch Arbour.

The program gets as far as the project window but, having located where I want to save the project, when I press “start”, nothing happens.

I have tried (apt-get) updating, fixing and reinstalling the program - all to no avail - and I am now a bit lost.

If anyone could point me in the right direction, I would be much obliged.

The following happens in the terminal when I try to open Ardour:

philip@philip-HP-Notebook:~$ ardour
bind txt domain [gtk2_ardour5] to /opt/ardour/share/locale
Ardour5.12.0 (built using 5.12 and GCC version 5.2.1 20150903)
ardour: [INFO]: Your system is configured to limit Ardour to only 1048576 open files
ardour: [INFO]: Loading system configuration file /opt/ardour/etc/system_config
ardour: [INFO]: Loading user configuration file /home/philip/.config/ardour5/config
ardour: [INFO]: CPU vendor: AuthenticAMD
ardour: [INFO]: CPU brand: AMD E-450 APU with Radeon™ HD Graphics
ardour: [INFO]: Using SSE optimized routines
Cannot xinstall SIGPIPE error handler
ardour: [INFO]: Loading default ui configuration file /opt/ardour/etc/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/philip/.config/ardour5/ui_config
Color shuttle bg not found
ardour: [INFO]: Loading color file /opt/ardour/share/themes/dark-ardour.colors
ardour: [INFO]: Loading ui configuration file /opt/ardour/etc/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /opt/ardour/etc/clearlooks.rc
ALSA: Cannot open device ‘hw:SB,0’: Device or resource busy
ALSA: Cannot open device ‘hw:SB,0’: Device or resource busy
Found nothing along /home/philip/.config/ardour5/templates:/opt/ardour/share/templates
run dialog
Failed to acquire device: ‘Audio1’
Device or resource busy
protocol Wiimote not found
*** Error in `/opt/ardour/bin/ardour-5.12.0’: free(): invalid pointer: 0x00000000016b93ac ***
Aborted (core dumped)
philip@philip-HP-Notebook:~$

Hello all, I had the same problem with Ardour 5.12 not starting (after pressing start Jack) sudo dpkg -P csladspa fiext my issue.
Thank you X42 !
jp

The first problem you have is that your Ubuntu system is not properly configured to allow Ardour to use the audio interface (“soundcard”). This should not cause a crash (that is likely caused by a plugin you have installed on your system, but we can get to that later). But until these messages are fixed:

ALSA: Cannot open device 'hw:SB,0': Device or resource busy ALSA: Cannot open device 'hw:SB,0': Device or resource busy .... Failed to acquire device: 'Audio1'

nothing is going to work. It isn’t to help Ubuntu users with this issue via a web-forum - I suggest you join us on our IRC chat channel and likely somebody will be able to help you out. See the lower left corner of this page or the “Support” tab above for details.

Many thanks, paul! I will try to work out how to configure the soundcard first. I have recently re-installed Mate after trying out another version of Ubuntu. I didn’t have any soundcard issues before so I am surprised it should crop up now. I’ll get back on here if I need help with the crashing after that.

The actual crash however may be due to csladspa plugin, see also https://community.ardour.org/node/15363 and http://tracker.ardour.org/view.php?id=7489
Assuming this is Ubuntu or some debian derivative try sudo dpkg -P csladspa

2 Likes

Hello,
I had the same problem after upgrading Ubuntu Studio from 16.04 to 18.04
sudo dpkg -P csladspa did the trick.

2 Likes

SOLUTION THAT WORKED: Make a backup of the config files (just in case) and delete those config files, restart ardour and should work correctly. THIS WORKED (uninstalling csladspa didn’t work).

In this case the error message will be different than the one from the OP:

And you had an entirely different issue due to corrupt config files, which is likely a local isolated issue.
Have you compared the config files with the one in your backup to determine what caused the issue?