Ardour unable to start, just vanishing [solved]

Hi there,

I just installed Ardour 7.1 (subscriber, pre-built Ardour 7.1).
Installation went just fine, did’nt change anything in the setup, left everything at default.

When I try to start Ardour, I get to the “New Session” dialog, choose my interface and hit “Start”, then for a second I see the application logo and Ardour vanishes.

My system specs are as follows:

Win 10 Pro, 21h1/.2251|ASRock B550 Pro4|AMD RYZEN 3600|32 GB RAM|NVIDIA GeForce 710 fanless|2x27" Full HD screen|250 GB SSD system|1 TB SSD Samples|500 GB SSD projects|2 TB HDD docs & images|ROLAND Octa-Capture|BCR2000|Nektar LX88+|ZeRO SL MkII|Maschine Mikro Mk3|FCB1010|KRK ROKIT 5|

Choosing ASIO4ALL as a driver does work with the same interface?
Changing to my Octa-Capture within the AUDIO/MIDI settings after program launch makes Ardour quit immediately.
So I’m guessing it has to do with my Interface drivers, even though they do work fine with any other music app on my PC (Cubase Pro 12, Reaper, Reason 11, Studio One artist 5.5 etc.).
Something about them that Ardour doesn’t like?


If you have any tips for me, I’m all ears.

TIA,

Ralf

Does Octa-Capture have a more recent driver you could try? Or an older one you could go back to?

Does “buffered I/O” (Utiliser des E/S avec tampon) help?

Is the device used by any other applications ? ASIO only allows one application to use the soundcard at a given time.

Hi John,
The Octa-Capture doesn’t provide neither older nor newer driver.
Roland only provides drivers for Windows 10 via Windows updates.
Rolling back is no option.

Hi Robin,
I’ll try your suggestion.
And no, no other ASIO application open when I try to launch Ardour.
I’m doing the DAW thing since 20 years, even though a slip through can always happen. :thinking:

P.S.: Enabling “Bufferd I/O” seems to help. :blush: :pray:
Ardour starts and lets me play audio and MIDI content. GREAT

That is great to hear!

By default Ardour prefers if the ASIO driver directly calls into Ardour to process audio. This is very efficient, however some drivers do not allow that, and require separation using additional buffers. So far I was only aware of only some M-audio device-drivers requiring this.

1 Like

@x42 : I can’t seem to find a way to edit the topic title to [solved].

By chance do you know if it has to do with the Discord privileges?
As a mod, could you append it for me please?

Thank you very much.