Ardour inputs with pipewire


I’m currently using Ardour 7.3 along with PipeWire 0.3.67.
I seem to be dealing with issue 9069.

I create a new session. Then I import an mp3 audio file in to a track. The created track is automatically assigned all audio inputs on my system (usb audio interface, webcam, …).
Then I’m having trouble deselecting them within the input configuration dialog of the track.

When I add an input track, I can’t assign any input to it.

The best way to make things work as I want is to create the input track prior to importing the audio mp3 file.

I don’t know whether the problem comes from Ardour or Pipewire.


A workaround until it gets solved could be to use qpwgraph to manage the in/outputs.

I did that too. It didn’t seem to work well either.

Does the problem persist if you use ALSA backend directly instead of pipewire? Is this a copy of Ardour from this site?


I had problems with pipewire 0.3.67 in that Ardour wouldn’t exit properly but hanged after “Butler drops pool trash”.
Reverting to 0.3.66 solved the problem, so it’s possible that .67 has some JACK issues.

I did not try alsa because I want to share the audio device with other apps.

Thanks. So, do you think it shall be reported to pipewire?

I just need to bisect pw and see if I can find the offending commit.

It is a good test to determine if the issue is caused by Ardour or Pipewire.

Pipewire is supposed to drop-in replacement for JACK, so it has to behave exactly like jackd does. The general rule is that: If it works without pipewire (via JACK or Ardour’s built-in ALSA backend), then it is a pipewire bug.

Pipewire commit 90b11e3c49, concerning node state handling, causes the hang in my case.
It may be entirely unrelated to your problems but if if ALSA works you could try with 0.3.66 or older versions of pw.

Alright. So I guess I need to turn Pipewire entirely prior to doing the test, right?

Thanks. I think I’m going to try 0.3.66 first. In case it doesn’t work either, I’ll try alsa.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.