Ardour inputs with pipewire (follow-up)


Following my previous post which happens to have been automatically been closed unfortunately Ardour inputs with pipewire, I managed to make some tests at last.
I tried with Alsa and in any case, I don’t understand why imported files as track (via Session → Import) get linked to inputs anyway, since not meant to be recording tracks.

I’m currently back to pulseausio+jack because pipewire 0.3.69 seems to have broken the jackd emulation. I works better like that but I’m still gettig those capture inputs linked to the imported file track.


Pipewire will likely be good when it’s finished, but I don’t think it’s reliable enough for serious pro-audio use right now. Maybe try it again in a few years time, you’ll know when it’s finally working because it will be immediately replaced by something new and broken again :slight_smile:


A self compiled pipewire 0.3.69 in jack mode under Ubuntu 18.04 works fine here. At lest in light testing.
I’m starting Ardour using pw-jack -p 512 /path/to/ardour

The link-capture-ports-to-imported-tracks isn’t a pipewire thing; it’s something Ardour does.
I get the same thing when I import a track under pure jackd.

Why do you think that’s a problem? You’re not exhausting the capture ports by connecting them to tracks and they’re not affecting the tracks unless you arm them for recording.

It is not a problem with ardour but with Guitarix and other amp sims in which my guitar sounds seriously out of tune, whereas I’m not. It works fine back to the real jack.

I’ll wait for the final release.

If your guitarix output is constantly off by a certain amount of cents it’s probably a 48 vs 44.1 kHz thing.
Pipewire is 48 kHz by default; are you running jackd at 44.1?

You can tell pw to run at 44.1 by starting guitarix with something like pw-jack -p 256 -s 44100 /path/to/guitarix

If you’re waiting for the final release of pw you’re likely in for a long wait :slight_smile:
Not even 1.0, if it ever gets to that version number, will be 100% bug free and 100% feature complete.

I didn’t change anything to my setup. Just upgraded it. I’m running everything at 48 kHz, both Pipewire (jack.conf) and Jack.

Here comes 0.3.70 with regression fixes…

The Linux kernel has been around for 32 years and still has regression fixes every now and then.

Nothing in this .70 release seems to be directly related to pitch regressions

  • Fix a regression in the scheduler that could keep some nodes IDLE.
  • Fix a regression in the biquad filters in filter-chain.
  • Fix a regression and potential crash in the ALSA mixer probing.
  • Fix a regression in pipewiresrc with timestamps that could cause cheese to record video with wrong timestamps.

I’ll see if I can find time tonight to check guitarix with 0.3.68, 69 and 70 and see if there actually is something wrong with pw.

Be my guest :slight_smile: I hope you’re not wasting your time.

As I fully expected I did waste my time, because there’s absolutely no difference in pitch when running guitarix under pipewire 0.3.68, 69 or 70.
It’s also the correct pitch.

I’m sorry you did. But you cannot conclude I’m having delusions because we both probably don’t run the same hardware. I can tell you my experience with latest versions was horrible without changing anything to settings.
Hopefull plain jack made things work great again. Why am i looking for trouble anyway? :upside_down_face:

Thanks for your help!

No, I don’t question what you heard but I think the chance that you or your hardware did something strange far outweighs the chance that there was something in pw causing it.

Unless you ran a random git version, which just happened to be buggy, or if the person compiling the release made some mistake.

If you’re happy running jackd then all’s well.

My original question still stands: why are there any audio inputs linked by default to a non-recording audio track created from an imported audio file?

I would presume that Ardour uses the same “create new audio track” code whether it’s creating a new and empty one or a new one with imported audio.

Is this an actual problem for your workflow, other than perhaps being a bit aesthetically ugly?

You can disable this by setting Edit->Preferences->Signal flow->Connect track inputs to “Manual” but then you’ll have to manually connect the inputs even when you’re creating empty tracks.

Initially, the issue was with pipewire. And it still is.
Not with pulseaudio + jack.

I was replying regarding your original question :

Ardour connects inputs to imported audio even under pulse/jackd; it’s not a pipwire thing, it’s an Ardour thing.

I’m running pulse and jack2-1.9.20, no pipewire whatsoever, here and imported the csound-test.wav
As seen the track has automatically been connected to the inputs

And again; is this an actual problem that seriously affects your workflow?
If so you should file a report in the Bug Tracker.

It described the problem there Ardour inputs with pipewire
It works fine with the real jackd.

Importing a track into Ardour and then disconnect it from the inputs works fine here with Ardour 7.3.65 and pipewire 0.3.69

I even added a webcam to my system, to see if a second set of inputs would mess tings up, and while Ardour messed up the connections a bit, due to the webcam input being mono, I had no problem disconnecting them


Have you filed a pipewire bug report ?
Maybe the problem only appears if you have several sound cards announcing “capture_FL/FR”?

And once again : why do you feel the need to disconnect these inputs?
As long as you don’t arm the imported track they won’t affect your work.


The problem has just been fixed in pipewire git.