Ardour for Apple M1/ARM pre-release

Dear Apple users,

initial work to make Ardour available for Apple Silicon has been completed.
A full version (incl. video-tools and plugins) that runs on BigSur on the M1 can be found at:

Basic testing has checked out, but before we commit to it, we’d appreciate wider testing.

If you’re a lucky person who already has received their M1, it would be great if you could check out Ardour, and let us know how things go.

Some notes and hints:

  • The binary is not signed. So you have to drag it to /Applications and right-click (or cmd+click) and select “open”, probably twice to allow to run it.
  • Play with Preferences > General > CPU/DSP Utilization. The M1 only has 4 high-power cores.
  • The ARM vesion will only load native plugins. Rosetta-2 does not bridge Intel VST/AU
4 Likes

As a note, if you ARE on an M1 processor, don’t use Chrome to download the link above, curl works fine, and I believe Safari works, but for some reason Chrome breaks the downloads.

  Seablade
1 Like

Ok correction… just use curl for right now. Not sure why it is failing with other methods yet.

  Seablade

OK. so it seems the file has to appear on the local disk as is it was not downloaded.

Via /Applications/Utilities/Terminal

cd ~/Desktop
curl -O https://community.ardour.org/files/Ardour-6.5.52-arm64.dmg

I have an M1 Mac Mini as of yesterday. I did have to install via Curl (the Safari download unpacked okay, but was ‘corrupted’ when I ran the application).

Ardour seems to runs great on my M1, except that I can’t get the inputs to work. It’s showing 24 inputs available, but I can’t record or see any meter levels change in Ardour. My MOTU 828es/driver may be part of the problem; the “MOTU Discovery” tool says there’s no interface connected, but the OS is showing an 828es connected, and “MOTU Audio Tools” shows me FFT/Scope data when I play into the interface. The system sound dialog says the 828es has no input controls, but Logic Pro allows me to select and record a single input or pair of inputs. I don’t see how to set up multi-channel audio in Logic Pro.

That aside, I copied over an Ardour project directory from my Windows system, and I can play it back and work with it on my Mac mini. It did complain about a missing file that seemed to be mapped to C\users\Dave\Documents\ but when I skipped all missing files it loaded fine. The built in plug-ins seem to work fine, and MIDI input from my keyboard is working. Didn’t see DSP go above 5% but I’m not really stressing it. I’m running with a 512 sample buffer (11.6 ms at 44.1 kHz).

I have to sort out some issues with MOTU before I make any judgements here. I’m really impressed with the M1/ARM pre-release. Thanks Robin, Paul, and all the devs/community members!

Is that universal or just within Ardour?

Could it be that Ardour lacks permissions to access the Inputs?

When launching Ardour for the first time on Catalina there is a popup asking to grant permissions to access the mic or audio inputs.

Perhaps it has to be done manually? @seablade did that work on your system?

Universal. If you want to run x86 plugins, you need to use a x86 host under Rosetta.

You need ARM compiled plugins to run on ARM compiled hosts.

For universal apps you can tell it to run under Rosetta (As universal apps have both x86 and ARM code in the bundle) with a checkbox when you look at the file info for the app.

  Seablade
2 Likes

We found the cause, for some reason the default download is placed into a quarantine.

One can manually remove the attribute:

xattr -rd com.apple.quarantine ~/Downloads/Ardour-6.5.46-arm64.dmg

It’s related to the “downloaded from internet” warning, but for some reason trying to open the app shows “corrupted” on BigSur.

1 Like

Heh honestly I hadn’t checked recording on this machine, it isn’t somewhere I do a lot of recording. I had mainly checked old sessions and my student’s work on it. I don’t 100% remember seeing the popup for microphone access honestly but that could just be because it was a while ago, I wonder if there is a way to force it.

    Seablade

Robin, that seems likely. I don’t see Ardour in the list of apps requesting access, nor do I see how to add it. Does the app have to request access?

1 Like

So more testing needed, and I may be eating my words slightly, as I have my Izotope plugins installed as x86, but the AU versions are showing up in Ardour. Haven’t tested them yet so take with a huge grain of salt, not sure why this is working honestly.

Strangely the VST3 versions don’t have the same behavior. And yes I have confirmed both are x86 through file on the commandline.

Again take with a huge grain of salt as I have no idea how that could work, and goes against everything I have heard so far about the process.

    Seablade

Not usually. It should happen automatically when trying to use the device.

Here there was a popup when I started Ardour for the first time and opening the audio-device (by pressing “Start” in the Audio/MIDI Setup dialog). That was on Catalina/Intel though.

I do not have direct access to a M1, and only remote access to an A14Z dev machine (and that has no built-in mic, nor a soundcard connected).

Ok so short version, I can see the AU, but I cannot use it in any meaningful way. The UI doesn’t load, and won’t enable. So short version is even though you can see it you still can’t use it. This is closer to expected, but still a UX issue to be worked through.

   Seablade

So it is odd… Mixbus (Intel) did request access. Ardour (ARM) did not that I can see.

Not 100% that this isn’t an issue on Apple’s side of things but maybe we have to do something different as well.

   Seablade

I hear that. I don’t remember Ardour requesting that access. I tried dragging the app to trash and reinstalling, but it didn’t prompt for the usual first-time install things (how will you use Ardour, use hardware mixing, etc.) so I’m not sure if Ardour6 was fully deleted.

I also found some links about requesting access to protected resources and how to reset microphone access with tccutil. I tried

% tccutil reset Microphone org.ardour.Ardour6
Successfully reset Microphone approval status for org.ardour.Ardour6

But no change. Ardour didn’t ask for permission, and it still doesn’t appear in the list of apps that want Microphone access.

Could you try with https://community.ardour.org/files/Ardour-6.5.52-arm64.dmg ?

That was updated:

New build seems to have input, asked upon opening for permission to the microphone, and was able to record and play back audio from my MOTU Ultralite AVB using USB Class Compliant connection.

  Seablade
1 Like

Brilliant! Thanks for the fix, Robin. I got the “Ardour would like to access the microphone” request and verified that recording works on my Mac M1 with Motu 828es via USB.

Incidentally, although the M1 isn’t officially supported by MOTU yet, I have been able to connect using Ethernet/AVB to access the web-based setup and control. Using AVB audio was tricky, though; I had one kernel panic and some garbled-sounding attempts as I played around with it. USB seems stable once I set up the interface through the web page.

Thanks for testing. That’s good news. So we’re slowly getting there.

Now if we only could find an easy-to-use way to work around the Gatekeeper for unsigned apps…