Ardour exports flatline WAV file, no playhead movement through file

In Ardour( 6.9.0~ds0-1build1) Intel 64-bit, Linux, play head does not move, or appear at all during export regardless of output file type. Other details;

  1. On export result is a WAV file with a flatline. No sound I could determine.

  2. During export there is no playhead motion, no meters move as would be expected in working export.
    Instead there is a bar graph showing progress over time of the export with message “Exporting session timespan 1 of 1” followed by “Normalizing. 1 of 1…”

Export dialog windows shows message; Warning: some channels are empty

Real time export produces same result (flat line WAV file) just taking longer.

Other info in case relevant:
The project does have audio on a few tracks after END marker. NO midi data is after END marker.

I noticed every time I re-open project the Channel tab
of Export window shows 1 channel and I have to increase it to 2 using the tiny button to the right
of the track number text box.

Also have to select Master and sometime add track 2 (Out -2) to the “Export Bus or Track List”.

None of which helps. Export always races through “Exporting session timespan 1 of 1” followed by “Normalizing. 1 of 1…”,
no playhead movement or meter movement
and output is flat line file which I interpret as ’ no data’.

Wow. Something is really messed up… :frowning:

It is surprising that export works at all in this case. What audio-system do you use (Menu > Window > Audio/MIDI Setup)?

That certainly explains why there is silence.

Does this happen in every session?
Can you test with a simple new session just an audio track (import some wav file), no plugins etc.

That is even more mysterious. Well, maybe. The export settings are saved after a successful export. Perhaps you have changed this at some point and all successive exports failed.

To track things down, please see

  • if this issue is session specific: test with a new simple session
  • or backend specific: try with a different Audio-System, Pulseaudio or ALSA
  • or related to user-config (re/move ~/.config/arodur6 - mv ~/.config/arodur6 ~/.config/arodur6.bak)

Thank you very much for your reply.

Results of your 3 suggestions.

  1. “- : test with a new simple session”
    – New project records and exports fine. Playhead, moves, meters active,etc. Export WAV file
    created & not flatline.

  2. “backend specific: try with a different Audio-System, Pulseaudio or ALSA”
    – System is using ALSA.

  3. “… related to user-config (re/move ~/.config/arodur6 - mv ~/.config/arodur6 ~/.config/arodur6.bak)”
    – Done. Moved original ardour6 config dir but issue remains.
    – Other projects and snapshots (in problem project) continue to export fine.

I should have included this in first post:
The empty export is in the latest snapshot of a project with 6 snapshots.
Earlier snapshots of project export with no issues.

Other projects on same PC all export fine.

The problematic non-exporting snapshot has no other issues I can determine.

“Perhaps you have changed this at some point and all successive exports failed.”
You are probably right. I made a change that somehow trips up this one export.

Next step I plan to compare the non-exporting snapshot to completely different project that exports fine. I’ve done this before but maybe missed something.

Will also look at possible difference in earlier snapshots before this export issue started.

Thanks again.

Post up screenshots of the three tabs in your export dialog for that session?


Hi Seablade. Here are screenshots of Export.
Screen 3 shows this recurring drop of right channel and deselect of Master in the export dialog. I hope this might help find the cause of this empty export.

Correcting Screen 3 manually ( screenshot 4) does not help. Export still creates empty WAV file or any other format I select. No playhead movement during export timer and no audio in resulting exported file.

To repeat, I am able to export earlier snapshots of his project just fine. But this is the only snapshot that matters now. I can play this snapshot into another machine to record and will have to do that when
I can no longer delay creating the WAV and MP3 files.

This behavior of Screen 3 sometimes dropping the right channel, showing 1 channel and de-selecting Master Bus I hope might shed some light on whats causing this.

I compared settings with other projects that export fine and found no differences. Am still checking though.

Thank you.

Is it possible you do not have anything routed to the master bus? Still would think transport would move, but that would create an empty file. Is the file length the correct time/length?


Yes the exported file is 4 min. long matching the ‘start’ and ‘end’ markers.

Since I can hear a mix and watch the master meters moving (before exporting) the master bus must be carrying signal (?). I can pan tracks to left and right during recording/playback.

I opened the exported WAV file and it is not stereo. Just one track of pure noise. Not a hint of anything that’s recorded.
So the fact that I edit the Export Channels tab to show Channels:2 instead of 1
& add Out-2 under the ‘Export Bus or Track’ listbox does not help. it does not fool Ardour into
actually play & export.

I re-exported an earlier snapshot in this project just to remind myself that those snapshots export fine. Comparing settings in earlier snapshot does not show any differences but I
am still looking for error in some setting.

I tried realtime export with all variations of selected tracks to be output on Out-1 and Out-2.
Generated a stereo WAV file of noise.

For some reason its still sometimes necessary to edit that Export Channels tab to add channel 2.

Somehow the criteria for starting that playback correctly are not met. The playhead does not move only the progress bar graph indicates something happening but whatever it is it doesnt involve actually exporting sound.

Well before we get to far in bug reports I suppose one question is needed, can you make a backup copy of your session, and then open it in up to date A7 from this website, and see if the problem persists?


What has changed since? Have you added some plugins? Any significant different between the snapshot that exports and the one that does not?

I’m trying to remember if there were any specific issues with Ardour 6.9.0 that could explain it, while my memory does not go that far back, I don’t recall anything close to what you describe.

1 Like

Similar here, this exact behavior I don’t remember seeing.


Thank you both. I copied the project onto another machine with is identical in hardware and OS and created a new instance on it.
The new instance has the same problem of export.All other functionality appears OK. Just like on the source machine.
If I thought it might be worth a shot I would try to look at code to determine what is preventing that playhead from moving. If either of you think this is worth a shot let me know. WIll download the code and try it anyway.

I have to install Ardour 7 very soon and will give feedback on results with export problem.
All attempts to get export to work have failed.

  • Removed tracks and plugins, leaving only a midi drum, without WAV files or plugins in any track.

Result: fast export with no playhead movement and resulting flatline WAV.

Yes I have added plugins but removing them does not cause Export function to create a WAV
file and move playhead as in a normal export.

If I make a template out of this problem project and record a single midi track and WAV file they will export to an empty WAV file. (that is a failed export)
If I make a template of a previous version that exports fine, it will also export fine with a midi track and wav file.

So two things i am just realizing we didn’t cover earlier:

  1. What distro are you using?
  2. Where did you get the version of Ardour from, this website or your distro?

While you seem to have a problem that is specific to that session/state of session, it could be caused by a different issue so I am curious on #1 and #2 in that case. Just in case you are using a distro compiled/provided version when you do test with A7, please test with a version from this website, even the free version, to see if there is a difference.


Distro is Ubuntu Studio 22.04.
Ardour version 6.9.0, came with distrol.
Subsequent Ardour 6.9 projects on this machine show no export problem.
Have not had a chance to look at XML files. Maybe there is some incorrect value related to this snapshop. I tried a look at the C++ code to see how the export might start without actually moving the playhead. Maybe wishful thinking that I"ll spot something.
What about the XML files? Something tied to this snapshot maybe. Have not had a chance to dig into those yet.

I will install A7 from the website that you suggest and let you know.
Thank you.

Can you upload the session, so we can have a look?

I guess it’s too large to be attached to a ticket at, so please zip up the whole session folder and put it on google-drive, onedrive, or someplace similar.

If you cannot share it publicly please email to Thanks.

I tested with Ardour 7.1 with this cmd:
sudo add-apt-repository ppa:ubuntustudio-ppa/ardour-backports
sudo apt upgrade

I will next try Ardour 7.1 from Ardour site like I was asked to.

But with above, using Ardour 7.1 the strange unchecking of Master bus with only I channel re-appears as shown in #3 screenshot above.
I’ve gone through all the comparing all the settings between a snapshot that works and the problem one.
I’ve removed plug-ins.
Still possible I overlooked something so will check again and
get the Ardour site v7 download to try.

Because you got A7 from Ubuntu, make sure when you test with the package from this site that you run it directly by giving the full path to the binary (Located in /opt)