Ardour cannot create Session?


#1

So I’ve just installed Ardour 3 [full version], and started up my Jack server using Qjackctl.

When I start up Ardour, I can create a new session, but whenever i type in a name and click on ‘open’, it just kind of crashes, giving me an error saying it could not create the session and this log file:

[INFO]: LV2: Discovering 0 plugins [INFO]: Loading menus from /opt/Ardour-3.2-dbg/etc/ardour.menus [INFO]: Loaded mixer bindings from /opt/Ardour-3.2-dbg/etc/mixer.bindings [ERROR]: JACK: Cannot create thread res = 1 [ERROR]: JACK: Cannot use real-time scheduling (RR/5)(1: Die Operation ist nicht erlaubt) [ERROR]: JACK: JackClient::AcquireSelfRealTime error

I’m new to the whole audio scene, and i’m still not quite sure what jack actually does or why I’m getting weird interferences on my mic, but I don’t think this is the problem here, right?

I’m also getting a message informing me of Ardour not being able to free up enough RAM, but I also don’t think that’s the point.

Can anybody help me here?


#2

@drmccoy20: http://jackaudio.org/faq


#3

I’m getting the same error


#4

That’s exactly the error I get too.

And paul, revering to the FAQ didn’t help me at all. If there is something useful in there and I am not seeing it, please be a little more specific.


#5

Well, I figured it out, the page of the FAQ paul was revering to was: http://jackaudio.org/linux_rt_config

The only thing i had to do was rename:
etc/security/limits.d/audio.conf.disabled
into:
etc/security/limits.d/audio.conf


#6

Hi People Need help!
I also have the same failure output! I already tried the steps on http://jackaudio.org/linux_rt_config and changed the limits.conf in the way described. Still i have the same failure! Please help because I wanna do a recording session, with this beloved cool DAW.
MY system: Opensuse 13.1 64 bit


#7

if you cant start jack with realtime your not part of the audio group. theres plenty of info on how to add users to the audio group. google is your friend


#8

Thanks alot but i am already in the audio group … i also did the how to add audio to rtprio 99 and memlock unlimited to he limits.conf but it didn´t help :wink: So, that is all i could find on google, it seems, that there is still something missing to get realtime permission … So some other suggestions would be helpful! Thx


#9

i made the workaround like it is said on http://jackaudio.org/linux_rt_config.
benji@linux-hy7i:~> groups
users audio rtkit realtime


#10

Okay interestingly i installed the old version of Ardour (2.8.13), which is working without problems (Still there comes a message, saying, that Ardour does not have unlimited permission to the memory, but everything seems to work fine). So i guess there is some bug in the Ardour 3.5.74 version, which is preventing Ardour to start, still it is the same failure message as given by drmccoy20. Some ideas?


#11

what distro are you using, and are you using a low latency or Real time kernel?


#12

I´m using Opensuse 13.1 and Kernel 3.11.6-4-desktop …


#13

Then maybe its your kernel thats stopping ardour from starting,

All i can suggest apart from getting a low latency kernel is to start jack first and then start ardour. Maybe ardour 3 is set to start jack with realtime option.

Open up qjackctrl and uncheck realtime, though i suggest tryuing to get a realtime kernel otherwise you wont be able to run with lower latencys.


#14

Interesting … Actually starting jackd without Realtime did work. Strange because in Ardour2 i never encountered any compareable problem – sofar everything worked fine, also with realtime! Any workarounds or suggestions?

Thanks veda_sticks!


#15

I forgot to mention, that there is just one strange thing too: When i start jack with realtime support, then ardour3 does not work. So it is just working with jack without realtime! Might this be because of the kernel? Or is it a ardou3 problem?


#16

See the FAQ at http://jackaudio.org/faq specifically the section on Linux realtime configuration.


#17

Now I too have this problem – I’m using Ardour 3.5.308~dfsg-1 from the Ubuntu repo in Ubuntu 14.04.

FACTS:
-The realtime configuration is correct, I’ve quadruple-checked it. Not up for discussion.
-It does not work, either, when I start JACK and Ardour as root. Same error.
-libcgroup is not installed
-…and every other software works correctly – I just tested Yoshimi and jack_rack. Only Ardour doesn’t work. (I should have done this before…)
-This is the same setup that was working well a week ago, the only difference is that I updated it to Ubuntu 14.04

So it is definitely a configuration or packaging problem related to Ardour and not a general problem of the system.


#18

I have not seen this problem… However, have you guys considered using jack in dbus mode… It does mean starting jack with a different method… (I use ladishd and the associated tools… but from looking about if you are running the kxstudio tools, either in arch or kxstudio/ubuntu itself then there are even nicer tools. - If I were on an ubuntu variant, I’d be looking at sticking with the LTS versions…


#19

We’re already using jackdbus.


#20

Unless there is a specific need to upgrade (unlikely) stick with Ubuntu LTS versions (specifically in this case 12.04 LTS)
from the Ubuntu site: “…It has continuous hardware support improvements as well as guaranteed security and support updates until April 2017…”

I’ve found that lots of things tend to get broken in between LTS releases.