Ardour and Video

I installed all the necessary dependencies for Ardour to import Video and it does so successfully and shows my audio tracks imported. That is great.

  1. However, I cannot see the video.
    If I go to View → Video Monitor then it is all blacked out.
    Why cant I see the video during playback and only have the audio files for playback, and more importantly, why is it blacked out ?

Any way to get the video displayed as this will help me a lot as Video processing software has horrible audio manipulation. I master video in Davinci Resolve, and then do the audio in Mixbus or Ardour, but it would be nice to see the video also.

  1. Does Ardour, have high quality rendering to place the audio back into the Video replacing only the original audio tracks, but keep the Video data unaltered.
    This will save me the step of having to import the audio back into Resolve.

Using Linux MX21

Either you have not installed the video monitor software (harvid, xjadeo) or you have not imported a video file via Session > Open Video.

Ardour binary from Download Ardour | Ardour Community has all the tools setup out of the box. If you use a distro version, please ask the distro maintainers.

Yes, Session > Export > Video takes the original video file, leaves the video as-is and only muxes the new audio-track into the file (using ffmpeg).

1 Like

Thanks Robin.
harvid, xjadeo and ffmpeg is installed as spelled out in the manual.
Still the video options are just blank.
I used
sh -c “$(curl -s -L”
as in the manual and all installed.
Any idea why it still wont work or what tests I can do ?

Otherwise excellent that it leaves the Video processing alone.

  1. Start Ardour from the command line/Terminal

  2. After you’ve clicked Session->Open Video and have selected your video file, do you get a Transcoding window where the File Information looks “reasonable”?
    Something like

Check the “Debug mode” box and click OK
Do you get a Transcoding Video window with the light blue bar moving back and forth?

Do you get any ffmpeg error in the terminal window?

1 Like

Here is my output. Seems to be an ffmpeg issue.

$ ardour
Ardour6.9.0~ds0 (built using 6.9.0~ds0-1~mx21~1 and GCC version 10.2.1 20210110)
Ardour: [INFO]: Your system is configured to limit Ardour to 1048576 open files
Ardour: [INFO]: Loading system configuration file /etc/ardour6/system_config
Ardour: [INFO]: Loading user configuration file /home/testuser/.config/ardour6/config
Ardour: [INFO]: CPU vendor: GenuineIntel
Ardour: [INFO]: CPU brand: Intel(R) Celeron(R) N5105 @ 2.00GHz
Ardour: [INFO]: Using SSE optimized routines
Ardour: [INFO]: Loading plugin meta data file /usr/share/ardour6/plugin_metadata/plugin_tags
Ardour: [INFO]: Loading plugin statistics file /home/testuser/.config/ardour6/plugin_metadata/plugin_stats
Ardour: [INFO]: Loading default ui configuration file /etc/ardour6/default_ui_config
Ardour: [INFO]: Loading user ui configuration file /home/testuser/.config/ardour6/ui_config
Ardour: [INFO]: Loading 452 MIDI patches from /usr/share/ardour6/patchfiles
/usr/share/themes/Greybird-dark-mx/gtk-2.0/apps/xfce-panel.rc:7: error: unexpected keyword 'bg', expected string constant
Ardour: [INFO]: Loading color file /usr/share/ardour6/themes/dark-ardour.colors
/usr/share/themes/Greybird-dark-mx/gtk-2.0/apps/xfce-panel.rc:7: error: unexpected keyword 'bg', expected string constant
Ardour: [INFO]: Loading ui configuration file /etc/ardour6/clearlooks.rc
Ardour: [INFO]: Loading bindings from /etc/ardour6/ardour.keys
Loading ui configuration file /etc/ardour6/clearlooks.rc
Found nothing along /home/testuser/.config/ardour6/templates:/usr/share/ardour6/templates
Scanning folders for bundled LV2s: /usr/lib/ardour6/LV2
Set cursor set to default
/usr/bin/ffmpeg_harvid -i /home/testuser/Videos/Lesson-013_2024-03-26 15-56-10.mkv -b:v 10000k -s 1920x1080 -y -vcodec mjpeg -an -intra -g 1 /home/testuser/Untitled-2024-04-04-05-29-53/interchange/Untitled-2024-04-04-05-29-53/videofiles/Lesson-013_2024-03-26 15-56-10.avi 
ffmpeg: 'ffmpeg version 5.0 Copyright (c) 2000-2022 the FFmpeg developers'
ffmpeg: '
  built with gcc 4.9.2 (Debian 4.9.2-10+deb8u2)
  configuration: --enable-gpl --enable-libmp3lame --enable-libx264 --enable-libxvid --enable-libtheora --enable-libvorbis --enable-libspeex --enable-libbluray --enable-libgsm --disable-vaapi --disable-devices --extra-cflags='-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64' --enable-shared --enable-static --prefix=/home/rgareus/local'
ffmpeg: '  libavutil      57. 17.100 / 57. 17.100'
ffmpeg: '  libavcodec     59. 18.100 / 59. 18.100'
ffmpeg: '  libavformat    59. 16.100 / 59. 16.100'
ffmpeg: '  libavdevice    59.  4.100 / 59.  4.100'
ffmpeg: '  libavfilter     8. 24.100 /  8. 24.100'
ffmpeg: '  libswscale      6.  4.100 /  6.  4.100'
ffmpeg: '  libswresample   4.  3.100 /  4.  3.100'
ffmpeg: '  libpostproc    56.  3.100 / 56.  3.100'
ffmpeg: 'Unrecognized option 'intra'.
Error splitting the argument list:'
ffmpeg: 'Option not found'

Ah. So you have installed video-tools for Ardour 8 (new ffmpeg), but still run Ardour 6.9 !

I must have mixed up the manual versions. Is there a way to do this with the current installed version? Problem is that apt will just uninstall the newer Ardour version if I run an upgrade and that is annoying, so I would like to stay with the distro version.

Current Version Ardour 6.9.0~ds0

I initially installed harvid, xjadeo and ffmpeg through apt, but ardour could not find ffmpeg, although I am using ffmpeg with many other applications who does find ffmpeg, so the problem must be with ardour in this case when ffmpeg is installed through apt.

You have two options: Either get recent Ardour 8.4, or install the old video-tools.

You might be able to acquire those from your distro (search for ardour-video-tools package), or use the now 6+ year ancient ones from

PS. binaries from can be installed in parallel to distro versions.

Thanks a lot, I will try that, else I will have to pin ardour in the repos so apt doesnt try to install the older version if I installed the newer version.

I guess the problem was that I did not know that the online manual was not general and that it is seemingly only valid for the latest version.
I will keep that in mind in the future.

Thanks to all who helped.
Got it working.

1 Like

It is the first time I managed to use Video in Ardour.
I am a paying Mixbus32C user so I always debug on Ardour first as it is the
source for Mixbus. Once it works here I will move to Mixbus.

I however encountered a bit of a fatal flaw.
Ardour seemingly defaults to avi and extracts audio incompletely, probably due to the avi default.
If I open an .mkv file that contains a video and 6 mono audio sources, Ardour only extracts the first audio track and then doubles it as stereo, while ignoring 5 other audio tracks. This is not correct as there is therefore no point importing Video\audio into Ardour if this is the case
Why doesnt Ardour natively use .mkv as it is far superior in this regard regarding multi audio source video.
You probably do this for windows compatibility.
It would be nice though to have it use .mkv throughout, so that multiple audio channels can be imported into Ardour from a .mkv file. (I use usually 6 mono audio channels in one .mkv)
Isnt avi sort of REALLY outdated ? None of my professional Video Studio Software uses it (such as Davinci Resolve) as they sure view it as incapable and outdated.
I did not use avi for more than 15 years now, for good reason.

Which version of Ardour are you using?

  • Ardour extracts the audio directly from the .mkv and supports multichannel audio. I am regularly doing that with 5.1 - Ardour8 also comes with a plugin to downmix 5.1 to stereo.

  • avi/mjpeg is only used as proxy for the video-monitor. This is a tradeoff to have fast seek times. Pretty much all other codecs do not support sample-accurate seeking or require CPU power to do so (which introduces a delay every time the playhead locates). – This is entirely unrelated to Audio (the proxy video does not even contain sound), and most other video authoring tools do the same under the hood.

PS. If you use Mixbus. you only get 2 channels. Mixbus does not support multi-channel tracks by design.

What is Mixbus thinking ?
Well that tanks the entire operation then.

I will do it manually then, write a script to extract all audio into separate files and create a proxy video file, and then load the lot individually.

The audio tools in resolve and other high end Video Production Software is really lacking compared what I can do with the audio in Mixbus.

Ardour is not a video editor. Neither is Mixbus. Our requirements for an internal video format are quite different from those of an actual video editor (like Resolve).

Did I ever say that ?, please point me to where I say what you mention above.
I never claimed Ardour or Mixbus is a Video Editor. That is absurd.

Have you ever worked with Resolve and compare audio processing tools with Mixbus/Protools ?
If you did you will quickly learn to do the audio in Mixbus or Protools etc.

You are completely missing the point.

You’re asking why we use avi. We use it for the reasons that Robin outlined, which fundamentally reflect the fact that we’re not a video editor. The internal format we use is defined by our needs as an audio editor, which is at this time different from what we would choose if we were a video editor.

Then since it is an Audio Daw, then why not do the audio correctly and always extract all the audio channels.

Please dont put words in my mouth. That is something that really riles me.
I am not an idiot. I know that Ardour is not a Video editor and NEVEr made that claim- please!

If it does not, then this is a bug. Are you using Ardour 6.9 or 8.4?

I tried the Distro version 6.x and compiled from source from Ardour site. Both have the same problem.
It is not really a relevant issue anymore, as I will just write a script to extract all the audio and then load the audio into mixbus or ardour manually.
It is less hassle than to deal with new installations and since Mixbus cannot import multiple audio tracks in mkv, it is anyway pretty moot for me and a dead end.

I will just do it manually.
Thank you very much for helping me to figure this out.
This solves my problem.

Sadly that will not fix the bug that only stereo tracks are imported.

In case this is file-specific, can you share the multi-channel video file, so that we can try to reproduce this issue? If you cannot share it publicly, could you email it (or a link to the file) to me Thanks in advance.