Ardour 8.6 released

Ardour 8.6 has been released. This is a hotfix release for 8.5, primarily to fix a drawing bug that was not noticed/fixed before 8.5 was released. It also comes with a fix for a crashing bug that can occur when JACK2 is being used.

In all other ways, 8.6 is equivalent to 8.5, but 8.5 should be considered “blacklisted” - we don’t want anyone to have to deal with the drawing issue.

Full release notes (for 8.5 and 8.6) over here as usual.

ADDENDUM: turns out we introduced a bug that ONLY affects macOS Catalina on Intel hardware. The downloads for macOS intel have been updated to include the fix for Catalina. No other changes were made.


It looks like the BBT marker has some problems.

To test I did the following:

  1. new session, just one MIDI region, tempo set to 120
  2. new BBT marker at measure 9
  3. new tempo marker at the (new) measure 8, set to 80
  4. right-click on the preceding tempo, set “ramp to next”
  5. the tempo doesn’t ramp at all (see screenshot)

Notice in red the quarter note=120.000, although the playhead is in the middle of the (allegedly) ramped section.

Also, the blue line in the tempo ruler is doubled after the tempo change.

I can reproduce it:

Any thoughts, other than “avoid BBT markers”? :wink:

bug report posted [0009690: Tempo ramp after BBT marker do not work - MantisBT]

1 Like

With 8.6, I’m having an issue with the grid completely vanishing (at most zoom levels). It started when I was using Grid Mode and persists in any other mode and even after closing Ardour and re-opening the session.

There are barlines only (no beat lines) when zoomed quite a way out, but when zoomed further in (to the kind of degree you’d need for moving the grid around accurately), the grid completely disappears for the bars I’m working on and several bars after.

I’ve just opened the session in 8.4 and again, no grid, as if it’s affected the session file :open_mouth:

Is this related to the drawing bug in 8.5?

ETA: here’s a screenshot of the damaged session file opened in 8.4. The timing of MIDI parts is completely screwed up and there are bars with weird and wonderful extraneous beat lines in addition to the 11 that should be there (it’s in 11/8).

No, this is unrelated.

I have had disappearing grid lines at certain zoom levels since ardour 8.0 and unfortunately have not received a response to my bug report.

Edit: I have to correct myself. I haven’t updated since 8.0 and don’t know if the problem still exists. I only suspect it if others have the problem with the current version.

I’ve been trying to reproduce it but haven’t been totally successful. It seems to be when there’s a second BBT marker on the timeline, moving the grid around and pressing Ctrl+Z to undo that the grid can then disappear, the grid gets double up before the second marker etc, but I couldn’t reliably reproduce it.


I’ve just upgraded v8.2 to v8.6 (Linux Intel/AMD), but when I double click or add a new plugin, the GUI for that plugin does not appear. I can add a plugin, but just can’t configure it.
I tried both with and without Harrison XT plugins and ACE plugin GUIs. I tried to refresh plugins.
I rolled back to v8.2 and it is all working again. Is there something I should configure? I’m guessing it’s a “me” problem, as no one else has queried it.

Is that the official binary, a distro version or a self-compiled?

Could it be that the plugin Window opens behind the main Ardour window?

What Desktop environment do you use? If it’s KDE, perhaps try to enable Ardour Preferences > Appearance > Quirks > All floating windows are dialogs.

Is there a message in Ardour Menu > Window > Log ?
…or if you run Ardour from a Terminal Window, any message printed there?

So far indeed only you and an unknown number of others who have not bothered to report it.


For the sake of clarification does the official 8.6 release have an issue with the BBT markers?

Try to put a tempo ramp after a BBT marker and see if it works.
I am having also other tempo-related minor problems, in the week-end I’ll try to reproduce and report them.

1 Like


Unfortunately I’m not able to work in the Studio right now and have little time for extracurricular testing, I will keep an eye out for your findings and see if any other reports surface… Right now a nightly 8.2.5 is rock solid here…

Thanks for ideas…
It was the official binary from
There were no other windows that opened, even under the main screen.
I’m using Cinnamon (Mint).
Further investigation shows that some UIs do open, but none of the Calf ones. I can edit only with the Generic Controls.

The log does contain errors…

2024-04-17T18:53:27 [WARNING]: LADSPA</usr/lib/ladspa/>: Cannot load module “/usr/lib/ladspa/” (/usr/lib/ladspa/ undefined symbol: __exp_finite)
2024-04-17T18:53:27 [INFO]: Scanning folders for bundled LV2s: /opt/Ardour-8.6.0/lib/LV2
2024-04-17T18:53:28 [WARNING]: LV2 Port 7 (‘CV Input 1’) has no known data type
2024-04-17T18:53:28 [WARNING]: LV2 Port 8 (‘CV Input 2’) has no known data type
2024-04-17T18:53:28 [WARNING]: LV2 Port 9 (‘CV Input 3’) has no known data type
2024-04-17T18:53:28 [WARNING]: LV2 Port 10 (‘CV Input 4’) has no known data type
2024-04-17T18:53:28 [WARNING]: LV2 Port 11 (‘CV Input 5’) has no known data type
2024-04-17T18:53:28 [WARNING]: LV2 Port 12 (‘CV Output 1’) has no known data type
2024-04-17T18:53:28 [WARNING]: LV2 Port 13 (‘CV Output 2’) has no known data type
2024-04-17T18:53:28 [WARNING]: LV2 Port 14 (‘CV Output 3’) has no known data type
2024-04-17T18:53:28 [WARNING]: LV2 Port 15 (‘CV Output 4’) has no known data type
2024-04-17T18:53:28 [WARNING]: LV2 Port 16 (‘CV Output 5’) has no known data type
2024-04-17T18:53:29 [INFO]: xjadeo version: 0.8.13
2024-04-17T18:53:30 [INFO]: harvid version: 901
2024-04-17T18:53:30 [INFO]: Loading menus from /opt/Ardour-8.6.0/etc/ardour.menus
2024-04-17T18:53:32 [INFO]: Removing MIDI patch file custom:DrumGizmo:0x7f477e0f3010
2024-04-17T18:53:32 [ERROR]: MidiTimeAxisView: unknown automation child main-out-volume
2024-04-17T18:53:32 [ERROR]: MidiTimeAxisView: unknown automation child main-out-volume
2024-04-17T18:53:32 [INFO]: Loading user ui scripts file /home/graeme/.config/ardour8/ui_scripts
2024-04-17T18:53:32 [INFO]: Loading plugin order file /home/graeme/.config/ardour8/plugin_metadata/plugin_order
2024-04-17T18:53:32 [INFO]: Loading history from /home/graeme/Music/Ardour/bat-2024-04-14/bat-2024-04-14.history
2024-04-17T18:53:40 [ERROR]: failed to instantiate LV2 GUI
2024-04-17T18:53:40 [ERROR]: failed to instantiate LV2 GUI
2024-04-17T18:53:40 [ERROR]: failed to instantiate LV2 GUI

That is expected. Calf uses GTK2, which has been deprecated, see Ardour 8.4 Calf plugins [ERROR]: failed to instantiate LV2 GUI - #4 by x42

1 Like

Ah, that would explain it. Thanks.
Oh well, I guess it’s good bye to Calf. :frowning:

Hmm… I have installed ardour 8.6 and the calf plugins are working fine. I also have no problems with the gui on ubuntu 22.04.

Not using them anymore but just checked it out of curiosity. The GUI doesn’t work on Debian 12 and Ardour 8.6. It complains about g_task_set_name symbol:

suil error: Unable to open UI library /usr/lib/lv2/calf.lv2/ (/lib/x86_64-linux-gnu/ undefined symbol: g_task_set_name)

The calf-plugins package is installed from Debian repository (0.90.3-4). Maybe other builds will work somehow (for now).

Hmm, strange.

As I said, the calf plugins run normally.

If your distro still supports the nowadays deprecated GTK2 and Ardour is compiled, either by yourself or by the distro folks, to use the system libraries then it’ll work.
The official Ardour binary is compiled to use its own internal version of GTK2 and that clashes with the system libs that your Calf plugins are using.

If your particular Ardour/Calf combination works; good for you.
If it doesn’t and instead breaks you get to keep both pieces :slight_smile:

1 Like

That is debatable - unless you’re wearing a “more distortion” t-shirt. :slight_smile: