Ardour 8.2/8.4 audio setup (pipewire/jack)


I have the flatpak 8.2 install on a Ubuntu 23.10 dist.

Everybody knows the problems with flatpak, it’s not the subject here.

I wanted to try a “normal” install of Ardour, so I get the 8.4 demo, to see if it works before buying/contrib.

But it doesn’t.

With the flatpak 8.2, I have Jack working thru Pipewire (jack is not installed), and it works fine, I see the connections in qpwgraph, I can change whatever I want, and I see both sound cards (my Uphoria UMC204HD and my internal Intel soundcard).

With Ardour 8.4, the Alsa engine works, but it seems to be exclusive to Ardour, no other apps (firefox, etc…) works, the UMC204HD is no longer in qpwgraph or Pavucontrol. Ardour itself doesn’t show in the graph.

I tried to set up Ardour 8.4 to work with Pipewire/jack, as I did with the 8.2 version, but it says that Ardour cannot connect to the audio/midi engine.

I’m a bit disappointed … I’d really like to get rid of this flatpak version.

When you’re using the ALSA backend it hogs the sound card, so you won’t be able to use it with other sound sources simultaneously.
That’s per design.

qpwgraph and pavucontrol are for managing PipeWire and PulseAudio connections respectively, so they won’t be able to see your Ardour->ALSA connection.

Try starting your Ardour 8.4 from the command line and tell it to explicitly use PipeWire’s JACK emulation :
pw-jack -p 512 /opt/Ardour-8.4/bin/ardour

Thanks, It works.

But if someone could explain why it’s not the same with the 8.2 flatpak version … This one I don’t need to launch it from a command line. And I don’t remember doing anything for that; it finds a pseudo jack straight on.

The pw-jack libs are usually installed in a directory that’s not in the linker’s search path

Your pw-jack libs are probably installed in /usr/local/lib/x86_64-linux-gnu/pipewire-0.3/jack/ or /usr/lib/x86_64-linux-gnu/pipewire-0.3/jack/
The fix is to create a /etc/ file with the path to those libs and then run sudo ldconfig
Once that’s done ldconfig -p | grep libjack should say something like (libc6,x86-64) => /usr/local/lib/x86_64-linux-gnu/pipewire-0.3/jack/ (libc6,x86-64) => /usr/local/lib/x86_64-linux-gnu/pipewire-0.3/jack/ (libc6,x86-64) => /usr/local/lib/x86_64-linux-gnu/pipewire-0.3/jack/ (libc6,x86-64) => /usr/local/lib/x86_64-linux-gnu/pipewire-0.3/jack/ (libc6,x86-64) => /usr/local/lib/x86_64-linux-gnu/pipewire-0.3/jack/ (libc6,x86-64) => /usr/local/lib/x86_64-linux-gnu/pipewire-0.3/jack/


This is the result.

~$ ldconfig -p | grep libjack (libc6,x86-64) => /lib/x86_64-linux-gnu/ (libc6) => /lib/i386-linux-gnu/ (libc6,x86-64) => /lib/x86_64-linux-gnu/ (libc6) => /lib/i386-linux-gnu/ (libc6,x86-64) => /lib/x86_64-linux-gnu/ (libc6) => /lib/i386-linux-gnu/

so, no pipewire here…

I suppose I have i386 libs because of wine ? or something like that ? and the others are, as you said in /usr/lib/x86_64-linux-gnu/pipewire-0.3/jack. Those are links to a which are in the same directory. I suppose it is to manage versions ?

So, I created a file 00_pw-jack.conf as you said, and it works fine, when I launch Ardour I see it in qpwgraph, it does not cut the sound of videos, etc. Works fine. I still not understand why there is such a difference between 8.2 and 8.4 (flatpak?) but never mind, I learned something.

After ldconfig, I still have the original jack libs, I suppose I could get rid of those ?

Well, thats a lot of questions, I’m new to Audio Linux, I use it mainly for personal use and for photography (Darktable, Gimp, etc.) for many (20 ?) years now, but audio is a different matter, much more complex as I see. Audio is for recording music with friends, a bunch of old guys playing just for pleasure and we want to keep our sessions with a more “pro” sound if we can. As I’m the only one using Linux (and knowing a little about computers),I got the job.

I’ll take a subscription soon.

I will probably have many other questions later.

Thanks again for the help, it was very clear.

Have a nice day

(From France)

Yeah, the difference isn’t between 8.2 and 8.4 but between the flatpack and the ordinary program.
A flatpack is like a mini distribution in itself and it probably has its own version of the pw-jack libs, that it’s set up to be using.

Uninstalling the original jack libs will probably also uninstall a bunch of other audio programs that depend on them, like plugins, synths and stuff, so you’d better leave them alone.
Those plugins and programs will also find and use the pw libs now, so there’s no harm in keeping the original ones.

Yeah, wine depends on on the 32bit (aka i386) version of jack, so if uninstall libjack:i386 it’ll remove Wine as well.
Note that pw probably only comes in the 64bit version, so you may not be able to use Windows programs and plugins through Wine, at the same time as using pw-jack programs.

Flatpak is NOT the way to go for Audio applications in general… Ardour provides you a fully supported binary of their own without any of these other entanglements for as little as $1, what is the attraction to Flatpak with all it’s extra PITA issues?

Hi Glen,
Yes, Flatpak is not for software like Ardour, but it was a nice way to try it, with some limitations. I do my best to learn and work with Linux for more than 20 years now, but a computer is a tool to do things, you don’t buy a car or a watch just for the pleasure to disassemble it but to go somewhere and to be there in time.
I like learning things, but the goal is to use the tool. And clearly I could not find by myself all the things I asked in forums or find “ready to work” on the net.