Ardour 7.4 released

Ardour 7.4 is now available. This is mostly a bugfix release — several important ones have accumulated since 7.3 — but there is also a sprinkling of new features, notably MIDI subgroup busses.

There has also been a lot of work on features that we had hoped to have ready for 7.4, but will now be officially released in 7.5. The curious may find some of them already, but we’re not ready to announce or document them yet.

One other small change for this release: people interested in just trying Ardour out via our free/demo build will no longer have to wait to get an email containing the link. We’ve decided that after 10 years of asking people for their email address and doing nothing with them, we’ll just stop asking and provide the download link directly.

Please read the full release notes for more details and/or download as usual at


Hooray, thanks for fixing retina rendering on macOS. While 7.3 was perfectly useable, 7.4 ist much easier on the eyes. I really appreciate it – keep up the good work!

1 Like

Is tempo mapping back working?

1 Like

Seems to be although I’ve only done a very quick test.

Thanks very much for the release.

Tempo map still often breaks when opening old sessions. The breakage seems to make more sense than it did, and can be manually fixed, so that’s progress. (Bug reports: 0009324: Tempo map is corrupted when opening old sessions - MantisBT and 0009323: Audio regions and location markers are no longer glued to bars and beats in pre-7 sessions - MantisBT)

I’m hopeful that I’ll find 7.5 to be usable. But 6.9 is still a good bit of kit, so why worry?

Hi Ardour Team, congratulations for this version, Great Work!

A good idea to the next version is to stretch audio to the left, that’s crucial when working with vocals!

Hello Paul,
I hope my question is in the good place …

I use an Ardour 5 version on my Mac with UAD Apollo 8 for 3 months without any problem. Everything works . It s perfect. The problem is that version has the silence interruption mode…
When I try with the version 7 downloaded with my subscription, no sound arrives to Ardour whereas the sound arrives in the Apollo8 (I can observe it with the Apollo console)

I use Jackrouter and its recommandated protocole without résult.

Is there any solution to make the Ardour version 7 work with my Apollo8 or an Ardour version 5 without silence interruption possible?

Thanks a lot and congratulations for your work!
Jerome pinet France

Ardour itself does not know or care about the soundcard, on macOS that is all handled by Coreaudio. So it should work with any soundcard that is supported by the OS.

If you still use JACK, please you check if Ardour7 is actually using it:

Ardour Menu > Window > Audio/MIDI Setup

In general we recommend to not use JACK. Ardour can directly use CoreAudio.

Next check Ardour > Window > Recorder - Are there any inputs shown? and if so, do they show a signal?

Does macOS ask if Ardour7 is allowed to use the inputs? Perhaps macOS > System Settings > Privacy does not allow for that?

PS. Which version of macOS do you use? Jackrouter no longer works since macOS 10.12, and it also no longer exists in recent JACK (since 2020).

Hello Robin

Thank you very much for all those precious informations.

I will check all what you explain to me on my computer and I will say to you if it works!

Thank you so much!


Hello Robin,

I have check in the menu Audio/Midi Set up:
And It doesn’t with Jack or without Jack even when Jack has been deleted from my computer and when It s written that Ardour use Coreaudio.
Moreover, no signal appears or is noticed by Ardour in the menu Recorder.
Finally, nothing is reported Not Allowed in the menu System Setting-> Privacy…

On the other hand, Ardour5 does works without any problem (except silence mode)
I have noticed that when I open Ardour5, I can choose Input= Thunderbolt (for my Apollo8) and Output= Thunderbolt (also for my Apollo8) whereas Ardour7 doesn’t propose me anything at this stage

My computer is a Mac bookpro from 2015 version 11.7.1

Thank you very much Robin!

I’m using 7.4 and have noticed that just recently the delete key won’t delete a selected region until I first enable, then disable recording on the track that contains the region (disable, enable, disable for tracks that are already enabled). If there are several regions I’m trying to delete in a track, this must be done in order to delete each region. I’m trying to figure out if I need to open a bug, or whether there’s something messed up in my settings that has set some legitimate option to create this behavior.

I noticed it as well. Backspace still works, though. It is strange, since delete does show up as the same shortcut as backspace in the shortcuts window.

Maybe a bug report should be filed. (I haven’t done it since I did not know if it was just me.)

I can confirm that too.

Had the same or very similar problem when upgrading to 7.4. I was able to remove a selected region using the backspace only. Deleting user defined shortcuts (~/.config/ardour7/ardour.keys on Linux) did the trick and the Editor/editor-delete action worked as usual, although all user defined bindings must be created again.

Pretty sure the issue can be fixed by altering offending lines in ardour.keys salvaging all user bindings (probably by resolving conflict with Notes/alt-delete in my case) but didn’t care since I have just two shortcuts redefined. Had similar problems many times when upgrading and remove&redefine is my standard procedure in such cases. Never filled the bug but maybe I should.

1 Like

The issue has already been fixed in the nightly build. Just waiting for the next release :slight_smile:

1 Like

Good to know that! :+1: :+1: :+1: :+1: :+1:

After upgrading from official 7.4 to 7.5 the problem remained on my system… Manually deleting the aforementioned one line in ardour.keys solved it now… See:

1 Like