Ardour 7.0 arm64 crashes on Mac Mini M1

Starting a new session, or opening an old one (6.9) cause crash every time on my machine. I tried it with “Safe Mode: Disable all plugins” too, there is no difference. Could you please check it?

Don’t own a mac and not involved on development, but I stumbled on Ardour 7.0 crashes on Mac book air, maybe you’ll find some insight there?

Nothing particularly revealing there. This is likely a system-specific error (i.e. it does not happen on every Mac Mini M1). Will be hard to debug as-is.

Do you have access to our nightly builds (i…e are a subscriber or paid $45 or more for the download) ?

Thank you for the suggestion. I tried to grant ‘Full Disk Access’, but it didn’t help. It seems I have to try the other proposal, the complete update, but it will take more time. (from version 11.7 to 12.6)

No, I have no access to nightly builds. I can use only the free/debug versions from there, but for testing I think it will be enough. I downloaded Ardour-7.0.64-arm64.dmg, but the symptom is the same with it.

It seems upgrading the OS from 11.7 to 12.6 solved the problem.

I wondered about that.

We do build Ardour on Big Sur (11.7) and set flags for the application to work on 11.0 or later.
There are now at least 3 reports that it fails to run on BigSur.

I cannot test this myself, but we did however provide builds long before Monterey was released and it was known to work there. It’s a mystery. The crash report is also seemingly unrelated to any mac compatibility.

Anyway glad to know that it works on 12.6!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.