Ardour 2.3 on Ubuntu Hardy - 100% cpu

The upgrade to Ubuntu Hardy and thus to Ardour 2.3 seems to have broken my system. Simply put: I open an Ardour session and the CPU use jumps to 100% and stays there. It takes something like ten seconds for the program to register when I try to select a different sound file. It will play a session fine, but doing any real editing (let alone trying to run a sequencer at the same time!) causes overload, crashes etc. It doesn’t seem to be anything to do with the plugins - disable or enable, it’s still 100% CPU. The really weird thing is that the programme doesn’t want to close down! It ignores a “Quit” command from the menu - I can “Close” the session and then quit from the next window but - here’s the surprise - check System Monitor and the Ardour session is STILL running, consuming 50% of CPU.

Hardware specs: Celeron 2GHz processor, 768M RAM, running kernel 2.6.24-16-rt.

Any suggestions? I can’t see this anywhere as an already-noted bug.


don’t know what’s the matter there… could you tell us your jackd version?

Also, are you familiar with kernels? Is this a self build kernel, or the -rt kernel from the Ubuntu Studio project?
Can you try another one?


Just note that on Hardy they seem to have automatically enabled dynamic CPU scaling.

You can do a: sudo apt-get install cpufrequtils
and then run: sudo cpufreq-set -g performance
to get the most performance from your CPU (ie: No underclocking it)

You can also uninstall powernowd (I think :P) which will disable the cpu scaling.

It tied me up for a while.

Also while you’re at it, it is a good idea to install the rt kernel in the Ubuntu repos by doing a:
sudo apt-get install linux-rt

You can also install the ubuntustudio metapackages to install lots of audio plugins and applications, should you require: ubuntustudio-video, ubuntustudio-audio, ubuntustudio-graphics, ubuntustudio-audio-plugins


In a long irc conversation last night I discovered 4 things about ubuntu hardy.

  1. As shipped in Hardy, Jack and Ardour are apparently compiled with SSE disabled. SSE is really critical to performance, recompile your jack with --enable-dynsimd. I honestly don’t know how to turn off SSE in ardour, it always comes up with SSE when I compile it myself.

You will see “SSE” on the output of both jack and ardour when they start, if it is enabled.

  1. As shipped in Hardy, the sound drivers all talk to pulseaudio by default. You need to get pulseaudio out of the picture. I’ve seen how to do this for ubuntu fiesty, but not hardy. Google for pulseaudio jack fiesty.

  2. Compiz is enabled in Hardy. While pretty, it’s hard on the cpu and the bus.

  3. irqbalance is not installed by default.

When I load jack (From the ubuntu repo) I see:
Enhanced3DNow! detected
SSE2 detected

Another thing is that (at least for me and one or two others) it appears disabling the “nohz” option of the kernel improves performance at the moment.

Look for something similar to this in /boot/grub/menu.lst:
title Ubuntu hardy, kernel 2.6.24-16-rt
root (hd1,1)
kernel /boot/vmlinuz-2.6.24-16-rt root=UUID=a118dfcd-89d1-4aa7-8be9-85e206edf080 ro quiet splash

And add to the end of the kernel options:

Hopefully that will make some improvements.

Thanks for your help. But I am afraid that I am completely ignorant about how to go about recompiling jack. Plus, the links given about pulseaudio go into great detail about how to turn it on, not turn it off.

It is looking increasingly like the upgrade to Ubuntu Hardy has broken Ubuntu Studio.


I wouldn’t recommend compiling these things by yourself if you aren’t familiar with it. It also has the big disadvantage that you would need to compile every new version, because if you compile things yourself, you obviously don’t get updates via synaptic or alike.

I think one should talk to the ubuntu people. Doloras, are you using ubuntu studio 8.04 or the normal ubuntu 8.04 release with a realtime kernel?

If these are really problems of ubuntu studio, the maintainers should fix these things. Maybe someone using ubuntu studio could hook up with these people?


You could change your /etc/security/limits.conf
@audio - memlock 512000
@audio - memlock unlimited

This is the only improvement to the file I know of.

Which realtime priority are using with qjackctl? It should be displayed under options.


Thanks, Benjamin. I am using Ubuntu Studio 8.04, and I certainly intend to take up the suggestions you guys have raised with the maintainers once I get a few minutes leisure time!

I’m using the “(default)” option for realtime priority in qjackctl. Have you got a better suggestion?

I’ll try removing the memlock point when I get home from work and give a further report.

All right, guys, partial breakthrough - adding the “nohz=off” line to grub means that jackd is not crashing any more - but Ardour still is. Thanks for the recommendation.

Specifically: what I am trying to do is running a sequence from Rosegarden into ZynAddFX software synth and trying to record it on Ardour. Before, trying to run the sequence would instantly bring down jackd’s MIDI module, crashing Rosegarden. Now, Rosegarden stays up and plays the sequence happily - but Ardour won’t record, giving a “your disk system wasn’t fast enough to keep up” error.

So, I feel I’m getting closer to solving the problem here! I know that the “disk system not fast enough” error is quite a common one - can someone give me some tips? If you also had time, you could tell me how to stop the error on startup which tells me that connection to the Mackie control surface failed. I don’t have a Mackie control surface, I never have, I don’t even know what one looks like, but Ardour 2.3 and 2.4 seem upset about this for some reason. :slight_smile:

for the last of your questions go menu->options->sync
and disable the mmc stuff. it should help.
you ll have to do this for every session once, since it is the default setting for some time now and is always turned on an a session creation.


Okay, thank you, everyone. It seems obvious in retrospect that my problem was the recognized big problem with inflated jackd latencies which has been reported by many users of Ubuntu Hardy. When I added the following to limits.conf:

@audio - nice -19”

and unchecked both “unlock memory” and “no memory lock” in qjackctl, and cranked up the Ardour latency REAL high, I finally managed to get sequencing and Ardour working together. Now I just have to figure out why Rosegarden crashes for no reason, and I should be set. :slight_smile:

Thanks for the useful info on cpu scaling. Why on earth would they enable that by default?

Anyway, my audio apps run a lot smoother now on my Hardy box :slight_smile:

Ok, tried as advised (disabling freq scaling) and it seems to make not a lot of difference. I am using the Ubuntu Studio default RT kernel (as I said above, 2.6.24-16-rt), and jack version 0.3.2. I’ll try the generic kernel but I’m not sure it will be any better.

Hmm, I don’t think Using the generic kernel will improve your situation. Seems to be something with your set-up, as I’m not experiencing any of the issues you have. As I’m typing this I’m playing back a Rosegarden midi sequence to QSynth, synced to a Hydrogen drum sequence and an Ardour session containing the vocals with some fx plugins, all without a glitch and CPU at about 15%.

I do have a better spec machine though (AMD X2 4400+ with 1G RAM), but still you should be able to use Ardour normally. Possibly some stuff broke during the upgrade? Is an install from scratch an option? Upgrading from Gutsy to Hardy broke my display, so the method isn’t flawless for sure.

I really don’t want to reinstall my entire system, as my UbuntuStudio is highly customised and I really don’t want to go through doing that again.

Further experiment: opening a new session, the CPU usage only goes from 25-40%. It’s the older sessions, which I recorded in the last version of Ardour in Ubuntu Gutsy, that demand a 80-100% CPU load.


could you post the entire *.project file of an older session that consumes 80-100%cpu somewhere (maybe your own webspace or so, but there should be free spaces around to keep the code for a week or so)?

Maybe we can find out what’s wrong there.


p.s. In linux, there’s no need to reinstall the system, even if major things went wrong - it can always be changed without redoing everything. If people do or recommend so, they don’t know enough about this.

p.s. In linux, there’s no need to reinstall the system, even if major things went wrong - it can always be changed without redoing everything. If people do or recommend so, they don’t know enough about this.

While this is very true, sometimes reinstalling (ans thus reconfiguring) from scratch is easier and quicker than finding the solution for a broken system.

Thanks, Benjamin. I’m not sure what you mean by a .project file - there’s a .ardour file, if that’s what you mean, or do you mean the entire project folder?


Sorry, this was a very bad typo :wink: I meant the .ardour file, you are right.

If you don’t find a place to post it, you could send it to me via e-mail “realhangman (you know what to fill in here)”, I’ll post it on my website and post it here.

I know, but this expires after 24 hours, not so good for a forum conversation and archives.

TomB: true :wink:


Done -