ALSA mode

I can’t run Ardour 4.7 in ALSA mode. Could you please help me?

Thank you Ccaudle and Paul!

Another question.
If I start Ardour under the JACK backend then script “a2jmidid -e &” will not work? Only when I run the QJackCtl first?

ltgr@ltgr-Lenovo-V580c ~ $ jackd -V
jackdmp 1.9.11
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2015 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
jackdmp version 1.9.11 tmpdir /dev/shm protocol 8
ltgr@ltgr-Lenovo-V580c ~ $

Running a2jmidi -e will work no matter how you start JACK. The only question is precisely how you run that: via QJackctl’s setup stuff, via the command line, or some other method. They are all basically identical in terms of functionality.


Related comment, even on systems with JACK1 unless I’m mistaken the built-in implementation of a2jmidid in JACK1 doesn’t (or definitely didn’t at one point) recognize hotplug events, so if you have your session up and running and suddenly inspiration strikes and you plug in your USB MIDI keyboard it will not appear unless you completely shutdown and restart JACK1. If you are using a2jmidid externally as a daemon it will recognize new hotplugged devices as you add them. Just sayin’…

The version of Jack1 in git does handle hotplug. Once the next Jack1 is released, it will Just Work ™.

I do not see “Other”

Perhaps Paul means “Ardour Misc”.
Misc is another word for “Other”

Maybe I do not understand because I’m not a programmer.
I tab all that is possible and software (qtklick) do not start(

In midi connections window:
when using alsa backend, my nanoKontrol2 (as well as a usb midi device) is listed under “system”.
when using jack w/midi bridge its listed under “other >> a2j”.

Sorry, I meant listed under “Hardware >> System >> nanoKontrol2” when using alsa backend.

“Other” covers things that are NOT hardware or Ardour itself.

It will not show up if you use the ALSA backend. It does show up if you use the JACK backend. Under the ALSA backend, all ALSA-supported MIDI endpoints will show as “Hardware”.

Sorry, I wasn’t clear. I was just trying to give khomkovm some idea of where his/her midi device might be found in midi connection window based on whichever backend is in use.
But thanks for clarifying. Good to know.

I’ve started Ardour under the JACK backend and gtklick work very well but now I dont see my midi controller nowhere.

Oddly enough but interfaces of QJacktl and Qtractor for me turned out to be more understandable.
While I do not understand how to use Ardour fully I will use them.

Have you started the alsa 2 midi bridge ?
Your alsa midi devices may not be exposed without the bridge running.

a2jmidid -e
in a terminal while jackd is running.

No I do not started a2jmidid.
I will try Thanks.

ahellquist, thank you.
Everything works as I wanted.
Except for one error after stopping the JACK:
ERROR: a2j_destroy: Cannot close jack client (-1)
Bridge stopped
ltgr@ltgr-Lenovo-V580c ~ $

Now every time I need to run a2jmidid in terminal apart from Ardour that all worked?

If you are using qjackctl you can set a script to run when jackd is started. In the setup dialog there is a tab called Options with entries for scripts to run when jackd is started (same time), after jackd is started, when jackd is stopped, and after jackd is stopped.
In the after jackd is started script entry, put “a2jmidid -e &” . The “&” character makes a2jmidid run in the background, without that qjackctl will hang at that point after a2jmidid is started.
In the execute script on shutdown line put “killall a2jmidid” to kill the a2jmidid process when jackd is being stopped.

And if you are using Jack1 (instead of Jack2), then the functionality of a2jmidi is builtin (and slightly more efficient). But most distributions supply Jack2 instead (sometimes making Jack1 available an alternative).

On the other hand, if you use the ALSA backend, you don’t need a2jmidid either …