Zynfusion Ardour midi

Hi to all! I am running Ardour 6 on Manjaro with Alsa and headphones. No usb audio interface. Installed Zynfusion via Octopi aur. Dexed, Surge, Tubefish, everything works fine with Arturia keystep usb midi. But Zynfusion have no sound via usb midi, only via virtual keyboard. Zyn track midi signal is on, but not on master track. Tried a little with Cadence Jack, but no success. Is Jack for Zynfusion mandatory? I have read some forums and suggestions but nothing for me. Help please! Sorry on my bad English.

I see some solution in older post 2019. Someone says: “The wrong channel was selected in part settings.” but with no elaborating. Can someone please explane this? Thnx

It refers to the MIDI channel. By default ZynAddSubFX responds only to events for the 1st MIDI channel. Apparently your keyboard sends Events using another MIDI channel.

As for “part setttings” those are in zyn’s UI. click on it, and then you can activate the voice for a given MIDI channel:
image
(or you can middle-click directly in the main UI)

To find out what your keyboard sends, you could load the “a-MIDI Monitor” plugin (comes with Ardour) and add it before zyn.

To change the channel, see the doc: https://www.arturia.com/support/keystepquickstart

The global MIDI channel can be modified directly on the KeyStep by holding down the Shift button and pushing one of the 16 first keys of the keyboard.

1 Like

O yeah. At last. Thnx! Shift+1! Thnx!