ZynAddSubFX problem

Hi all,

when I open an Ardour project where there are many MIDI tracks, those with the ZynAddSubFX plugin very often reset to the default instrument, so I have to reselect the correct instruments in each track. Now, if I close the project (after saving) and reopen it, the previously selected instruments are lost again.
Maybe there is a way to avoid this?
[Ardour 6.9.0 from repository, Ubuntu 22.04]

Thanks,
a.

Put MIDI event filter from the x42 midi filter collection (x42 MIDI Filter Collection) before Zyn, set it to “Block Program Changes” and your problem may well be solved.

Is this due to a MIDI patch/program-change message?

If so right-click on the track-header and deselect “Restore Patch”.

1 Like

Yes it works, thank you.
At this point I put it before any plugin for security.

Bye,
a.

That’s right, I didn’t realize that “Restore Patch” is selected by default. I will always uncheck it from now on.
Thanks,
a.

Well, usually one wants to restore patch-changes that were sent to the track in the past, so that a given instrument patch/program is restored.

…but it does depend on the synth.

Now the problem with ZynAddSubFX is solved.

Instead I see that the same problem occurs in those MIDI tracks where I put the
ACE Fluid Synth plugin (loading FluidR3_GM.sf2).
I select the “Harp” instrument (right mouse button , “select patch”, “Harp”).
The harp sound is correct. This is the configuration:

So I record the MIDI track playing a MIDI keyboard, and then I save and close the project.

But…when I reopen the project, in that track doesn’t play the harp, but the “Yamaha Grand Piano” appears selected:

So I have to select “harp” again, and again the sound is that of a harp.
But as soon as I close and reopen the Ardour project, the problem returns.

It goes without saying that I applied both of your suggestions:

-uncheck “Restore Patch
-insert “MIDI Event Filter” by selecting “Block Program Changes”.

Thanks in advance for any suggestions.
a.

Recheck restore patch, remove MIDI Event Filter.
That should fix this one. You do want the patch restored here.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.