Zoom R24: Works initially, but not after opening Ardour again


I’ve been spending some time trying to set up Ardour to work with a Zoom R24. It took me a little while to get it up and running, and I’m still having trouble with it. When I start up Ardour and create a new project, it works beautifully. I’ve been using the Recording Session template. I’m able to record music, and I really like being able to control the mixer in Ardour with the R24. I’m impressed with Ardour so far.

My trouble comes in when I try to open a project I’ve previously created. The project opens up fine, and I can still record, but the faders no longer work. The thing on the R24 that does anything on Ardour is the master slider. I still see the the noise levels from the mic that’s hooked up from through the R24.

I’ve tried messing with Jack, Alsa, Mackie Control settings, and even the routing grids, but I can’t find a difference between a new project that works and an existing one that doesn’t. I have no idea where the problem lies, but I suspect it’s somewhere inside Ardour, and not my hardware.

I’m using Ardour-5.12, and in case it matters, I’m using the distro build from Raspbian Buster on a Raspberry Pi 3 Model B. Speed is not an issue (I’m typing this on my Pi.) Ardour runs just fine, except for the hiccup with the R24.

When starting Ardour, I get some warnings. I don’t think they matter because they are there whether its a new project of an existing one.

[WARNING]: ardour-request-device binary was not found..'
[WARNING]: AlsaAudioBackend: adjusted output channel count to match device.
[WARNING]: AlsaAudioBackend: adjusted input channel count to match device.
[INFO]: Loading bindings from /etc/ardour5/ardour.keys
Loading menus from /etc/ardour5/ardour.menus
[INFO]: Loading 88 MIDI patches from /usr/share/ardour5/patchfiles
[INFO]: Loading history from /home/user/Music/project/project.history

Here’s the output of aconnect as well.

$ acconect -o
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
client 20: 'R24' [type=kernel,card=1]
    0 'R24 MIDI 1      '

The first device that shows up there is a part of the Raspberry Pi. Its there whether or not the Zoom R24 is plugged in. Sorry if I should be sending this to the bug tracker, but I’m not sure if this is an Ardour problem or something about my setup. Thanks for any help.

So you when you create a new session everything works, and the issue you’re experiencing is only with a specific session?

Do you mean they have no effect on the signal, or you cannot move them with the mouse?

For former could be because you’ve bypassed it (check if the LED next the the fader processor in the mixer-strip is green) image

If you cannot move it, perhaps it is in automation-play mode? See if automation-mode button below a Fader in the mixer shows “Manual” (or “M”).

A screenshot of the mixer window may help

Sorry if I was unclear earlier. If I open any exiting project that I created earlier, not just a specific one, the track sliders on the Zoom R24 have no effect on the sliders on Ardour. The Master slider on the R24 still works, but that’s the only thing on there that still does. Also, the buttons above the sliders on the Zoom R24 that can toggle Mute/Solo/Record in Ardour stop working as well.

Thanks for the help. I’ll work on getting some screenshots in the next few minutes.

Here’s a screenshot of the main mixer screen:

I also have a screenshot of the audio setup:

The Mackie Control preferences window too:

Let me know if there’s any other information you want.

Well it is an issue I get randomly with my behringer xtouch too with ardour 5.12 on ubuntu studio from time to time, not everytime .

The only workaround for me is to uncheck my mackie controller setup and then turn it on again and then remap the xtouch ports in the mc setup.

I wonder if there is not some mess with the linux midi handle as I encountered the same weird behavior with lmms and a akai midimix, my midi bindings were still there but didnt worked and I had to remap my midi too, that was very annoying esp in lmms where I had to remap every buttons.

Thanks god it is simpler in ardour as i only have to remap only 2 midiports.

I hope this will be better with ardour 6 :wink:

1 Like

Ardour5 with Mackie still has the problem that (mackie) sliders do not have effect until moved beyond the current position of the slider in Ardour. That may be confusing.
I often use a generic MIDI protocol (instead or Mackie) to avoid this.
Ardour6 doesn’t have this problem.

I dont have this problem at home as I use motorized ones, it is just that the link beetween my xtouch and ardour seems broken, as the xtouch receives no feedback, the faders dont iniate nor the displays and lights. Only buttons from the right side of the xtouch works ( transport,loop etc…)

Thank you all for your help. I’ll give Generic MIDI a try, since turning off Mackie and turning it back on didn’t do anything. I’ll post my results later.

I didn’t have any luck with either resetting the Mackie Control protocol and remapping it or with Generic MIDI. The Master slider on my Zoom R24 controlled the master slider on Ardour, but nothing else worked. When I tried Generic MIDI, even that didn’t work. I’m going to see if the Ardour-6.0-rc1 git tag is any different. I’ll report back on my results, but it’ll take me a while. I’ve got to build it all from source.

You could also try with the demo package :wink:

I wish I could use the demo package. Alas, the Raspberry Pi uses an ARM processor, not Intel, and it doesn’t even have enough RAM to compile Ardour. I thought 1 Gigabyte would be enough, but apparently there’s some massive source files inside of Ardour.

I forgot that, sorry.

I will at my side subscribe and try the nightly build asap. I should have done last weekend but I had other financial priorities :frowning: + I want to achieve 3 projects with my 5.12 ardour.

I will tell you when i do this.

There are demo versions available, for RPi.
Scroll down near the end of the linux section of nightly builds and grab the “Linux ARM Free”.

I used the demo package. I had no idea that there was builds for ARM, but thank you guys. Unfortunately, the sliders on the Zoom R24 still don’t work when I’m opening an existing project, even with Ardour 6. I think I’m going to submit this to the bug tracker.

Just curious though, @x42. How do you compile the ARM nightly builds? Do you cross compile them on x86?

Yes, on x86_64, even.

I also did a native compile once, but that took about 2 hours on a recent RPI4b (with 4GB RAM - I had to limit concurrency for the final link stage, since that can take a lot of memory).

While trying I ran into the same problem… I noticed the Mackie was set to Mackie Control Universal Pro. Switching it to Mackie Control made the sliders work again.

Just in case: Did you use the MIDI Tracer window to see if MIDI events come in?

Thank you Sciurius. Setting Mackie to Mackie Control finally made the sliders and other buttons work again for me too. When they weren’t working, there was still events coming in on the MIDI Tracer window. Strangely, on a new project, everything works when it is set to Mackie Control Universal Pro.

Thank you all for your help.

It may be that changing the setting solves it, not the setting itself…

It doesn’t seem like changing the setting solves it. When its not working, changing it to “Mackie Control” makes it work. If I put it back to “Mackie Control Universal Pro” it doesn’t work, even though it does with a new session.

In my case it does, but sometimes not, the I restart ardour and repeat this to get it work.