Zoom operations

I seem to be able to zoom the timeline using ‘-’ and ‘=’ but most of the other zoom operations don’t seem to work for me. For example, selecting a region then pressing ‘ALT+z’ doesn’t zoom to the selected region (the menu option works, but not the shortcut).

Also, how do I invoke ‘mouse zooming’ mode? At various times I’m sure I’ve somehow invoked this by accident but I’ve never been able to reproduce whatever I did.



Thanks Quentin. Somehow I managed to miss your reply.

Anyway… I followed that link and downloaded the bindings for X window. Strangely enough though, it’s only got about half as many entries as my existing file ???

I realised I can invoke mouse-zoom by just typing ‘z’ but I still can’t get those extra shortcuts to work (SHIFT+Z / ALT+z / CTRL+ALT+z etc). In fact, they aren’t even in my bindings file. Is there an extended set of bindings that I need to obtain?

Thanks Paul. Somehow I missed your last post but I looked again and you’re right. With the new bindings file I magically get the missing zoom operations.

Something’s puzzling me though…

A comment in ‘mnemonic-us.bindings’ suggests that it gets processed by scons to produce the user’s actual bindings file. Does that mean that I should have used the data from:- http://ardour.org/files/ardour-2.8.3-bindings-x to replace mnemonic-us.bindings or to replace my personal bindings file? I only replaced my personal bindings file which makes me wonder if it’ll get overwritten, next time I run scons.

the files online are “drop-in” replacements for your own personal bindings file.

these files are always generated from a “template” because the primary and secondary modifiers on X Window and OS X differ. hence, a binding that is intended to be -a has to be Cmd-a on OS X and Ctrl-a on X Window.

scons does not overwrite anything in ~/.ardour*. the task of merging existing personal bindings files with new ones in a new release has long been a source of pain for me and for users and is still not solved yet.

@john: Look at your “existing” file. There are a lot of entries commented out (’;’ at the start of the line).