Zombified jack while using drumgizmo or geonkick

Hello!
Recently i wanted to use some drums plugins with ardour. However I had a problem whit two of them (Drumgizmo and Geonkick). When I add them sometimes ardour crash with message
Failed to register port “Out 12(Geonkick)/audio_in 2”, reason is unknown from here

[1] 20537 segmentation fault (core dumped) ./ardev

other times i get message in messagebox

[1] jack zombified

As I read in other post on this forum It could be probelm with jack settings when these are by choosing audio hardware parameters that your system is incapable of keeping up with but I don’t think that’s a case because I have a new computer (16gb ram, ryzen 7 8x3.7 GHz and GeForce RTX 2060 6GB). Maybe there is parameter that I missed and it’s important? I start jack server by qjackctl. Here are my settings

Maybe someone see any incorrect settings?
As a last resort i tried to compile ardour from source code (on arch linux) but it was the same. I had also the same problem on my previous computer so back then I was sure It’s hardware issue but right know I have no clue. Maybe someone had similar problems or have ideas what could be a problem? I would be very grateful. Thank U in advance sory if it’s something obvious :stuck_out_tongue:

This is the root-cause. When port-registration fails, Ardour will likely crash sooner or later.

Check “Port Maximum” in the “Advanced” Tab of qjackctl’s setup dialog. maybe that is too low.

geonkick by itself can add 32 output ports, Drugizmo adds another 16. Ardour by itself has at least 20 (stereo Master In/out, auditioner, metronome, etc). Things can add up quickly.

If increasing the port-count doesn’t help… Which version of Ardour are you using (Menu > Help > About)? Does it work without JACK (Menu > Window > Audio/MIDI Setup)?

I increased Port Maximum to 1024 and it didn’t changed anything. I tried without jack and it worked well. I was able to make 2 instruyments midi tracks two audio traks and 2xDrumgizmo and 2xGeonkick and while playing DSP never reached 30%. My ardour version infor:

Ardour 6.3.0
“Hybrid”
(rev 6.3)
Intel 64-bit