Yamaha/Seinberg Windows USB Driver snafu

I tried Ardour on Windows but couldn’t get MIDI working with my MODX. It was looking like the only choice was WinMME for MIDI handling. Is that right? It might work if I delete the Yamaha/Steinberg driver I guess. This driver provides 10 audio channels from MODX to the computer, 4 audio channels from computer into the MODX engine, and 2 MIDI ports - one 16 channels to drive the MODX sounds and one 16 channels that are from computer to MIDI out on the MODX. So that’s a lot to give up.

Honestly I constantly have problems sorting out Yamaha’s MIDI implementations. I haven’t tried on Windows, but the Mox8 I have run and some of their consoles on OS X can be confusing at best to get MIDI properly set up on no matter what the software.

I would typically say that you shouldn’t delete the driver, but honestly with Yamaha I have learned never to count anything out. It can be good stuff once you get it figured out, but dang it can be obtuse sometimes.

    Seablade

I thought to suggest deleting the Yamaha/Steinberg driver because of this post:


Glad something worked. The main idea is to get the digital channels Ch3/Ch4 (Digital L & Digital R) to have audio sent there without requiring a DAW installed. VoiceMeeter was the only thing, thus far, I found to do this (in stereo). Windows alone can do this in Mono mode - but you lose spatial separation. And again, Cubase should be able to handle this with proper settings. My DAW machine is in transition, so I can’t run through that. I personally would not use VoiceMeeter on a machine I had a DAW installed due to the extra software stage.

EDIT: I see what the difference is. I installed this on a machine with no Yamaha Steinberg USB driver installed. In this configuration, Montage will attach to Windows using standard drivers. Unlike the Yamaha Steinberg USB drivers - the standard drivers will install the “MONTAGE Line” device with 6 channels. The Yamaha Steinberg “MONTAGE Line” instance will only have two channels. The sound properties look different too.

In both cases, VoiceMeeter needs to be the default Audio Output device. When VoiceMeeter is installed - this is set by default (which is why I didn’t call it out).

I’ve installed the Yamaha Steinberg USB driver and can confirm that selecting the ASIO driver as you’ve outlined is required to get the 6-channel output (from PC to Montage) to “engage” - and the rest of the instructions apply.

The reason I followed this is because I’d think a machine with a DAW would leverage the DAW for Audio routing – and some random machine with youtube assumed no DAW installed - so I also assumed no Yamaha Steinberg USB drivers installed.


which came from https://yamahasynth.com/ask-a-question/use-montage-cubase-to-record-from-internet/?start=20

But this is really counter-intuitive to say the least! I had really just started evaluating Ardour and would really go with a Linux installation, but since the Windows version is available, I had to suss that one out because students will gravitate towards that unfortunately. At this point I would have to judge the Windows version of Ardour to be somewhat unworkable, and it would be really hard to explain that to students.

I will do some more searching for Windows users experiences on forums.

Everything you’ve just cited above and the situation you’re facing is entirely caused by the Yamaha/Steinberg device and drivers. If you were using a different device, none of this would be happening. I say this only to point out that generalizing this to “the Windows version of Ardour” isn’t fair or sensible.

I have to second with @paul said. Everything you quoted above has nothing to do with Ardour, and everything to do with Yamaha and would affect any DAW as a result honestly. As I mentioned I have run into this with Yamaha, and I am someone that has used a variety of their equipment in the past. They are great at making things rock stable, but when it comes to the user experience they are just awful sometimes. I have literally had to download drivers off the Japanese site as the US site didn’t have links to them at times, or I couldn’t find them in english but could in Japanese for some reason, etc. It can just be confusing as all getup.

 Seablade