XRUNs with Behringer XR-18

Hello there.

I’ve bought the XR-18 after reading on several forums that it works perfectly with Linux, but I’m experiencing a lot of XRUNs. I’m running Ubuntu 14.04 with 3.13 Lowlatency Kernel on a Sont Vaio Core I5 with 4GB RAM… I didn’t expect to have these kind of troubles. Version of Ardour is 5.5 I’ll update to the newest version soon, but I don’t think that it could be the cause. I usually start jack using Qjackctl, configuration is: 48k, 2048 frames, 3 periods.

I’ve tried the same configuration using the internal audio card of my laptop and it works fine, but as soon as I switch to the XR, jack reports constant XRUN and Ardour can’t even connect to the server showing me the connection dialog at start.

Any suggestion? Thanks in advance.

@aFunkyBass: Could be your builtin usb ports that might be causing this. Maybe try disabling usb3 support in your BIOS and see if that helps. Also try the XR-18 on another PC and see if it still acts up if that’s available to you. Also be good to see the ‘Messages’ window from qjackctl to see what’s happening when you start jackd using the XR-18.


dsreyes1014 has a good first step there with USB-3 potentially causing problems.

I don’t have the Behringer but in my experience many USB-2 Audio Devices do not run at nearly as low latency settings as internal soundcards and PCI(e) cards with vanilla or ‘lowlatency’ kernels. It is also important that your ‘Periods/Buffer’ are set to 3 instead of 2. I have a system optimized for Audio work and in my case with a USB-2 Presonus 1818VSL the only way to get acceptable latencies without Xruns was to use a full RT Preempt kernel, YMMV.

a side note I just purchased MOTU’s Ultralite AVB and wow it runs well on linux. With 32 channels in/out through usb @96k and jackd setup @96k with 3 periods/buffer not one xrun. DSP was low on it as well. I say this because I’m coming from using a Behringer UMC204 usb interface and I couldn’t go past 44.1k sample rate/frames with occasional xruns. This on the same system. So test that interface on another PC if possible and make sure it’s not the XR-18 after disabling usb3. Behringer products has not been nice to me.

Hi guys, thanks for your replies. Unfortunately there’s no option on my Vaio BIOS to disable USB 3 support, but there is a USB/SATA combo port which should be USB 2.0… I have to confess that I didn’t try that port. @GMaq, thanks for your suggestion. I’m sure I set periods/buffer to 3 and frames to 2048. Since I only need to capture live events with no need for monitoring, I don’t mind latency.

Tomorrow I’ll go at the studio and make new attempts. I’ve also bought a new USB cable (just in case…) :slight_smile:

BTW, maybe XR stands for XRUN?? :smiley: :smiley: :smiley:

Hello there! Good news!! A new high quality cable and using to the USB 2.0/SATA port did the trick!! Yesterday I’ve recorded a 90 minutes concert on 11 tracks with no problem!!

Thank you all for your help.

@aFunkyBass: No problem. That’s good news.