xruns after upgrade


After a major system upgrade I am getting xruns, when moving the mouse.

Question in short: is there an xrun problem known which is related to

  • 32bit / 64bit software
  • linux kernel 2.6.38 / 3.0.0


My environement until now:

ubuntu 11.4 32bit / normal ubuntu-kernel 2.6.38 (no rt, no lowlatency)
Focusrite Saffire 24 pro / FFADO-svn
jack-0.121 (-P70 -t200 -dfirewire -dhw:0 -r44100 -p128 -n4) (rtprio enabled in limits.conf)
ardour2.8.11 as well as ardour3-svn

This setup worked pretty well, xruns every now and then when changing jack connections.

Now I upgraded the system and thus changed to
ubuntu 11.10 64bit / kernel 3.0.0

and xruns coming up when moving the mouse, especially when the mousecursor is on the adrour window. The sound drops even a couple of seconds.

Both ardour2 and ardour3 are affected.

I tried the jackd1, that came with ubuntu, as well as a self compiled jackd1: same symptom. Changing the buffer size from 128 to 256 hides the problem, but I’d prefer solving it, if possible.

Thanks for your help


i get xruns (firewire) with gnome3/shell or unity , but not as many or often with xfce or lxde desktops, but i have a problem with dissconecting jack i have to force quit it and reboot on 11.04 and 11.10 . i suggest you use or dualboot ubuntu 10.04 LTS with the rt kernel or avlinux5.0 .

ubuntu 11.10

Probably has something to do with it - from personal experience, so far I’d have to rate 11.10 as one of the worst Ubuntu releases I’ve ever used. Which is disappointing as up until that point I would recommend ubuntu without hesitation (as a general OS too, not just audio). Unless you really can’t live without random mouse / pointer lockups, CPU freq scaling that gets stuck mysteriously at the lowest level (and cannot easily be changed), inability to add applets to the panel, a new linker which breaks a lot of software builds, pop-up ‘overlay scrollbars’ which randomly fail to appear (or then disappear as you go to move them), a package manager (in Kubuntu) which now crashes inexplicably with some .deb packages, the Ubuntu software centre occasionally failing to start (and sometimes just silently corrupting its database), the new ‘Global Menu’ which (brokenly) attempts to emulate one of the most annoying aspects of any Mac OS, together with inability to focus windows unless you click specifically on the title bar (not just in the window) (sometimes) - then I see no need to upgrade (all of the above and many other problems have happened on my installation of 11.10 at least once, where 10.04LTS has been extremely reliable on the same hardware in every respect)

Hi there!
I am no native english speaker, so accept my errors in expression :wink:

I used Xubuntu 10.04 LTS which is a very good system. My new usb modem is not detected in 10.04 LTS so I updated to 11.10 a week ago and it performs rock solid - it is one of the best Xubuntu releases ever!!!

I prefer a complete new install to an upgrade. You can get a rt-kernel from here https://launchpad.net/~abogani/+archive/ppa?field.series_filter=oneiric (I am using this kernel without any problems).
Jackd2, Ffado et al can be downloaded from here https://launchpad.net/~kxstudio-team/+archive/latest/?field.series_filter=oneiric

I install these because of “dependeny reasons” and afterwards I overwrite them all with my own compilations (I made the experience this gives me a better performing system).

rt-prio can be set in two different files etc/security/limits.conf and etc/security/limits.d/audio.conf - use only one file.
Are you member of all necessary groups (audio, disk, plugdev, …)?

There is a “rtirq-init” script which gives firewire priority to usb, … - I use this one “20111007-1+firewire1~oneiric1”.

Experiment with all the qjackctl settings (frames/period, period/puffer, interface) and ffado settings (clock, synchronisation, …), try a different usb mouse.

Stop all autostarted applications you do not need (Autoupdate, Hardware/Firmware search, network manager! and the **** pulse audio).

I hope it helps but I know how hard it is to find the proper remedy because of so many variables.

Try Xubuntu!

Cheers, Michael

Thanks for your answers!

Some comments:

  • I don't like the idea of a dual boot system, because it is quite an overhead. However AV-Linux may be worth a try.
  • I want to avoid ppa-repositories as far as possible. They have been kind of troublesome on my systems (broken packages, non-resolvable dependencies, etc.).
  • One reason to upgrade was that Ubuntu 11.10 brings all the packages needed to compile ardour3. On 11.4 I needed to install some lv2-stuff (lilv, etc.) manually which is always thinner ice than distribution packages. On my actual system only ffado-svn and ardour3 are self-compiled.

Now I will try AV-Linux, more for curiosity.

Yesterday I’ve been doing some recording and it worked well with -p128 -n4, no xruns while recording. No-one touched the mouse while I’ve been singing :wink: For mixing and hydrogen drum programming I swich to 256 frames/period. So this is an acceptable temporary solution. According to qjackctl the latency is 23.2 ms.

On other strange thing happening since upgrade to ubuntu 11.10: qjackctl blocks all ALSA-devices even, if no jackd is running. This is really annoying. Anything known?




For the record AV Linux comes with all the required dependencies to build Ardour2/3 pre-installed including the newer lv2 libs. It also only uses ALSA and JACK and ffado so avoids some of the complications introduced by other audio servers like Pulseaudio. To be fair if you are comfortable with Ubuntu there is also Dream Studio which is optimized for audio and video and is fully compatible with Ubuntu, it uses the some of the KXStudio PPA’s (you mentioned you don’t love PPA’s) however by all accounts it is a great Ubuntu based OS and actively developed by a fellow Ardour user '‘macinnisrr’

I’m certainly not discouraging you from AV Linux, however it is a very different philosophy from Ubuntu and if that’s what you are used to it may be best to try a different flavour of Ubuntu more focused on what you need before trying something completely different.

AV Linux : http://www.bandshed.net/AVLinux.html
Dream Studio: http://dream.dickmacinnis.com/forum/

@GMaq Thanks for making a " working right out of the box " audio distro .
Thanks Again !!


thanks for your comment.

I now tried AV-Linux and I confess, that I am not really happy with it. First obstacle was, that all my music data is in LVM-volumes. As AV-Linux did not install the LVM-stuff by default I head to figure out which packages I need. No need to blame AV-Linux for that, someone who decides to use LVM should be able to install the needed software on a debian based distribution. So no problem

A big advantage was, that ffado trunk was installed, so no need to compile the ffado-drivers to get my Saffire working.

In the end the whole expedition to AV-Linux failed, as I did not get ardour to work. It started, loaded an existing session, the jack connections required by the session were set up and when clicking the play button, the ardours jack connection dropped. It simply disappeared from the jack client list. I never seen that before and was not in a mood of exploring it further.

My new AV-Linux installation is still on my disk and bootable, so maybe I’ll come back to it some day.

About the PPAs: Yes, I don’t really like PPAs, but that doesn’t mean that I by all means want to avoid them. KXStudio is a candidate, that I’ll might use. Or maybe I’ll just pick some debs from it.

Thanks again.

For the records, Tango-Studio is also a very good alternative, based on Ubuntu 10.04 LTS. Download from here http://tangostudio.tuxfamily.org/

To my experience, every distribution contains some issues you have got to solve!

For the records:

The problem that qjackctl on ubuntu 11.10 blocks alsa devices can be worked around by installing qjackctl from source.

So the most annoying thing is fixed at least.


I have upgraded to Ubuntu 11.10 as well and am now contemplating created a separate partition to dualboot 11.10 and 11.04. On 11.10 I randomly get complete audio dropouts, which don’t even show up as xruns. The audio just stops and starts again. I am using abogani’s lowlatency kernel and this is completely unacceptable for audio work.

FYI: Last week have found a setup which is satisfying:

  • lowlatency kernel by alesio bogani
  • Compiz desktop effects swiched off.

This is working well on ubuntu 11.10 without xrun problems. There are xruns occuring when thereis a high harddisk activity. But this is only occuring when launching a large app. During audio work everything is fine.