XFCE: ALT+Scroll Wheel zooms screen, doesn't adjust track height [solved]


I just switched from ubuntu-desktop to xubuntu-desktop (which, by the way, has greatly improved my performance). Previously, when using “regular” Ubuntu, I was able to adjust individual tracks’ height by using ALT+Scroll Wheel. However, this operation now seems to activate the DE zoom level, rather than adjust the track height. Could it be that I have to set Ardour to override my DE settings? Any help much appreciated. Please see included video for a demonstration of what happens. Many thanks in advance!

Link to video demo

Your desktop environment gets the first chance of responding to keyboard and mouse events. If it “steals” Alt-scroll, then there’s nothing an application can do about that. You will need to alter the settings for the DE if you want this to not happen.

In general, we try to avoid Alt keyboard bindings (especially Alt-Fn) precisely for this reason. But this is the first I’ve heard of Alt-scroll being an issue.

1 Like

Search the web for “xubuntu disable alt+scroll zoom”, you should find:

From the Xfce Menu, choose Settings > Setting Editor. In the Channel pane select ‘xfwm4’ and in the right pane scroll all the way down to ‘zoom_desktop’. Uncheck the Value box.


Thank you! Robin’s solution seems to have done the trick!