[Windows] VST No GUI, black bars and unable to resize

Hi there,
I just bought a subscription to Ardour, keep up the good work.

I’ve been banging my head against a wall trying to make the Kontakt VST work inside Ardour, but it seems to be broken in some ways.

This is what it looks like within Ardour:

I am unable to play sounds, see the GUI, resize the window back down when enlarging it (which only results in black bars appearing instead of the UI scaling properly).

My config:

Build documentation: False
Debuggable build: False
Export all symbols (backtrace): False
Install prefix: /home/ardour/win-stack-w64
Strict compiler flags: []
Internal Shared Libraries: True
Use External Libraries: False
Library exports hidden: True
Free/Demo copy: False

ALSA DBus Reservation: False
Architecture flags: None
Aubio: True
AudioUnits: False
Build target: mingw
Canvas Test UI: False
Beatbox test app: False
CoreAudio: False
CoreAudio 10.5 compat: False
Debug RT allocations: False
Debug Symbols: False
Denormal exceptions: False
FLAC: True
FPU optimization: True
Freedesktop files: False
Libjack linking: weak
Libjack metadata: False
Lua Binding Doc: False
LV2 UI embedding: True
LV2 support: True
LV2 extensions: True
LXVST support: False
Mac VST support: False
OGG: True
Phone home: True
Process thread timing: False
Program name: Ardour
Samplerate: True
PT format: True
PTW32 Semaphore: False
Threaded WaveViews: True
Translation: True
Unit tests: False
Windows VST support: True
Wiimote support: False
Windows key: Mod4><Super

PortAudio Backend: True
CoreAudio/Midi Backend: False
ALSA Backend: False
Dummy backend: True
JACK Backend: True

Builstack: -system-
Mac i386 Architecture: False
Mac ppc Architecture: False

C compiler flags: ['-I/home/ardour/ardour-w64', '-mstackrealign', '-I/home/ardour/win-stack-w64/include', '-DHAVE_RF64_RIFF', '-DPLATFORM_WINDOWS', '-DCOMPILER_MINGW', '-DUSE_CAIRO_IMAGE_SURFACE', '-DWAF_BUILD', '-DNDEBUG', '-fshow-column', '-O3', '-fomit-frame-pointer', '-ffast-math', '-fstrength-reduce', '-pipe', '-DARCH_X86', '-mmmx', '-msse', '-mfpmath=sse', '-DUSE_XMMINTRIN', '-masm=att', '-DBUILD_SSE_OPTIMIZATIONS', '-Wall', '-Wpointer-arith', '-Wcast-qual', '-Wcast-align', '-Wno-unused-parameter', '-DBOOST_SYSTEM_NO_DEPRECATED', '-D_ISOC9X_SOURCE', '-D_LARGEFILE64_SOURCE', '-D_FILE_OFFSET_BITS=64', '-DENABLE_NLS', '-DPROGRAM_NAME="Ardour"', '-DPROGRAM_VERSION="5"', '-Wstrict-prototypes', '-Wmissing-prototypes']
C++ compiler flags: ['-I/home/ardour/ardour-w64', '-mstackrealign', '-I/home/ardour/win-stack-w64/include', '-DHAVE_RF64_RIFF', '-DPLATFORM_WINDOWS', '-DCOMPILER_MINGW', '-DUSE_CAIRO_IMAGE_SURFACE', '-DWAF_BUILD', '-DNDEBUG', '-fshow-column', '-O3', '-fomit-frame-pointer', '-ffast-math', '-fstrength-reduce', '-pipe', '-DARCH_X86', '-mmmx', '-msse', '-mfpmath=sse', '-DUSE_XMMINTRIN', '-masm=att', '-DBUILD_SSE_OPTIMIZATIONS', '-Wall', '-Wpointer-arith', '-Wcast-qual', '-Wcast-align', '-Wno-unused-parameter', '-DBOOST_SYSTEM_NO_DEPRECATED', '-D_ISOC9X_SOURCE', '-D_LARGEFILE64_SOURCE', '-D_FILE_OFFSET_BITS=64', '-DENABLE_NLS', '-DPROGRAM_NAME="Ardour"', '-DPROGRAM_VERSION="5"', '-Woverloaded-virtual', '-Wno-unused-local-typedefs', '-D__STDC_LIMIT_MACROS', '-D__STDC_FORMAT_MACROS', '-DCANVAS_COMPATIBILITY', '-DCANVAS_DEBUG']
Linker flags: ['-Wl,--enable-auto-import', '-L/home/ardour/win-stack-w64/lib', '-Wl,--enable-auto-import', '-L/home/ardour/win-stack-w64/lib']

Thanks in advance, Raphaël.

I can’t comment on the “no sound” issue, but to resize the GUI, use the three striped bars bottom right of the plugin itself (not the container window).

I have tried this before, but (arguably worse) black bars appear, sadly.