window's multicore detection


I use both versions, linux and windows of the last update of Ardour. I record under linux and i mix under windows, because i have betters plugins.
I have an I7 with 16Go ram.

Since the last update, the version windows 5.8, Ardour indicate a false usage of cpu ressources. 100% for Ardour is 35% for windows. I have try many configurations and i allocate all my core but one to Ardour. The affinity and priority is well configured under windows.
There is an easy solution or is it a bug?
I didn’t notice this trouble with previous version. I will re-install it and check in the future.
Thanks in advance for your answer :).

Ardour does not indicate CPU usage, it indicates DSP (Digital Signal Processing) usage. You may want to look over the plugins you are using on your Windows side to find out what is utilising so much DSP, and if they are absolutely required to be used for the entirety of your mixing process, you may want to look into DSP Accelerators or getting a dedicated audio card.

What buffersize are you using? Ardour-Menu > Window > Audio/MIDI setup. try to increase it. 1024 or 2048, that should lower DSP load.

Thanks for your answers.
I use some greedy plugins (like Ozone or some in the wave suite). And my buffer is high enough but ardour configuration is not the same than asio driver. When Ardour indicate me a buffer at 1024, Asio say me 4096. With high buffer, DSP charge is lower but not enough for some heavy sessions.
I use Ableton live too and i don’t reach the dsp limit so soon, with same plugins or more. This is not a hardware trooble, with others DAW or under linux all work fine with more heavy sessions or similars one.
To compare, under Ableton my heavyest session is about 50 tracks (audio and midi), with a lot of synths and audio process (about 150 plugins running) and i touch the 99% dsp charge.
With Ardour i can reach this limit with 4 tracks audio and about 20 plugins for audio processing.

You should not compare the “DSP load” reported across DAWs - it is extremely unlikely to measure the same thing.

I would recommend that, since Ardour can do much more than this on other platforms and/or for other users, that you start with an empty session, start addding tracks and plugins and watch what causes the DSP load to jump. Otherwise, it is pretty hard to offer much advice.

I know Paul. All dsp meter dont mesure same things but i dont have other tools and it just give an idea :). But the difference i see between Ardour and others DAW is my cpu usage. With Ardour i never go above 50%.
I have already try to identify wich plugins cause overcharge. IZotope 5 and S360 Imager have a heavy load. In fact All Ozone 5 plugin are really heavy in Ardour and i avoid it now.

Do you have the GUI (“editor”) for these plugins open when the load is high?

Well, plugin’s Gui amplify the problem, but charge is still high with gui closed. When the dsp meter is closed to 100% in Ardour, my Cpu is around 55%. If i open the Gui of ozone for example, I have some new cracks in the sound (i can ear i’m over the limits) but my cpu dont really go up and is still around 55%.
As you said, all plugins dont cause the same issue. I have no real troubles with Fabtfilter, soundtoy and Slate Digital suites but Ozone and some of the Wave suite are really more heavy than with others DAW.
By the way, the buffer indicated by my Asio driver (the one from the manufacturer (M-audio profire 26)) is alway 4X the buffer indicated by Ardour’ s config is this normal?

Can you be specific about which Waves plugins demonstrate this excessive CPU usage?

Also, you might want to check Edit > Preferences > Audio … Denormal Handling

These are settings that control which (if any) processor features are used to deal with extremely small numbers (as occurs as the tail of a reverb decays, for example). They can make a huge difference to CPU load if they are set incorrectly. Intel processors incur enormous overhead when dealing with these sorts of numbers, and Ardour offers several approaches to improving this. Most other DAWs just use a fixed technique and don’t offer the user a choice.

I done some tests to be more specific.
Ozone Izotope 5 take around 20% dsp load (with eq and dynamic parts active) on master buss. If i add harmonic exciter and maximizer, the charge increase by 10%. It’s the most heavy plugin by himself.
But i realized one thing while testing waves plugins.I maybe made a mistake while diagnosing the problem. In fact, with Puigtec EQP1A when i use even one automation on a parameter, the dsp charge inscrease by 25-35%. I done some others tests with some others plugins with no troubles. I use this plugin a lot so that’s why all my sessions are heavy.

I tryed all possible denormal config with no significant changes.
I miss time yet to do more tests, i will try to find if there are others plugins with this issue in the future.

In all cases, this is the dsp load increasing, not my cpu charge. I done all tests with a buffer of 256, with a buffer at 1024, the dsp load decrease by around 1/3.

..In fact, with Puigtec EQP1A when i use even one automation on a parameter, the dsp charge inscrease by 25-35%...

Other Pultec EQ’s are available… :slight_smile:

(some even run natively on Linux too - as well as Windows and Mac…)

I’m glad to see you are promoting the OvertoneDSP Linux versions again on your web site, after a period of apparently concealing the existence of Linux versions.

Yes mike, i know. I have your eq and dyn 500, fc70 and ptc-2A. They are in my favorite list and i use them a lot under linux. I will use them instead of waves under windows too.