Will linux/ardour work with USB interface

Will this work on Ardour3.
http://www.aliexpress.com/item/Free-Shipping-Guitar-to-USB-Interface-Link-Cable-PC-Laptop-Computer-Recording-Studio-White/680147890.html?s=p

Running latest ubuntu.

Thank you :smiley:

it even works with this one. http://tinyurl.com/m6howsf

@joelwalkingzombie

The question really is, will it work with your OS, in your case Linux. Not something I know the answer to off hand sadly. If i had to guess…

The description mentions a driver for Mac that is required, which usually indicates the device is not class compliant and likely won’t work. However one of the comments mentions that they didn’t use the driver and it just worked, so there is a chance that it is.

My guess is that it would, but that is only a guess, and can’t know without more information or without seeing it, sorry.

  Seablade

Here’s some feedback for you: https://dgtlmoon.com/behringer-guitar-link-ubuntu-linux

Linux will discover it.

I simply did a web search on “Guitar Link 4 Linux.” Maybe you did that already and are still looking for someone who’s done more than simply plug it in and run dmesg??

Thank you guys, I’ve recieved it today and it’s plugged in.
Now I can’t seem to get it running at all, it’s being discovered via terminal but Jack, along with any other program won’t find it.
It also doesn’t output from the speakers either. I’m fairly new to Linux, especially with USB.

I’ve done of all that and had mixed results, I still haven’t gotten any real playback from the guitar but Ardour did pick up a signal a few times, so far I’m having troubles with;

1.Getting a realtime playback through an amp simulator (I’ve tried guitarix and rakarrack)
2. Having jack pick up the USB in the connect window, I’ve looked at various forums already and from what I can see it’s all well and good, all systems and connections, capture, link etc appear right

I installed the .exe drivers that came on the disc through wine and it worked perfectly apart from the horrible delay, I really don’t want to use wine though.
Thank you all for the help! I’ve been so keen to start recording again

I have gotten the sound to work but I’m having problems recording into ardour with rakkarack without xruns. I’m going to say it’s because my computer has a single 3.05 processor and only 2GB of ram.
Also, when I use JACK there is a high pitched ring, is there any way to stop that?
Thanks for the help everyone :slight_smile:

xruns are not related to processor speed or RAM.

This link is explanatory, though not actually helpful: http://www.manual.ardour.org/setting-up-your-system/the-right-computer-system-for-digital-audio/