Now with recent 2.7 (by the way thank you for this release), I no longer can build with wiimote support, although I have libcwiid and have succesfully built it with this option from SVN version before, now it gives me the error

WIIMOTE configured but you are missing libcwiid!

ubuntu Hardy 32 bit



It seems libs/surfaces/wiimote didn’t make it into the official release. Grab it from SVN?


Further to Joe’s question, if you have set a switch in the scons build ie “WIIMOTE=1” and scons doesn’t find the library shouldn’t it halt instead of just rocketing through the configure stage? I tried an SLV2 build earlier this week and had an outdated library, the configure didn’t halt long enough for me to notice…I guess I blinked or scratched my nose or something!

Anyway scons built the target anyway, and didn’t fail until the install. To my way of thinking and experience with compiling other programs if a requested lib isn’t there shouldn’t there be more than a 4 millisecond warning, in fact the configure should halt.

I have also built 2.7 with WIIMOTE=1 and CWiid 0.6.00 and have no Wiimote listed in my control surfaces. Scons shouldn’t just be building it anyway without a clear warning. IMO

Well it didn’t go through all the building or configuring stage, it stopped before it started configuring like if I had done “scons --help”.

It’s just weird I had the wiimote with one of the SVN checkouts, now nothing with 2.7…really strange.


It’s like oden said in the post above, there is no /libs/surfaces/wiimote folder in the 2.7 official tarball. I tried it with 2.7 and although it did do the build in my case even though I used the WIIMOTE=1 switch, there was no Wiimote in the surfaces menu in the finished installed program.

Paul has said Wiimote is “disabled” in the Stable release, that is a little misleading because the libraries are not present at all!

I can however confirm that 2.7SVN 4238 can be built with VST, LV2, FREESOUND, FFT_Analysis and WIIMOTE. I built it this weekend and have all supported plugins working and Wiimote appears in my dropdown list of surfaces.

So I’m afraid you will have to build another SVN Yet Again! By now I’m sure you can do it with your eyes closed. BTW you will also need SLV2 0.6.1 to get LV2 running in case you haven’t already.

Ah! Ok, thx for info GMaq. Yes, SLV2 is up to latest version on my side, just didn’t understand what was going on with the wiimote , will try SVN this week.


So is wiimote disabled again in ardour2? I just downloaded SVN 4504, tried to compile with wiimote and get the error again:

WIIMOTE configured but you are missing libcwiid!

I browsed the code and there is a wiimote folder (/libs/surfaces/wiimote) but just keeps giving me this error… Anything I have to enable in another file inside the source? Or create a symlink to libcwiid somewhere in my system?

Ubuntu Hardy 32


ok, this is an old post, but i wanted to report here, that ardour-2.8.10 compiles and works perfectly with the wiimote enabled!
i just got one of those wiimote controller for cheap on ebay and i am kinda impressed!
now, we can lean back and start a recording! isn’t that great?

thanks for this - such a cool feature!