Why doesn’t ardour or mixbus show GPU activity

Isn’t ardour/mixbus supposed to have hardware graphics accent for the gui, on Mac I noticed it doesn’t have gpu activity unless I open a plugin. I was testing on mixbus but I think it’s the same with ardour as well.

Ardour and Mixbus use 2D graphics. We don’t really care about contemporary GPU performance, because in most sense we don’t use it. In addition, there’s no standard way of measuring or displaying GPU activity.


Does this 2D graphics use GPU or mainly
CPU. I always thought the metering in ardour was GPU powered.

Because the GPU workload is ultra low, and usually you don’t need to care about it.
In 99% cases, the plugin use CPU to do signal process.

Exception: Maybe some plugins will use opencl or cuda to run some deep-learning algorithm

When I saw the option to disable graphics acceleration I just assumed that when it’s not disabled it would use GPU and when it’s disabled it would use more CPU.

I look back in previous ardour/mixbus versions and builds I use to wonder why I had lots of gui issues but I guess it depends on how it’s compiled or whatever.

Would ardour have benefits if it was accelerated?

It’s best to think of this the other way around. By default, Ardour uses a combination of Cairo, GTK and X Window to put stuff on the screen. We expect that this will include some use of “GPU acceleration”, even though we do not explicitly do anything to request it.

If you disable this “acceleration”, Ardour renders several major components of itself entirely on the CPU and then just passes the pixels for display. There are some (older) video adapters where some combination of their hardware and their drivers actually made this CPU-side rendering faster and/or less buggy.

I have two screens. Found one at a 125Hz refresh rate, the other 59Hz.
Reduced the 125Hz to 60Hz and all stuttering and hesitation stopped.
Using the onboard GPU in an ASUS gaming laptop. Hope this helps…

Interesting, thanks for sharing. I will try ardour 7 when I get to it. Ardour 6 on my m1 through Rosetta is very unresponsive.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.