Why do only a few VSTs load on Ardour?

So, I got a few VSTis and VST Effects and only two of them are loading, considering that effects are not loading, only VSTi.
I’m running Ardour 5.0.pre0.280 64x.

see Preferences > Plugins. Configure paths to where plugins are installed.

Enable “verbose scan” to track things down… then also clear the blacklist & cache and re-scan. in Menu > Window > Log there’ll be information about discovered plugins which may help to shed some light.


Sadly when this thread is viewed there is no indication of where it is posted, one of the shortcomings of this forum. So paul I believe, like myself, tends to just skim through the new threads using the forum tracker, and as a result we never see where it is posted to, and thus didn’t know it was in the Windows forum. VSTi and VST effects run on other OSes just fine as well, and are supported in Linux for instance, if compiled for Linux.

Finally repeating that the build is for testing purposes, is sometimes needed as many people just simply do not pay enough attention to start with. Good for you for reading it, but many people don’t and it is necessary to repeat it.

Sadly I don’t have any experience with Ardour on Windows to be able to help you out with your original issue, just wanted to clarify. Although one thing that comes to mind, did you download a 32 bit or 64 bit version of Ardour? And what version of plugins do you have?


Ahh nevermind, I see you downloaded the 64bit (I assume that is what you mean by 64x) in which case are your plugins 32-bit or 64-bit? 64 Bit Ardour will only load 64 bit plugins, and 32 bit Ardour will only load 32 bit plugins for instance.


All my plug-ins are 64bits and I’m using the 64bits version of Ardour, it simply won’t load most of them, just two VSTI, and those two are made by the same company (Native Instruments). Curiously I got a few more VSTi by Native Instruments, but Ardour do only load two of them (Massive and Kontakt). Those two run perfectly, no lagging or crashes, it’s just that Ardour don’t load any other plug-in besides these two.

What platform are you using? What are these VSTs? Windows VSTs ? Linux VSTs? Do you actually mean “VST plugin” or are you using “VST” as a substitute for “plugin” ?

I hope you realize that using the nightly build of Ardour at present is STRICTLY for testing ONLY and we do not guarantee that any sessions you create with it will be openable in the future.

Well since I asked in the Windows topic and said VSTi (as for VST Instrument) and VST Effects, I’m sure you understood the proposal of the message. What you said is the exact same thing as the Ardour’s startup message so I don’t think you really need to say it again, I was only asking a simple question. :confused:

I’d just like to say here that all of my Steinberg, Native Instrument, and other VST’s are working great! Pretty much everything I’ve tried to do just works. I will never give up linux but now I can side-chain to the windows DAW without using Cubase and access all the proprietary VST’s located there.

Sweet Work Ardour Team!


couldn’t find the “Verbose scan” plus My Kontakt plugin still goes to blacklist. Tried everything above.