white writing on white background

I had this trouble in Ardour3 before and it seems to be related to KDE. Anyway: an application for Linux should be usable in any major Linux DE OK? I tried to fiddle with the GTK-Settings in KDE but to no avail.

Now I see, that the problem occures in Plugin-GUIs also. And when I open CALF with its own GUI I do not see the problem. The GUI is perfectly the same as in XFCE or GNOME. But running the very same Plugin in Ardour shows white strings on white background…

So all I would like to do is find a fix for myself(that could maybe help others who run KDE also)
Where can I search?
Is it possible, to hack the XML-Themefile? Is it possible to do something at build?

Any help and hint would be most appreciated.

Let’s be clear: typical KDE configurations (not all) actively sabotage GTK applications that have their own themes. This isn’t necessary. Someone who uses KDE & Ardour can comment on what is necessary. There is no reason whatsoever for KDE to be inteferring in this way.

All I want is to find out, how this interference works and how to fix it. Be it by harden Ardour against it or disabeling KDE to do it.

The older thread, for reference: https://community.ardour.org/node/6133


Thanks a lot!! To delete the .gtkrc-Files fixed it!

Finally I can read the names of imports without selecting them before :wink: