While compiling Ardour-3.0, I'm getting following error!

[root@localhost ardour-3.0]# scons
scons: Reading SConscript files …
Checking for pkg-config version >= 0.8.0… yes
Checking for gthread-2.0… yes
Checking for lrdf… yes
Checking for libgnomecanvas-2.0… yes
Checking for gtk±2.0… yes
Checking for jack… yes
Checking for samplerate… yes
Checking for glib-2.0… yes
Checking for libxml-2.0… yes
Checking for raptor… yes
Checking for fftw3f…no
Checking for fftw3…no
LV2 support is not enabled. Build with ‘scons LV2=1’ to enable.
Congratulations, you have a functioning C++ compiler.
system triple: i686-pc-linux-gnu
Checking for usb_interrupt_write() in C library usb… no
Checking for C header file linux/input.h… yes
Checking for FLAC__seekable_stream_decoder_init() in C++ library FLAC… no
Checking for C++ header file boost/shared_ptr.hpp… yes
Checking for lo_server_new() in C library lo… yes
Checking for dmalloc_shutdown() in C library dmallocth… no
Checking for C header file alsa/asoundlib.h… yes
Checking for C header file jack/midiport.h… yes
Disabled building Tranzport code because libusb could not be found
Checking for internationalization support …
Found xgettext
Found msgmerge
Checking for C header file libintl.h… yes
International version will be built.
Checking for C header file /System/Library/Frameworks/CoreAudio.framework/Versions/A/Headers/CoreAudio.h… no
Checking for C function posix_memalign()… yes
Checking for C header file /System/Library/Frameworks/CoreServices.framework/Headers/CoreServices.h… no
Checking for C function getmntent()… yes
Checking for jack_client_open()…yes
Checking for jack_recompute_total_latencies()…yes
Checking for jack_recompute_total_latency()…yes
Checking for JackVideoFrameOffset in jack_position_bits_t enum…yes
Checking for C header file wordexp.h… yes
Checking for C header file sys/vfs.h… yes
Checking for C header file /System/Library/Frameworks/CoreMIDI.framework/Headers/CoreMIDI.h… no
Checking for C header file /System/Library/Frameworks/AudioToolbox.framework/Headers/ExtendedAudioFile.h… no
Checking for C header file /System/Library/Frameworks/CoreAudio.framework/Headers/CoreAudio.h… no
Checking for C header file /System/Library/Frameworks/AudioUnit.framework/Headers/AudioUnit.h… no
KeyError: ‘fftw3’:
File “/work/ardour-3.0/SConstruct”, line 1337:
SConscript (subdir + ‘/SConscript’)
File “/usr/lib/scons/SCons/Script/SConscript.py”, line 596:
return apply(method, args, kw)
File “/usr/lib/scons/SCons/Script/SConscript.py”, line 533:
return apply(_SConscript, [self.fs,] + files, subst_kw)
File “/usr/lib/scons/SCons/Script/SConscript.py”, line 256:
exec file in call_stack[-1].globals
File “/work/ardour-3.0/libs/ardour/SConscript”, line 307:


KeyError: ’fftw3’ It looks like you don’t have fft.
“New Library Required For Source Builders
Linux users building from source should note that this release sees a new library requirement. Ardour now requires your system to have the amazingly excellent FFT library FFTW3 (“Fastest Fourier Transform in the West”) library installed. You will need both the double precision and single precision versions (typically called fftw3 and fftw3f). Remember that you will need the development versions of these libraries. Some linux distributions put both fftw3 and fftw3f inside the same package, so get the fftw3 first and don’t worry if there doesn’t seem to be an fftw3f equivalent.”

Thanks your reply!
I always installed fftw3-3.1.1-1.el5.rf.i386.rpm on my CentOS5 system.
But I’m still getting that error!
What problem is this?
Please help me!!!

what about the -devel- package of fftw3? As mentioned above, you need that too.
Right at the moment, compiling/running Ardour3 is not for the faint of heart. And back up those sessions before you touch them with your shiny new ardour3 build, in case you get one! (i managed a build yesterday and it fscked up a session made in 2.3.0 earlier, though i’m not complaning, serves me right).

Thanks to your helps I already completed my compiling.
But at this moment, I have a problem, too.
When I create new session, I’m getting follow message!

Ardour could not start JACK.
There are several possible reasons:

  1. You requested audio parameters that are not supported…
  2. JACK is running as another user.

Please consider the possibilities, and perhaps try different parameters.

What problem is that?
Can not open the Ardour without Netjack device?
Please help me!!
Hopes you have a good time!

(Please forgive me… My English is very very poor~~~~)

try to start up jackd with qjackctl before running ardour.
then ardour won’t complain about jack settings.

and: are you planning to use netjack with ardour?
netjack ist just an extension to the regular jack, and is normally not needed.

regards, harald

Thank you very much!
I’m trying to install qjackctl, too.
but I can’t install that.
bcoz, It requries the libqt greater than ver 4.1.
So I already installed qt-x11-opensource-src-4.3.4.tar.gz and qt4-4.2.3-8.fc7.src.rpm.
But qjackctl still require qt…
I can’t understand why like this.
(bcoz, I’m beginnist…of linux)
Please help me!
Have a good time!