Where to put VST's ??

Using Ardour 3 on Ubuntu 13.10 64 bit.
Where should I install my VST’s???
The plugin manager doesn’t let you set your own path, (stupid), so what path does Ardour look in for plugins, VST etc…

acidblue: some people use the term "VST" as a generic term for "plugin". Others use it as they should, which is a term that describes a specific set of plugins that use a particular plugin API or format. It isn't clear from your question how you are using the term.

Information on this and related questions can be found in the (incomplete by useful) reference manual, accessible from the About menu, or directly via: http://www.manual.ardour.org/working-with-plugins/getting-plugins/ (Scroll down to "How do I install plugins?") which will also describe how to set your own path so that Ardour and other software can find plugins (though this is rarely necessary).

I found this in the manual you linked:
" Linux VST (LXVST) plugins are distributed as shared library files. They are typically installed in /usr/lib/lxvst, /usr/local/lib/lxvst or a directory mentioned in your LXVST_PATH environment variable."

But I do not have a ‘usr/lib/lxvst’ or ‘usr/local/lib/lxvst’ folder, I do haver a ‘usr/lib/vst’ folder, but Ardour does not look there.
How do I tell Ardour to look in the path that i want it to?, I could not find that info in the manual.

I am trying to use Linux VST’s like those from TAL Audio line.


It is actually stated right there in the part you quoted. You need to set an environment variable LXVST_PATH to the path where you have installed the Linux VSTs before launching Ardour from the same environment.


Ok, how do I do that??

export LXVST_PATH=/my/path/to/vst ??

That doesnt work, still not getting ardour to load my plugins/vst’s

@acidblue: did you launch ardour in the same shell after export LXVST_PATH=/my/path/to/vst? The environment variable is scoped to its environment (the clue is in the name). If it works you can set it in your ~/.profile or wherever so it’s always applied for your whole login session.

ardour wont launch from the shell.
I’ve tried ardour,ardour3,ardourvst.
I get ‘command not found’

Appearently you have to use a capitol 'A", DOH!
So Ardour3 works and my plugins load fine.

Now how can i make this a more permanet solution?
I dont have a bash_profile file but I do have a .profile file can I put LXVST=/path/to/vst there?

alot of things have changed in linux, and i cant quite keep up with them since i rarely have to touch them. it used to be in ~/.profile but it says that is not read by bash if bash_profile exists.

and the format of the file is now different as far as my non scripting eyes can tell.


It used to be that ./profile was used, however in recent ubuntu versions this is no longer the case. .profile now invokes others scripts.

For session wide enviroment variables set individually for users ~/.pam_environment

/etc/environment for system wide enverimoment variables.

there are a few other places you can set variables, id suggest reading that page.

you could just create the lxvst folder e.g.

sudo mkdir /usr/lib/lxvst

and put the plugins in there - or, if you have to have them somewhere else, you could then make a link to that folder e.g.

ln -s /usr/lib/lxvst /path/to/your/plugin/folder

I have to confess some responsibility for this problem (I developed the original code which hosts linux VST plugins in Ardour) however, things have got a little (more) untidy since.
Originally, the default location was simply /usr/lib/lxvst (to distinguish it from the Windows VST folder at /usr/lib/vst) but you may find that different maintainers have modified this (depending upon your distribution - I believe kxstudio uses its own custom tweak which hard codes the folder back to /usr/lib/vst again, I don’t know - or care - what anyone else does)
One of the great strengths of linux is its configurability, but this is also its biggest failing, and a source of much frustration and unnecessary problems. (There’s a great sense of achievement to be gained from solving these kind of issues, until it becomes apparent that in most other systems, they just wouldn’t have existed in the first place)

This is how I got VST plugins to show up in Ardour 5.5.
Ardour looks for plugins in /usr/lib/lxvst If that folder does not exist, create it using: sudo mkdir /usr/lib/lxvst
Copy vst plugin to that folder
Now, this is not enough, you also have to set the environment path of your VST plugins to that location. You can do that as follows:
in the terminal: sudo gedit ~/.profile
add the following line: export LXVST_PATH=/usr/lib/lxvst
also after saving do this in terminal: source ~/.profile
Logout from your user and log back in.
Launch ardour. Open preferences. Click on VST under Plugins. Click on “Scan for plugins”
Finally open the mixer window, add a plugin to your track, and your newly added plugin should show up.

Note that Ardour only uses LXVST_PATH to initially seed the search path at first start. You should use Preferences > Plugins > VST.