Where is the cursor???? It disappeared!

I’m using Ardour 2.7.1 in Ubuntu Intrepid ibex 8.10 (kernel rt).

During registration, after 5 minutes from start, Ardour don’t show me more the red cursor.
The registration continues, but I don’t see the track that ardour’s writing.
I can’t see if the input volume is too high and, consequently adjust it.
Aren’t there any solution to resolve this bug?
In ardour 2.5 there wasn’t this problem and also after 10 , 15 minutes the window continued to advance and i was able to see the track of input sound.

Thank you in advance! (excuse me for my non-perfect english)

View a screenshot of this bug:


actually, as soon you are recording for more than 5 minutes, the end marker should move with the playhead…
how ever, does it work in a new session now?


hallo, for me looking at the screeshot, your ‘red cursor’ (playhead) is at 00:07:28:23 in the timeline, but perhaps the option ‘follow playhead’ is not turned on, as your screen is showing the part of the timeline up to less than 7 minutes.

make sure that the option in menu->transport->follow playhead is checked. perheps it helps…


do you see the small magnifier icons on the bottom left of ardour’s editor window ? (it’s next to something called “destra” on your snapshot). Click on the right hand side icon, it will zoom out to the entire session and you will see the red playhead shuttle.

This is fixed in svn, and will be in 2.8, released today or within 24 hrs.


2.8 we be an official release in the next 24 hours?


Since svn is never “released” I don’t think you can interpret it any other way.

If it is any consolation, I am seeing exactly the same problem: All new recordings have the end marker at 5 mins, as I record past this point the playhead disappears to the right and leaves me with a view of the track at the 5 min mark. The recording works and when I stop the recording the end marker appears in the right place, but it is slightly annoying that I can not see the waveforms to check for overload - as slayristan described. I did not see this problem in 2.5; I never used 2.6.1.

While the recording is under way, using the PH button next to the end marker info on the locations window did not help.

Thanks guys!

@ nowhiskey:

If I click on “follow playhead” nothing happens.

I don’t have the opportunity to move to the right the screenshot, to display the playhead.

I don’t know why…

@ thorgal

I’ve tried several times your solution before writing this post.
If I do a zoom out, I can see the playhead, but all the track become too small to see how is the level of the instantaneous input volume for adjust it by my external mixer and my soundcard.

In Ardour 2.5 I never had this problem. The playhead was always displayed, also after 20 minutes of recording.
In 2.7.1 the problem perxist.

Thank you guys.

this reminds me on a bug we had in 2.6 or so, but that was resolved…
what if you open the locations window (menu->windows->locations) - where is the start and the end marker? are they listed in the locations window and at which time are they?


does it have to do with that annoying thing I experienced 6 months ago, namely ultra short regions being displaced at the maximum time location the time variable type can allow (12hours+) ? So that when you zoom out to the whole session, you end up with squizzed regions on the left, and you cannot see the super tiny regions that are located at the end of the session. It was due to a bug of which I cannot recall the root cause. I think it happened only in jack transport mode. Anyway, I did not experience it after I upgraded ardour but it could be that you are seeing the same symptom. It took me some time to understand what was going on because these stupid extra regions were so small, I could see them. I though it was an end marker issue, which misled my discussion with Paul on IRC. So the question is: does your session have a duration of ~ 12h ?


@ nowhiskey:
the start marker is in 00:00:00:00
the end marker is in 00:05:00:00

If i try to extend the end marker, nothing happens, and the problem remains.

@ thorgal:
my session have a duration of ~1h.

It’s a mistery…

I downgraded to 2.5.


Thank you.

what happens if now, when your playhead is at about 7 minutes in the timeline, in the locations window you click the ‘use ph’ button just next to the end marker display?

(in the moment it looks like your session is ending at 5 min. and your playhead is already at 7 minutes, which is not logical at all).


Oohh Guys!!!
I resolved it!
Nowiskey, I’ve re-tried to extend the end marker before play the registration, from 00:05:00:00 to 23:00:00:00 and it function!!!

Thank you!!!

It works but I can’t set it like default.
Every time, when I open a new session, before start the recording, I must change the end marker and move it from 00:05:00:00 to (for example) 23:00:00:00 .

Anyway, it’s works and unfortunately this is a bug of versions 2.6.1 and 2.7.1 .