When I starts a new session on Ardour VST, warning windows shows saying:

"warning: your system has a limit for maximum amount of locked memory. this might cause ardour to run out of memory before your system runs out of memory.

you can view the memory limit ‘ulimit -l’, and it is normally controlled by /etc/security/limits.conf"

My laptop is a Toshiba Dynabook core duo 2 2.00Ghz 2Gb ram/ My Ubuntu is a 10.10 converted to Dream.

Im sorry but this is my first time using both Ardour and Ubuntu…

I’d like to know what does that mean?

You really should learn to use google before asking a question like this. There must be half a million hits about this on the net.

Here’s the faq about realtime (rtprio) and memory locking (memlock) : http://jackaudio.org/linux_rt_config

You need to add this to your /etc/security/limits.conf

@audio - rtprio 99
@audio - memlock unlimited
@audio - nice -19

And then add yourself to the audio group

And, as reiterated in absurdum, the @audio - nice -19 has nothing to do with realtime audio and could/should be omitted.

Peder, Im sorry for havent looked at the google as you think… or maybe I did looked at google and just found very technical stuff for people who have some experience with configuration??

Thank you for the replies but I have no idea of what u r talking?

Is there a section in this forum dealing with beginners?

or… Should I have technical knowledge before thinking about posting here?

Because if this forum is not for beginners, Im wasting my time and yours. Im sorry for that.


Actually under recent versions of ubuntu, editing the limits.conf file will not help you at all. in fact it will be “overwritten” by a file which is called audio.conf.

In a terminal you should type:

sudo gedit /etc/security/limits.d/audio.conf

Hit enter, enter your password and find the line with memlock. Delete the number and change it to read:

@audio - memlock unlimited

You can also change the rtprio line:

@audio - rtprio 99

As noted above the “nice” line can/should be omitted. You can comment it out by adding a # at the beginning of the line:

#@audio - nice 19

Save the file and reboot your machine. (if you use dreamstudio, you should already be member of the audio group)

Should work, have fun

in general, its best to point people at http://jackaudio.org/linux_rt_config or just more generally http://jackaudio.org/faq

Will do that in the future…

saresu.bass: I’m assuming you’re using Dream Studio converted from an Ubuntu install, since you’ve asked about this previously and I didn’t see any more issues on that thread, also, you’re using ArdourVST which isn’t available in the standard Ubuntu repositories. As such, I’ll go ahead and let you know that the hack that christophski has been implemented when you installed Dream Studio - the only thing that could use some tweaking is the “Memlock” option. To change this easily on a Dream Studio system, open “Realtime Audio Controls” (in the System->Administration menu), and you’ll see that memlock is one of the first options. Just set it to 100% and don’t worry about it. This warning is perfectly normal, however.

As far as posting here goes, you really can’t be blamed for asking about an Ardour warning in the Ardour forum, and as far as I’m concerned, going to the source is always the first place I look before going to something as generic as Google. Nonetheless, if I’m correct, and you’re using Dream Studio, just come over to dream.dickmacinnis.com/forum and I’ll be happy to answer any questions personally.


@saresu.bass and macinnisrr : It’s perfectly correct to ask Ardour and /or JACK related questions here, even newbie ones (and I probably should let Paul handle out any reprimands, if needed).
But when the same question pops up every other week by some new guy who hasn’t tried googling first or used this forums search function (top right of this page: Search this site) you get somewhat frustrated.

Perhaps there should be a joint JACK/Ardour “FAQ For Beginners” at the top of the forum and you wouldn’t be let in any further before correctly answering a number of questions from that :wink:

I follow the instructions as lokki has posted and it’s worked perfectly (I hope It will keep working…).

dream.dickmacinnis.com/forum is bookmarked here! such an honor for your invitation, Thank You very much for ur comprehension.

Peder, about ur misinterpretation of my Topic, I was going to ignore this but I decide to take some time to explain it to you, from novice to expert…
The several posts about this topic that Ive found, were written by people who somehow HAVE a better understanding of Linux systems than me, then… the replies were made in a way that that “Kind” of people CAN understand… on the other hand, people like me (Zero knowledge about Linux) wouldnt never understand. Can u understand?

But, its nobody’s fault that I have no knowledge about Linux.
I decided to start studying Linux technical stuffs from the documentations that Ive FINALLY!!! found YESTERDAY on internet.

I got to a conclusion, that Its good for all the community that we beginners make our efforts to learn as much as possible by ourselves before overwhelming Forums like this, with repetitive questions.

I just wanted express my gratitude for your time to answer my posts, and by the way… Im really in love with Linux system.

Sincerely Thank you all!

saresu.bass: I’m glad lokki’s instructions worked for you, but as a side-note, the Realtime Audio Controls I mentioned is simply a GUI way to do exactly what’s mentioned here (as well as enabling/disabling firewire access).

Happy recording!!