What plugins shows inline dispay in the mixer?

I use Ardour 7.3 on Ubuntu studio and that gives me a huge load of pre-installed plug-ins. I find the inline display in the mixer very useful and handy but I really don’t want to go through all plug-ins to find out what plug-ins that have this feature.

Is there a list somewhere what plug-ins supports the inline display as I would like to set up a short favourite of plug-ins that I like sound wise and that have this feature.

There is no list that I know of, but you can check all LV2 plugins that you have installed.

The following one-liner iterates over all plugins, and prints the URI and name of those that do have an inline display. Open a Terminal window and run:

for uri in `lv2ls`; do if lv2info $uri | grep -q inlinedisplay; then echo $uri; lv2info $uri | grep $'^\tName:'; fi; done

Note that this only shows LV2 plugins found by lv2ls. These are likely only system-wide installed plugins, not including Ardour’s ACE-* LV2 plugins. It also does not include Lua scripted plugins (such as ACE Inline Spectrogram, or ACE Inline Scope).

PS. the script needs lv2ls and lv2info tools which are provided by the lilv-utils package on most GNU/Linux distros

1 Like

Thank you Robin!
However I get these kind of errors:

lilv_world_load_file(): error: Error loading file `file:///home/bengt/.lv2/klangfalter-linux64/manifest.ttl’
lilv_world_load_bundle(): error: Error reading file:///home/bengt/.lv2/klangfalter-linux64/manifest.ttl

It seems there are to many / or am I wrong

If I remember correctly klangfalter is a VST, not an LV2 plugin. I seems you have incorrectly installed it to ~/.lv2.

You can suppress error messages from lv2ls like this

for uri in `lv2ls 2>/dev/null`; do if lv2info $uri | grep -q inlinedisplay; then echo $uri; lv2info $uri | grep $'^\tName:'; fi; done

Too many what?

I still get a couple of hundreds errors using that script…
There are three /// in the file path… is that correct

Yes, file:// for the protocol and authority (like http://…), which is then followed by an absolute path that starts with a slash. This makes 3. Since there is not authority (user, host name) a single slash would suffice according to RFC but it makes on difference for the case at hand.

Are there any valid plugins listed? LSP plugins have inline-displays, most x42-plugins have. Here also DrumGizmo is listed, as is Carla’s BigMeter and a few others.

Yes I get for example:
Name: ACE Expander (stereo)
With Name in red and the rest in black. But the valid ones are drowning in lost of error lines…

The problem is that lv2info, for some reason, appears to iterate over all installed lv2 files and only print the one that’s asked for.
I intentionally mangled my darc.lv2 manifest and when I run
lv2info http://lv2plug.in/plugins/eg-sampler I get

error: /usr/local/lib/lv2/darc.lv2/manifest.ttl:1:1: bad verb
lilv_world_load_file(): error: Error loading file `file:///usr/local/lib/lv2/darc.lv2/manifest.ttl’
lilv_world_load_bundle(): error: Error reading file:///usr/local/lib/lv2/darc.lv2/manifest.ttl
Name: Exampler
Class: Plugin
Has latency: no
Bundle: file:///usr/local/lib/lv2/eg-sampler.lv2/
Binary: file:///usr/local/lib/lv2/eg-sampler.lv2/sampler.so

lv2ls 2> ERR_FILE 1> /dev/null ; grep "lilv_world_load_file" ERR_FILE | sort | uniq ; rm ERR_FILE
and then move the failing ones out of way , like
mv /home/bengt/.lv2/klangfalter-linux64/ /tmp ,
before running Robin’s command again.
Chances are there’s only the one klangfalter error but it’s repeated over and over again for every lv2 you have installed.

Or suppress lv2info’s errors using the same trick as Robin’s:

for uri in `lv2ls 2>/dev/null`; do if lv2info $uri 2>/dev/null | grep -q inlinedisplay; then echo $uri; lv2info $uri 2>/dev/null | grep $'^\tName:'; fi; done
1 Like

Thank you… that seemed to work. That gave a very long list… does all in the list really have inline display?

(Massive edit)
Robin’s x42 plugins do show inline display and so do Carla’s Big Meter.

LSP v1.2.3 works here but not v1.2.6. Both are self compiled using the same recipe but I’m not sure if it’s a bug in 1.2.6 or something with my compilation.

1 Like

Followup on LSP inline:
It’s been acknowledged here and will be fixed in the next release

1 Like

Is there a correlation inline meter available?

When I run Robin’s inline display script above I get

	Name:              Stereo Phase-Correlation Meter

If that’s what you’re looking for it would be the x42-meters plugin.

I’m using Mac, and I can’t afford that price. I don’t know how to compile from source as well. Was looking for a free plugin.

Just redirect std error at the end…

for uri in lv2ls; do if lv2info $uri | grep -q inlinedisplay; then echo $uri; lv2info $uri | grep $‘^\tName:’; fi; done 2>/dev/null

Weird: I read that bit of Bourne-shell / KSH / Bash-ism, and said to myself, “that’ll never work!” I grew up believing that stdio redirections (such as your 2>/dev/null) must occur “first” (in particularly, before any if / for / while control structures). I don’t know if what I absorbed as dogma was always false, or whether the subsequent forty (OMG, really?) years of evolutionary development of the “shell” has made that dogma irrelevant.

FWIW, I verified that, in this Year of Grace 2023, having the redirection after a for loop works just fine, in the shell I use daily.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.