What is the correct way to import tracks into Ardour?

What is the correct way to import tracks into Ardour?
Do you use “Import” or “New session”, or do you have to add an empty track first and import for example an mp3 file into this track?
I tried several ways but when I get to the folder where the files are, it tells me that it is not possible to import some files, and selecting an mp3 it does not matter, where am I going wrong?

Presuming by tracks that you mean audio files. Use the import dialogue or your can drag from your file browser, see the video below. If you’re getting an error, it might be a problem with the specific file(s)

Yes I have seen the video, but when it comes to choosing the files it doesn’t let me select them, they are mp3s but it says it is not possible to select them.

I thought it was a codec problem and I installed the codecs and restarted the Raspberry but the problem doesn’t go away, can anyone give me some advice to be able to import mp3s into Ardor?

From what I can read from old posts, you need a modern copy of libsndfile.

I just imported an mp3, and it worked just fine.

1 Like

Ardour does not use libsndfile to import mp3. There is built-in support to decode mp3 (based on GitHub - lieff/minimp3: Minimalistic MP3 decoder single header library)

1 Like

Thanks guys, I’m going to Github right now to read up!

Which version of Ardour? Where did you get it from?



The Ardour version is 5

I installed the minimp3 library but how do I integrate it with Ardour?

I also installed libsndfile, but the problem is the same, is it possible that I need to compile Ardour with these libraries?

Trust @x42 over me, any day of the week :slight_smile: I just did a cursory search, and it seems my info was irrelevant. If you are using Ardour 5, get something more up-to-date.

Another cursory search through the release announcements shows Ardour 6 offering mp3 for import and export: http://ardour.org/news/6.0.html

Current is 7.5. Self-recommending, as they say.


Yes Aaronwalker ok, I installed with apt install ardor and install 5, ok I’ll try to download this most updated one!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.