What is required to successfully compile and install these LV2 plugins? (OS X 10.6.8)

Hello there,

As awful as this is, I’ve been trying for several days now to successfully compile and install these two LV2 plugins packs:

So far, I understand that a “modern” version of GCC is required to compile them. My Xcode version 3.2.6 comes with GCC 4.2.1 and GNU Make 3.81, although I don’t believe these are sufficient, as then using “make” and “sudo make install” is immediately fraught with errors and fails completely. However, using Tigerbrew, I managed to get GCC 6.5.0 and Make 4.4 (“gmake”). If I cd into one of my unzipped plugins packs, and execute “gmake”, I still get a host of errors, including this line:

../../Descriptor.h:44:17: error: lv2.h: No such file or directory

In “chatting” with software (i.e., ChatGPT, -because at least I can’t bother it with my endless (and oftentimes stupid) questions), it suggested that I might need the SDK for LV2 based on that line.

So, question(s):

  1. Is the LV2 SDK required to successfully compile and install LV2 plugins in a Mac OS X (10.6.8) environment?
  2. …And/or, why might make/gmake keep failing? -Is there an unstated minimum version GNU Make that I would need to successfully build these plugins?

I just can’t identify what the real problem is here (-yes yes, “your OS is too old, that’s the problem”, I’m sure). -But there’s gotta be a solution here for me within this old OS. (-My problem also affects LADSPA LV1 plugins packs, by the way. -Also can’t install.)

Any comments/ideas are greatly, greatly appreciated!!!
I’m learning a lot here. -But at this point I just need some direct human help… :disappointed:


Yes, you can get it from https://lv2plug.in/

1 Like

I’m having a similar issue on Linux, Kubuntu 22.04 and Ardour 8.1. Several of my LV2 plugins will not show the user interface. In particular, I’m trying to get DrumGizmo to load. I built Ardour and overall it’s working great. I’ve compiled and installed drumgizmo, and Ardour is finding it, but won’t show the GUI and is leaving it unconfigured with no kit installed. I updated LV2 to version 1.18.10. DrumGizmo is version 0.9.20. I’ve built Ardour and DrumGizmo using all the same libraries, but the GUI will not load when I double click on it in the panel. I have seen in the debug window that the parent->child is NULL, which I think is the overall problem, but I don’t know how to fix that.

The DrumGizmo GUI test works. Carla will load correctly in Ardour and display it’s GUI, though it’s a VST plugin. Carla will even load add display the drumgizmo GUI correctly, But Ardour will not, so that may be a workaround. It feels like an issue with Ardour, and I can’t track it down in my configuration, but it would seem that a lot of people would point out if their LV2 plugins stopped working across the board, so that points back to my build.

Any ideas or suggestions? Any help is appreciated.

1 Like

Just compiled the TAP ones, that required patching the makefile to work on OSX.

http://robin.linuxaudio.org/tmp/tap-lv2-osx.zip (for OSX 10.5 or later 32 and 64bit Intel)

unzip and copy the *.lv2 folders to $HOME/lv2/.

something like:

cd /tmp
curl -O http://robin.linuxaudio.org/tmp/tap-lv2-osx.zip
unzip tap-lv2-osx.zip
mkdir -p ~/.lv2
mv -vi lv2/*.lv2 ~/.lv2/
1 Like

and now http://robin.linuxaudio.org/tmp/caps-lv2-osx.zip (OSX 32/64bit Intel, 10.6 or later)

That was a bit harder, it need a patch to compile on OSX [1]. On the upside it is prepared for mac, and has a Makefile option for macOS [2].

You can install those like

cd /tmp/
curl -O http://robin.linuxaudio.org/tmp/caps-lv2-osx.zip
unzip caps-lv2-osx.zip
mkdir -p ~/.lv2/
mv -vi caps-lv2-osx/* ~/.lv2/


diff --git a/dsp/v4f_IIR2.h b/dsp/v4f_IIR2.h
index 7400e04..1c1a163 100644
--- a/dsp/v4f_IIR2.h
+++ b/dsp/v4f_IIR2.h
@@ -34,7 +34,7 @@ namespace DSP {
 #if defined(__APPLE__) || defined(__FreeBSD__)
-inline float exp10f(float f) {return __exp10f(f);}
+inline float exp10f(float f) {return expf((float)M_LN10 * f);}

[2] To compile on macOS, set the MACOS env variable to 1. e.g.

MACOS=1 CXXFLAGS="-I$HOME/tmp/lv2-stack/include" make

Completely unrelated but thank you Robin, these are actually a fun set of plugins to play with so always good to have decent compilations of them for other OSes.


1 Like

Well, they’re no-frills, generic GUI plugins. Not to everyone’s liking.

1 Like

Man, dude, Robin @x42, you are the best! :astonished:
…So I guess you are the answer to everything after all? (har har)

Thank you very, very much! -I was not at all expecting THIS much help.
-Both of your compilings worked flawlessly, and are successfully up and working with my Ardour (6.9)!

However, I will now still try to get the LV2 SDK on my machine, so perhaps when I run into other LV2 plugins I want, I might be able to compile them myself.

Someone on another(?) forum once pointed-out that by not having so much of the visuals, you are forced to pay more attention to the sounds, which I thought was a good point. Beyond that, these plugins are super light-weight, and fun to mix together in large groups to produce odd and interesting ‘filler’ tracks/noise for guitars, say. I like 'em a lot. -They help me ‘paint’ with the sound in a more carefree way.

Thank you so much again!
I really appreciate it! :grin: :+1:
(-And thank you for all the work you’ve put in to making Ardour f*%king awesome.)


1 Like

Yep, but they are tools in the toolbox, that some people can play with.


I still have the 10.6 system that we used to compile Ardour on. It has everything setup. I figured it only takes me 10 mins (caps took a bit longer) and the result may be useful to others.

Thanks for checking. I only tested it briefly in the M1 here using Ardour/Intel version.

I considered creating 64bit Intel + ARM64/AppleSilcon versions. While that may work for tap, the CAPS / C++ plugins will likely require 10.9 or later.

A walk-through for future reference:

# get and compile LV2 SDK - for OSX 10.6 use the 1.16.0 because
# - `tar` on OSX 10.6 does not support .xz
# - more recent versions need python3/meson

cd /tmp/
curl -kO http://lv2plug.in/spec/lv2-1.16.0.tar.bz2
tar xvf lv2-1.16.0.tar.bz2
cd lv2-1.16.0

# compile and install to temporary dir (you could also install it with default prefix system-wide)
./waf configure --prefix=/tmp/lv2-stack/ --no-plugins --no-coverage --copy-headers
./waf install

# Get CAPS plugin source
git clone https://github.com/moddevices/caps-lv2.git
cd caps-lv2
# patch it for OSX 10.6
sed -i.bak 's/__exp10f(f)/expf ((float)M_LN10 * f)/' dsp/v4f_IIR2.h

# and compile it (here Include dir is set to LV2 SDK from above)
MACOS=1 CXXFLAGS="-I/tmp/lv2-stack/include/" make

# Now you could run `sudo make install`
# but if you prefer to not clutter up your system...
# install the plugins to /tmp
make install DESTDIR=/tmp/caps

# and then copy to your user's LV2 folder
# (you may first have to remove the older versions there)
cp -a /tmp/caps/usr/local/lib/lv2/* ~/.lv2/

PS. the .zip i provided exclude the modgui (HTML which is not useful without a MOD, and is rather large; 20 MB). I also compiled the plugins with -arch i386 -arch x86_64 for both 32 and 64bit multi-arch, that required a bit of Makefile hacking, left as exercise to the reader.

1 Like

True, and the DSP is rather decent as well.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.