What about original Mackie Control?

Hi everybody,
I have opportunity to buy an original Mackie Control (original means the first one, no type), for 160€, which seems very cheap!
How does it work with Ardour/Ubuntu? Working OOTB? Every functions (buttons assign, time counter, display etc) are working?
thank you for your comments…

Short version is it will work as well as the new ones:)

On A2 the basics worked. On A3 I believe overall the entire system runs much better and much more works. I don’t know the limitations off hand though, sorry.


160 € seems to be a good price - I guess you should try it. If it SHOULD not work you can sell it again.

I use a similar model: Mackie MCU Pro with Ardour 3 and it runs very well. Especially with Ardour 3.5.380.


thank you for your feedbacks,
Ok, I think I’ll configure Ardour and jack for it, and bring the laptop to the shop and try.
Then I tell you

ok, I tried to configure but there are many options available: first I didn’t found ‘Mackie Control’ in the config panel, just MCU Pro, which is the latest model. Then, which connections do I have to select in the matrix (MMC etc)? mk1967: how did you get your MCU to work?

There is an instruction site: https://community.ardour.org/a3_features_mcp
I have used the version with a2jmidid.
A site of the A3 manual might be helpful also: http://manual.ardour.org/using-control-surfaces/devices-using-mackielogic-control-protocol/

By the way: when I look at your nickname I suppose that you are a German native speaker :wink: ? There is a step-by-step instruction for MCU Pro in German language also:
Hope it might help :slight_smile:


well, i bought it, as the seller told me I can turn it back if it wouldn’t work (but really hope this won’t happen since this first model doesn’t work with latest ProT. versions, so it will be dificult to sell).
It doesn’t work so bad, but:
-I have to set on Mackie => BCF2000, doesn’t work on MCU Pro, and MC isn’t listed
-in your link: http://manual.ardour.org/using-control-surfaces/devices-using-mackielogic-control-protocol/, the ‘what to do if my device isn’t listed’ link goes to 404 error
-some buttons simply doesn’t work (Automation, …)
-othe crash Ardour (F8 !?!)
-but a lot are working!
-does your time display work?

There should be a map for this device, maybe I can help…

So it seems you could at least connect MCU to Ardour? :slight_smile: Fine. I must admit that I’ve forgotten about which of the three MCU Pro protocols I had to choose to make it work. Maybe the MCU also has more than one protocol to choose (and to check out)… the MCU manual should say it.
According to this http://permalink.gmane.org/gmane.comp.audio.ardour.user/13251 there should be no remarkable difference between MCU and MCU Pro, except for USB MIDI on MCU Pro.

Yes my time display works. Are you sure that you are using Ardour 3.5.380 (the latest version)? Some Linux multimedia distributions (like AVLinux) seem to come with former Ardour 3 versions, maybe even ancient beta versions - and with Ardour3 beta my time display did not work.

As for the buttons: it depends from configuration if they do work or not. You can go to a menu which is called (sorry, I only know the German name) “Bearbeiten > Globale Einstellungen > Eingabegeräte/Controller” and here to “Control protocol options > Function keys”. There you can find a large table with MCU’s function keys where you can find out if they are already programmed (my system shows three configuration sets: “Default”, “BCF2000” and “SSC Nucleus”). If not, left-click on the dots: dropdown menus will open an you can choose a lot of ardour commands. (There are some small screenshots in http://wiki.ubuntuusers.de/ardour#Ardour-3-und-MIDI - and the Function keys window with the configuration table can be seen here: http://media.cdn.ubuntu-de.org/wiki/attachments/56/07/030_-_Bildschirmfoto_vom_2014-01-15_093011.png .)

I’ve found another site right here in this forum which deals with MCU and Ardour:
Also this might help:


Well, it’s usable, but I would like to get a few more features for such a big device…
-You have 3 MCU protocols in your list? I have just 2: MCU pro and MCU pro extended. But I have to use BCF2000.
-Yes, I use 3.5.380, with KX Studio. I can try to configure some keys from controller, but there is no time option…
-I checked your links, but didn’t found any useful information.
-Yes, I speak a bit of german :wink:
but thank you for your help anyway

I remember there was some map file from users, but I can’t find them anymore. I should try to write one, also for the community, is it so complicated? Any suggestion how to start?

You don’t want a MIDI binding map for an MCU device. You want a device info file and/or a device profile file. You can find examples in the Ardour.org bundles under the “mcp” folder inside the installed package. You can create device profiles from within Ardour (binding each possible Mackie Control Protocol button to a given Ardour function).

ok, I made a file mixing MCU pro options and BCF2000:

?xml version=“1.0” encoding=“UTF-8”?>
Name value=“Mackie Control”/>
Strips value=“8”/>
MasterFader value=“yes”/>
TimecodeDisplay value=“yes”/>
TwoCharacterDisplay value=“yes”/>
Extenders value=“0”/>
GlobalControls value=“yes”/>
JogWheel value=“yes”/>
TouchSenseFaders value=“yes”/>
NoHandShake value=“yes”/>
HasMeters value=“yes”/>

(I removed first < because it doesn’t display)
I call the device just Mackie Control, as this early model isn’t yet ‘universal’…
I didn’t tried everything, but time display is ok, meter also (signal led and basic meter on display) , and basic functions. Maybe you have a list of options for .device xml files to go further?

It isn’t documented except at the source code level and via other examples. But you’ve got most or all of what you need there. The profile file is different and should probably be created with ardour itself.

will you add the mc.device file to next ardour versions? do I have to open a report?
and I’ll check the profile, and try to find out why ardour crash with some keys…

already added.

(how to subscribe to a topic, get mail on new post?)

no idea. i hate web forums myself, so i try to avoid thinking about this. also our forum software is very limited in its functionality. maybe someone else has a clue.

I don’t believe you can with this software as it is right now.

Would require an extension IIRC.