weird pitch change of recorded audio on Mixbus 2.0.7

First of all pardon me if this isn’t the right place to talk about this issue

Today i’ve been working on two different sessions @ 48KHz and have the same issue on both of them, after some recording (3 tracks) and handling the regions “suddenly all recorded audio changes its pitch”, at least what i didn’t bounce before that switch, its very weird and it affects from that point on and wont change back even after restarting Ardour.

This has never happened to me before so i don’t know if its a bug or some other thing related, this is my setup and how it happened, i’ve changed the sample rate today and i suspect that could be at some point the reason of all this.

Phenom II 955 on Asus MB
8GB Ram @ 1600MHz
RME HDSP 9652 conected via ADAT only to:
Focusrite Saffire Pro 40

OS: AVLinux 5.0.3
DAW: Mixbus 2.0.7
QjackCtl: 0.3.8
Jackd: jackd1 1:0.121.3avlinux-1

So, the Saffire Pro 40 is working on Standalone mode as a ADAT preamp, and it can be programmed only through Windows (if there’s a way to do it on Linux please tell me), so to change the Sample Rate from 44.1KHz to 48KHz i had to do it on Windows.

So back at AVLinux 5.0.3 i switched the HDSP to 48KHz also, then in Jack the same and started it, it all works fine (today i’m recording a friend for a video track so… 48KHz it is), so in the middle of the workflow, sounds an almost imperceptible click then all audio shifts its pitch a little so it all sounds weird and out of tune, minutes later just out of curiosity i oppened a .wav file @ 44.1KHz and i actually sounds cracky and out of tune also so thats why my guess is this is a sample rate issue, but… why is this happening? all hardware is working at 48KHz and the recording is at that sample rate, can any body help?.

I had a quick look at the Saffire’s user guide…

What is the “Sync Source” of the Saffire set to? I recommend setting it to “ADAT”. That way it should follow the sample rate you set the HDSP/Jack to (given that also the Saffire’s ADAT input is connected to the HDSP).

Remember that only one device can be the master and all others must be slaved. That means in your case you also could do it the other way around - setting the Saffire’s sync to “intern” and the HDSP to “Auto Sync” and changing the “Pref. Sync Ref” to the port you have the Saffire connected to. This would only be a bit inconvenient if you want to switch to a different sample rate.

The Saffire doesn´t seem to be a good slave… after all that i switched back to 44.1KHz and the clock kept dropping like crazy, so i ended setting it as master at 44.1KHz and the HDSP in Autosync so it is slave, the system went back to stable 44.1KHz, so keeping that in mind i´ll be back at the studio tomorrow and try it the same way on 48KHz and see if it is the cause or not of that strange pitch change…

I would really like to keep the Saffire as slave and have it switch automatically (i really wish i could switch the sample rate without rebooting into win) but the mixer in Win leads you to pre configurate the clock to a specific sample rate and it lets you switch it to master or slave but having the sample rate already fixed to that pre conf., after all its designed to be running as an interface on Win or Mac so they think you would always have the mixer at hand, its what i´ve seen, but will also check it out tomorrow again, that bug left me embarrassed to my “all mac” friend and band mate today heh… but hey! Logic hanged up on him like crazy also today so we´re even!

You should check the user list for help on this one… There maybe a mixer app that can be used for the device or it may be in the svn version … (I’m assuming you have tried to fire up ffado-mixer :))

I use the older saffire pro10io and I can change the sample rate by changing stopping jack and changing the rate setting and then restarting jack… although it usually takes a few attempts at starting jack to get it working… .(frustrating but it works really nicely once it’s up ) This is on a different chipset though so may be different.

@allank: well i’ve been using the pro 40 as a preamp so i’ve never used it over ffado, i know support is experimental and i actually read a a few hours ago on their forum there have been some improvements which is great, it is a good interface, however im using the pro 40 on “standalone” mode so it sticks to a fixed sample rate programmed on its mixer in Windows and flashed to the unit so it powers on with that sample rate, for this to work for me on Linux i would have to be able to “flash that option to the unit” and that goes far far very far beyond my programming skills and beyond the interest of the ffado project i think… eventually i’ll have to change this unit for a Octopre mkii that can handle sample rate on its own or via switch, maybe an octane would be good for that too (and would happily say goodbye to that Windows partition…)

@the C.L.A.: as you suggested, i set the pro 40 as slave to adat sync and the hdsp to master, it’s been great on 44.1KHz, but now i switched back to 48KHz to test the system and its crazy, i recorded a guitar, all fine but then during playback (and only during playback) the ADAT clock on the pro 40 starts to drop the lock over and over again, clicks everytime it does but Jack is not reporting any issue at all its all fine no xruns.

Now i started mixbus and i get this from the welcome page:

[ERROR]: AudioSetup value for timeout is missing data
[ERROR]: AudioSetup value for dither is missing data
[ERROR]: AudioSetup value for inputdevice is missing data
[ERROR]: AudioSetup value for outputdevice is missing data

rebooted… and it’s still there, changed Jack options above mentioned to: timeout 200, dither shaped, input and output devices are now hw:1,0 which is hdsp but theres still the crackling and lock dropping.

will change the pro 40 to master on 48KHz and will be back to test… then ill report back


I changed the output ADAT cable for another one, better construction i had for my home theater and its working ok, no more crackling nor lock dropping (even changed the Pro 40 to slave again and works perfect), however the errors in mixbus are still appearing as soon as i launch it, does anyone knows whats that about? it began when i started jack “from” mixbus and from that on it appears even if i start jack through qjackctl.

Does anyone know if the faulty ADAT cable could have done the pitch error appear? is it possible? it has not happened again ever since but i suspect Ardour has something to do with it, the recorded data was playing fine, then “as it was buffered as recorded and it was actually written or saved then the pitch changed” now, i don’t know if Ardour keeps a buffer for recorded data for then bounce it or just store it on the interchange folder, so something in that process would change the file… if anyone can explain a little that process would be great, or if that happened to anyone before since i’m not sure thats a fault of my system or something in Ardour.