Weird beep when using guitar effects

Hi there,

I’m hearing a weird “beep” when connecting my guitar to the PC and using effects, I got this problem using ardour as DAW and Guitarix or Neural Amp Modeler (by Mike Oliphant).

The beep doesn’t come regularly, but at random times, it seems like there is some sort of electronic clock signal which “clicks” at certain times…
I recorded the “beep” and uploaded it online, here it is.

Another (very) weird behaviour I noticed when using some effects of Neural Amp Modeler is that it makes a weird humming sound when pressing a key on my keyboard (yes, the one I’m using to write this question), as if the PC keyboard signal interferes with the audio signal (…?)

I’m using:

  • AVLinux Operative System (kernel: 6.0.0-10.1-liquorix-amd64)
  • Ardour 7.2.123 as DAW
  • Guitarix 0.44.1 as effects processor
  • Neural Amp Modeler (by Mike Oliphant) as effects processor
  • Jack audio server with QJackCtl user interface (preinstalled in the OS)
  • M-AUDIO MTrack II Plus at which I connect my instruments

Can anyone help me understand this weird situation? Because I’m totally lost

You use MTrack II Plus both for recording instruments, and for playing back the audio? No second device for playback only?

Are you using a high quality USB cable ? Maybe reroute the cable away from the pc and other electronics as much as possible. Maybe Cell phone interefrence picked up by guitar pickups or cable?

A while ago I noticed something similar when I tried to use the GxBoss DS1 plugin from Guitarix. Once the track is recorded, a beeping sometimes shows up and most of the times it does not. In rare cases the beep even stays permanent and it will go away when bypassing this plugin. So I think it’s a software bug in the plugin and I opened an issue for this (Strange audio artifacts in GxBoss DS1 LV2 plugin in Ardour · Issue #119 · brummer10/guitarix · GitHub).
My workaround so far: just don’t use those particular plugins :slight_smile:

When doing vocal recording using a Focusrite Scarlett 2i2, I sometimes see a very narrow peak in the spectrum (LSP Parametric Equalizer) at exactly 20kHz (I’m recording with 48 or 96kHz).
No idea what’s causing this one, I never saw it with the Behringer UPhoria. So most likely a hardware glitch in the audio interface?
My workaround for this one: it’s not audible anyway, but I usually just add a sharp Resonance cut in the LSP Equalizer and turn it down until the peak is gone when looking at the Post-eq spectrum.

In your case: try to play around with a pre-recorded region.
If you play back the same region multiple times and the beep occurs only randomly, it could be just a software bug somewhere.
On the other hand, if the issue is permanent and you also can see it in the spectrum of your region without any plugins involved, then it smells like some hardware or shielding issue, maybe even a wonky power supply from the PC mainboard to the interface.
In this case you could only try other (available) hardware and see if something improves: other PC/laptop, use a different USB port, go through an USB hub, other USB cable (with/without a ferrite bead), other audio interface, other room…

HTH.

1 Like

Exactly. I just connect my headphones/monitors to my MTrack II Plus

I’m using the cable I found in the package of my audio interface. Actually it seems a USB type B to standard USB cable and is also not so long… So it is hard to do such a test

Thank you for the insight! I maybe could give a try using a live version of AV-Linux in my laptop with the same audio interface connected, see if the issue is still there and share the results

Here I am again, I tried using a live version of AV-Linux on my laptop and still got the same result… So it doesn’t seem to be related to my PC. I also tried to keep my phone further away but nothing changed.
I also noticed that the weird “beep” seems related to the saturation/gain/humming background noise of effects… The more the saturation/gain/humming background noise, the more frequent the “beeps”.

… Any other ideas to solve this?

As tedious as it is, you may have to break the signal path down into small pieces to check.
By that I mean record your guitar for a while with no effect plugins loaded, to check that the guitar->interface->ardour->interface->headphones path does or does not have the problem by itself.

If it does then it becomes a little trickier, so maybe we can come back to that if it occurs.

If not, then add just one plugin and see if the problem occurs. Remove that plugin and try a different plugin, keeping note which if any have the problem.

If none of the plugins have the problem by themself, then begin adding multiple plugins in your normal order to check if some kind of interaction between the plugins is causing the problem.

Hi there, I’ve done my homeworks and it turns out that the problem occurs even if I directly connect the input of the audio interface where the guitar is connected to the outputs of the audio interface itself, without including Ardour or any plugin in between.
So it seems that the problem is in the audio interface/cables/headphones or speaker… But regarding the latest ones I have just verified that the problem occurs with both the speakers and the headphones, so I would exclude them.
Any other idea on how to proceed? Thanks a lot in advance

https://www.amazon.com/Tripp-Lite-Hi-Speed-Ferrite-U023-003/dp/B008VOPCGY

It could be another electronic device in the vicinity causing this. The cable may help, but I am uncertain. I have to use this type of USB with my interface. The ferrite chokes help reduce interference from other devices.

With audio still tranferred to the computer and back, or just using the analog monitoring path of the interface?

That interface is only powered by the computer, no option for an external power supply. If there is no audio software needed, just the computer connected to power and enable the interface, do you have another computer to try, or a friend who would let you connect your interface to your friend’s computer to see if the noise may be coming through the power connection from your computer? If the power supplied by the computer has a large amount of high frequency electrical noise it could cause that type of interference.

Hi, thanks for the help!
I’m uncertain too, but maybe can try it, just for the sake of curiosity :sweat_smile:

Hi and thanks again!
The audio signal flow is Guitar > Audio Interface Input (combo) > Jack Audio Server (QjackCtl U.I.) > Audio Interface Output (Speakers/Headphones).
I used QjackCtl to route the input of the audio interface with the guitar directly to the output of the audio interface (Speakers/Headphones), without Ardour or any other plugin in the middle.
Also the interface is set to make the 100% of the signal go into the computer (thus handled by Jack) and than out through speakers/headphones.

Unfortunately I already tried to connect the audio interface to my laptop using a live version of AV-Linux but still got the evil “beep”… :pensive: I described the test a few replies above.

Do you hear the noise if you use the analog monitoring of the interface (turn the knob all the way to “Direct” instead of “USB”)?

What buffer setting are you using with jackd? That noise sounds more like electrical interference than problems keeping up with the buffer pointers at really low latency, but if you have a small buffer setting it may be worth trying 1024 frames/period and 3 periods/buffer. That should be an easy load and so would tend to eliminate excessive driver latency as the problem.

1 Like