Waves H Reverb crashes Ardour

I’m trying to get Waves H-Reverb to work with Ardour on OS X 10.13.3 High Sierra. Ardour crashes every time I try to insert H-Reverb as a plug-in.

I’ve scanned and rescanned and emptied caches and uninstalled and then re-installed H-Reverb and shut down and restarted my MacBook Pro and repaired permissions etc etc.

If anyone can help shed light on this I’d greatly appreciate that.

P.S. I tried to copy in the crash report but was informed by the Ardour forum that my post has characters not accepted, even when I tried to embed the whole report within html formatting as I am not informed as to what characters are the problem. Not a good few days on the friggin’ IT front here.

Thanks in advance!

It’s not the only plugin that can crash Ardour (the same is true of all plugin hosts).

Without the cooperation of the plugin developers, it is almost impossible to diagnose the reasons for the crash.

Understood. Incidentally, the behavior is the same for Mixbus and Mixbus 32C. However, another Mixbus user has no problems running H-Reverb on 10.13.3.