Waveform visualization problem

Hi everybody.

I’ve installed Ardour a few weeks ago and i’m getting used to it but i have a serious problem or bug… I can’t view the waveform, so i can’t edit… i’m totally blind when recording… (I just can see a few red lines, even when i zoom it…)
Can anybody give me a hint about the problem? A program bug, a damaged lib… something…


its almost impossible to begin helping a problem like this without a screenshot. please take one and post it online somewhere, then put a link to it here. otherwise, show up on IRC (info on the support page) and we can perhaps talk real-time about what is going on.

I’m having the same problem: ardour 0.99.33 installation seems to work ok for the most part, but the waveform fields as well as the Meter/Tempo/Location Markers fields are all totally black. I don’t have any space online to post images, but I can email a screenshot if that will help.

Send a screenshot to naptastic [at] comcast [dot] net and I’ll link it in this thread.

Using ardour 0.99.3 on Gentoo, having the same problem. Instead of submitting a screenshot, I’ll try to describe the problem: Compared to the screenshot on the front page of the Ardour web site, some areas have a black background instead of the various shades of grey. Affected areas are the rows showing markers and ranges (meter, tempo, location markers, range markers, loop/punch range, but not the rows showing time BBT,SMPTE or H:M:S.sss) as well as the track display rows (waveform, automation). If I change display options (for instance, switch visibility of one of these rows on or off) I see the correct color of these rows for a short moment, but only that part that was covered by the menu. After a short period of time (varying about 1 second) these regions revert to black. Possibly same problem shows up while playing (follow play head = on) whenever the display jumps to the next position: white background and a litte bit of waveform is visible for a very short time, then being redrawn again in ‘black on black’.

My vague conclusion: either the redraw code (in conjunction with GTK?) does something questionnable, or it is solvable by tweaking the GTK Theme settings (mine were set by IceWM, I never tweaked them by hand).

Hope that helps.

Hello all! I am new to this forum.
I just realized that my problem is most probably not Ardour specific, that it is system wide, but I can’t find any other forum suitable for discussing this kind of question.

I had no problem installing and running JACK and Ardour, my distro is SUSE 10.1. Ardour is v. 0.99.3-0.pm.1
The problem concerns waveform visualisation so I post here under this subject.

I can see the waveform quite well, no prob here. Problem starts when I start playing the sound. It seems that waveform visualisation runs approximately two times faster than actual sound. So immediatelly after I start playing there is no relation between what I see and what I hear. This makes visual editing not possible.
Whenever I place the cursor, it starts playing exactly in this place. But since the speed of cursor is way faster than actual playing, I am totally lost in no time. It seems that movements of the cursor and sounds are two completely unrelated stories.

I have two different computers and it is exactly the same problem on both.
Both computers are equipped with Soundblaster Live! cards.
I tried to use files with sampling frequency 44100 HZ and 48000 Hz, all the same.

Only lately when trying to narrow down the problem I discovered that when I use Audacity wavefile editor, which does not require JACK, the problem is still the same.

I will appreciate any input that might put me into the right direction.

Yours Virtually, Zbigniew A. Oslo, Norway

Hello fellow gentooer,

I had some visualisation problems with first builds I made of ardour, they went gone once I upgraded gtk stuff. If you look at ardour’s ebuild you see depndencies on gtk+ and gtkmm, I seem to remember that upgrading gtkmm solved my problems. Anyway, on my two gentoos (running ardour 0.99.3 and ardour2 smoothly) these packages versions are:

gtk+ installed: 2.8.20-r1 (last available 2.10.6, argh! time to emerge)
gtkmm installed: 2.8.3

Try to reemerge this thingies and you’ll most probably end up with a working setup :^)
… uh, by the way, if you haven’t seen it I’d like to point you to http://proaudio.tuxfamily.org/wiki/index.php?title=Main_Page , this is evermind’s proaudio overlay and there you’ll find more updated ebuilds for almost everything in the audio world (includying an ebuild for ardour2 which dowloads directly sources from svn)

good emerge!

oh yes The waveforms disappear!. I can see the waveforms until I split them (I push “s” in the desire place to split). when I do this the waveform automatically disappear, I can still play the audio, but cant see anything. I would really appreciate any help.
/ Eduardo.-