WASAPI option has too much latency

Hello everyone,

The installer comes with the option to install the WASAPI driver for Ardour. From what I understand All audio processing is done over portaudio.
I’ve tried other DAWS that use WASAPI ( shared mode ) directly and from the midi controller input to audio output it feels real time, but not in Ardour.

Is there something that can be configured for portaudio or are we at the mercy of the portaudio folks? I also wonder if there are any other windows users that tried WASAPI with success?

I tried FlexAsio as an alternative but from what I understand they use portaudio as well and I can’t get WASAPI in shared mode to perform fast either.


Is there a reason to not use either a dedicated ASIO driver for whatever your Audio device you have or the generic ASIO4all driver? I do a bit of Ardour use on Win10 (but 90% on Linux) but I’ve never used WASAPI since ASIO works so well.

Because ASIO forces exclusive mode which is not what I want. With WASAPI shared mode I can get full audio from any app and still retain that “realtime” feel when I hit keys on my midi controller. It just doesn’t in Ardour for some reason.

ASIO works fine, it’s just not ideal for me in terms of how i use my system.

have you tried FlexASIO?

My brother Nils, I literally mentioned FlexAsio

KoordASIO, updated flexASIO, gives you the option of Shared or Exclusive…

The problem isn’t shared or exclusive options the problem is there is too much latency with any wasapi driver. FlexASIO has shared/exclusive options too.

I don’t know if this will work for you, and I have not personally tried this software, but it is listed as compatible with ASIO devices, so perhaps you could switch to the ASIO driver and use this virtual mixer to hear multiple sound sources at once. Case Study #3 in the user manual seems to touch upon your setup if I understand things correctly.

I am not familiar with how WASAPI works and can offer no suggestions for reducing its latency, unfortunately.

Thanks for the suggestion. I’ve personally been avoiding voicemeeter because I think it overcomplicates my audio setup. For now ill just stick to an alternative DAW ( unfortunately not open source ). I guess we are just at the mercy of the PortAudio people, or something is off about my system. But I do wonder if anyone else on windows had success.
Nothing feels like sub 100ms latency with any option.
Saw an issue on FlexASIO where they did some benchmarks but I can’t replicate those low latency targets. Sucks, hope my issue is resolved in the near future.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.