Want to share my experience with RME Multiface + Expresscard (no cardbus)

Since there are not many expresscard users with linux running i want to share my experience while trying to get this combination to run under a Intel machine with AMD64 architecture Linux box.
My machine is a Intel Notebook (called Nexoc Osiris, that same model like a compal barebone). It has a C2D CPU, 4 Gig RAM, and a Nvidia 8600GT Graphics with 512MB DDR3 memory.

I rent a expresscard from a dealer to figure out if it works with linux or not. the first time it worked after switching the computer on, firmware was loaded and everythink runs well (i configured everything before i got the card, i am running the PCI version since years without problems).
After testing for hours i shut down the machine. At the next day i wanted to continue but did not get the firmware loading, i always got the message “no multiface connected”. From now on i tested for many days and it never worked anymore, sometimes the notebook becomes extremly unstable when the card was plugged in up to the fact that the BIOS !! doesn’t came up after switching on the computer.
When the computer comes up the device “Xinix Multimedia controller …” appears under lspci sometimes yes, sometimes not.
So i assumed a hardware issue and replaced the Expresscard with a new one (the dealer sends it back to RME)
While testing with the new expresscard i made the same experience than before - extremely unstable behavior of the whole hardware.

Afterthat i assumed that the computer is broken so i replaced it by the same model, this was possible because my girlfriend owns the exactly the same model. My experience was the same, i never got the expresscard / Multiface running.

At the end a friend provided me the old PCMCIA cardbus version for testing but my computer has not PCMCIA slot so i bought a PCMCIA->Expresscard Adapter.

–> The combination runs well on my machine now from the first try on !!!

I still have some issues with xruns whenever i resize windows on my desktop so this seems to be graphicard issue. Anyway, this is strange since my old Athlon64 box with just 1 Gig RAM runs very very well with the same driver, i can open windows and even with opengl applications which does not cause any xruns. This is an open issue but my machine runs now with the old cardbus verson in combination with the adapter.


You might have hit an issue with the first revision of the express card adaptors. They were faulty and should be exchanged, check out


The PCI, Cardbus, PCIe and Expresscard interfaces for the HDSP io boxes work nice and flawless in general. There’s an even lower latency with PCIe :slight_smile: