VST3 from old to new workstation is missing


I’m using Ardour6.9 on W10 on my old laptop, now I’m moving to a different machine, installed ardour on it (same installation file 6.9.0)

created the folder:

C:\Program Files\Common Files\VST3

and copied there my file as I did on the old laptop, here I stop because there’s no way to load it, here below the screenshots of VST options on old and new machine[Processing:

Thanks for your time.

Perhaps 32/64bit mismatch?

This is an old style VST3 plugin that is not in a multi-arch bundle, so from the screenshot is not obvious if it is a 32 or 64 bit VST plugin.

Which version of Ardour do you use (Menu > Help > About)? 32 or 64bit?
64bit Ardour can only load 64bit VSTs.

Yep I forgot to mention, 64bits for everything, from OS to VST file.


I got the same error message for one VST3 plugin I use from White Elephant Audio called MONSTR (Stereo Imager) on Linux in Ardour 6.9.0 (flatpak). I still use Ardour 6.7.0. and this is not an issue. This screenshot below shows that I saved plugin in two locations and gets the same error message. I use Bertom Denoiser (a gate noise reduction plugin) and it works fine even though it is in the same folder as my VST3 plugins.

Keep in mind the plugin that gives an error message is in 64-bit so it should work in the latest version of Ardour.

So the plugin was dynamically linked and depends on external system-wide libraries.

here: libcurl-gnutls.so which is not present on your system – perhaps because libcurl-nss or libcurl-openssl package is installed instead.

Plugins should be statically linked for that purpose. Say you have yet another plugin that relies on libcurl-openssl.so then the two plugins will conflict.

There is nothing we can do about this, best contact the plugin vendor and ask them to compile the plugin in a way that does not rely on external libraries.

Gotcha Robin @x42. Thank you for the quick response.

@x42 I have a separate question relate to this issue.

After reading your quote in this forum below from a few months ago Called “Ardour as a Snap or flatpak”, you mentioned this:

(Ardour as Snap or Flatpak)
“The problem with either is that plugins also need to be inside the flatpak or snap. So 3rd party plugins cannot be used [1].”

I am using Ardour 6.9.0 which is available as a flatpak in my software manager for download (I am using Linux Mint). It seems to me that 3rd party plugins work in it as VST3 plugins like my Denoiser plugin as shown above. I just want to make sure if your quote applies to the flatpak of Ardour I am using.

If the plugin is self-contained (no external dependencies) and installed in $HOME/.vst3 or $HOME/.lv2 it should indeed work.

As for other plugins esp system-wide installed ones, things are more complicated. There is ongoing work to support those. Particularly a shared runtime env is required:

Proposal for audio plugins - Flathub Discourse and a custom location for VST3: Missing the concept of VST3_PATH environment · Issue #67 · steinbergmedia/vst3sdk · GitHub

1 Like

Gotcha. Thanks for the explanation. Like you mentioned, perhaps when an external library is not in use when I am using 6.7.0 for those plugins.

My problem is solved. I contacted the vendor and after they updated the plugin, it works again in Linux. Thanks for the help @x42

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.